Closed Bug 771174 Opened 7 years ago Closed 4 years ago

Provide an option for how to handle links when Firefox is the default browser

Categories

(Firefox for Metro Graveyard :: General, defect)

x86_64
Windows 8.1
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: bbondy, Unassigned)

References

Details

(Whiteboard: [feature] p=0)

IE10 allows users to control how link invocation works, we should allow the same type of control for when Firefox is the default browser.

- The Desktop options UI should present a new drop down box only in Windows 8 for "Choose how to open links".  Possible options are:  Let Firefox decide, Always in Desktop Firefox, and Always in Metro Firefox.
- The UI should display disabled when Firefox is not the default browser in Windows 8.
- The UI should not be visible when OS < Windows 8

Since this is not a per Firefox-profile setting, and since the CommandExecuteHandler is the thing to handle this option, we should store this setting in the HKCU registry.

As part of this task we should also honor this option in the code for the CommandExecuteHandler.
Blocks: 771176
Jim do you agree that this should be set in HKCU? We can't store it in a preference because the CEH can't read preferences.

I could see some users not wanting to ever use the metro browser at all, so I'd like to make sure we get this done.
(In reply to Brian R. Bondy [:bbondy] from comment #1)
> Jim do you agree that this should be set in HKCU? We can't store it in a
> preference because the CEH can't read preferences.
> 
> I could see some users not wanting to ever use the metro browser at all, so
> I'd like to make sure we get this done.

HKCU seems fine. 

(In reply to Brian R. Bondy [:bbondy] from comment #0)
> - The Desktop options UI should present a new drop down box only in Windows
> 8 for "Choose how to open links".  Possible options are:  Let Firefox
> decide, Always in Desktop Firefox, and Always in Metro Firefox.

I don't understand the first option of letting firefox decide, seems like it is really Windows that's doing the decision making.
IE has the equivalent options. It basically means that if you are in metro mode, you stay in metro mode. If you are in desktop mode you stay in desktop mode.  The CEH controls it.
Assignee: netzen → nobody
Actually this involves the CEH and registry more than front end code, so changing cc to jimm
Product: Firefox → Firefox for Metro
Version: unspecified → Trunk
Summary: Provide an option for how to handle links when Firefox is the default browser → Private browsing in metro firefox
Whiteboard: [metro-mvp?]
No longer blocks: 771176
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Whiteboard: [metro-mvp?]
Duplicate of bug: 771188
Jim: I think this was closed by accident and title changed by accident
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: Private browsing in metro firefox → Provide an option for how to handle links when Firefox is the default browser
Duplicate of this bug: 858815
wow - 

Provide an option for how to handle links when Firefox is the default browser → Private browsing in metro firefox

Huh? Not sure what happened there. Sorry about that.
Status: REOPENED → NEW
No longer blocks: metrov2planning
Whiteboard: [feature]
Keywords: uiwanted
Whiteboard: [feature] → [feature] p=0
Depends on: 967719
Removing 'uiwanted' keyword as UX dependency bug has been created which blocks bug 965842.
Keywords: uiwanted
Bug 771174.

(In reply to Marco Mucci [:MarcoM] from comment #9)
> Removing 'uiwanted' keyword as UX dependency bug has been created which
> blocks bug 965842.
OS: Windows 8 Metro → Windows 8.1
Status: NEW → RESOLVED
Closed: 7 years ago4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.