crash in g_idle_dispatch on shutdown using Ubuntu and EDS Contacts Integration addon

RESOLVED INVALID

Status

Thunderbird
General
--
critical
RESOLVED INVALID
6 years ago
3 years ago

People

(Reporter: wsmwk, Assigned: Chris Coulson)

Tracking

({crash})

Trunk
x86
Linux
crash
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [addon:edsintegration], crash signature)

(Reporter)

Description

6 years ago
#31 crash for thunderbird 13.0.1
most but not all crashes mention closing thunderbird.

This bug was filed from the Socorro interface and is 
report bp-3f30b346-c196-49d2-8ca8-d12222120628 .
============================================================= 
0.0.0 Linux 3.2.0-25-generic-pae #40-Ubuntu SMP Wed May 23 22:11:24 UTC 2012 i686
0		@0xad5aa830	
1	libglib-2.0.so.0.3200.3	g_idle_dispatch	gmain.c:4657
2	libglib-2.0.so.0.3200.3	g_main_context_dispatch	gmain.c:2539
3	libglib-2.0.so.0.3200.3	g_main_context_iterate	gmain.c:3146
4	libglib-2.0.so.0.3200.3	g_main_context_iteration	gmain.c:3207
5	libxul.so	nsAppShell::ProcessNextNativeEvent	nsAppShell.cpp:162
6	libxul.so	nsBaseAppShell::DoProcessNextNativeEvent	nsBaseAppShell.cpp:171
7	libxul.so	nsBaseAppShell::OnProcessNextEvent	nsBaseAppShell.cpp:324
8	libxul.so	nsThread::ProcessNextEvent	nsThread.cpp:619
9	libxul.so	NS_ProcessPendingEvents_P	nsThreadUtils.cpp:195
10	libxul.so	mozilla::ShutdownXPCOM	nsXPComInit.cpp:622
11	libxul.so	ScopedXPCOMStartup::~ScopedXPCOMStartup	nsAppRunner.cpp:1124
12	libxul.so	XRE_main	nsAppRunner.cpp:3731
13	thunderbird-bin	main	nsMailApp.cpp:144
(Reporter)

Updated

6 years ago
Blocks: 779524
(Reporter)

Comment 1

6 years ago
#24 crash for TB14
I guess some of the crashes are caused by the fact that one (or more) class is unrefed before it should be.
(Assignee)

Comment 3

6 years ago
We discussed this a bit on IRC a few weeks ago. This is the sort of trace I'd expect to see if a library were being unloaded whilst it had events pending on the event loop. It turned out that an addon we're shipping does unload libraries on shutdown (it uses ctypes), and it's entirely possible that this is done whilst there are still events pending.

I've pushed an update of this addon to Ubuntu 12.10 users to stop unloading libraries on shutdown, and we're no longer seeing these types of crashes from those users....
(Assignee)

Updated

6 years ago
Duplicate of this bug: 779524
(Reporter)

Comment 5

6 years ago
Thanks Chris. Which addon?
(Reporter)

Comment 6

6 years ago
Chris?

(suspect no longer topcrash)
Keywords: topcrash → topcrash-
(Reporter)

Comment 7

6 years ago
which addon?

(In reply to Chris Coulson from comment #3)
> I've pushed an update of this addon to Ubuntu 12.10 users to stop unloading
> libraries on shutdown, and we're no longer seeing these types of crashes
> from those users....

Should people still be crashing if using these? ...
globalmenu@ubuntu.com	3.5.4
edsintegration@mozilla.com	0.3.11
messagingmenu@mozilla.com	0.9.3


#2 and #1 (bug 779524) crash for linux TB16
Flags: needinfo?(chrisccoulson)
(Assignee)

Comment 8

6 years ago
Hi, sorry. Yes, the edsintegration addon is the one that I suspect causes it. Are there any of these crashes from version 0.5 of the addon?
Flags: needinfo?(chrisccoulson)
(Reporter)

Comment 9

6 years ago
(In reply to Chris Coulson from comment #8)
> Are there any of these crashes from version 0.5 of the addon?

unknown. perhaps a linux fan would have time to check?
Summary: crash in g_idle_dispatch → crash in g_idle_dispatch using Ubuntu
Whiteboard: [addon:edsintegration]

Comment 10

6 years ago
Hi.

My first thoughts are:

1) Why Thunderbird 13? Stable version is 16 nowadays. Is there a reason for using older version?
2) Would You be willing to upgrade to version 16? Is there one in Ubuntu repositories?
3) Would You be willing to test the trunk build? This is a PCLinuxOS version of how-to try it out without a big risk http://sparewotw.wordpress.com/2012/10/10/testing-mozilla-thunderbird-central-daily-19-safely-on-pclinuxos-2012-x/ but I am sure if You are willing to dig around the system a bit You can apply the howto to ubuntu.
4) Have You tried:

a) Thunderbird in safe mode? (thunderbird --safe-mode from terminal)
b) Resetting the panels and toolbars to default? (available from safe-mode menu)
c) Disabling all add-ons (also in safe-mode menu) and then if crashes stop enabling one at a time to see which causes the issues
d) Creating fresh profile in Thunderbird to see if it was something in Your profile that caused issues
e) Creating new user account on Your system to see if it was system-wide or user oriented

Let's see what this causes...

May the source be with You.

Andy
(Reporter)

Comment 11

5 years ago
(In reply to Chris Coulson from comment #8)
> Hi, sorry. Yes, the edsintegration addon is the one that I suspect causes
> it. Are there any of these crashes from version 0.5 of the addon?

yes, with version 0.5.

this crash is very much still with us in current releases with newer addon. These two crashes have email addresses. So if you have something to be tested we may be able to contact them.
bp-b3342b5a-5e5e-4c83-b18b-65c342130320
bp-e9ae6b80-18ab-4f42-b478-060f62130319
Flags: needinfo?(chrisccoulson)
Summary: crash in g_idle_dispatch using Ubuntu → crash in g_idle_dispatch on shutdown using Ubuntu
(Reporter)

Updated

5 years ago
No longer blocks: 779524
See Also: → bug 779524
(Reporter)

Comment 12

5 years ago
Is a version newer than 0.5 in the works at https://launchpad.net/thunderbird-eds-extension ?

or is the addon dead?
Flags: needinfo?(mconley)
Summary: crash in g_idle_dispatch on shutdown using Ubuntu → crash in g_idle_dispatch on shutdown using Ubuntu and EDS Contacts Integration addon
Chris Coulson from Canonical was the maintainer of that add-on the last time I checked - he'd be more able to answer that than I would.
Flags: needinfo?(mconley)
(Reporter)

Comment 14

5 years ago
yeah, and I think chris resolved the other issues in the past.
Assignee: nobody → chrisccoulson

Comment 15

5 years ago
The topcrash- keyword is not actively maintained and pollutes queries with topcrash.
Keywords: topcrash-
(Reporter)

Updated

5 years ago
Blocks: 779524
(Reporter)

Updated

5 years ago
See Also: bug 779524
Duplicate of this bug: 779524
(Reporter)

Comment 17

5 years ago
per chris on IRC, we're not seeing TB24 crashes because at some point between 17 and 24 we hit bug 888840
Crash Signature: [@ g_idle_dispatch] → [@ g_idle_dispatch] [@ g_main_context_dispatch]
Depends on: 888840
Flags: needinfo?(chrisccoulson)
(Reporter)

Comment 18

3 years ago
https://bugs.launchpad.net/thunderbird-eds-extension/+bug/893169/comments/5 indicates problem is gone.
And this bug should be closed anyway
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.