Marketplace theme/persona previews do not work

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: cvan, Assigned: kngo)

Tracking

({regression})

regression
Points:
---

Details

(URL)

(Reporter)

Description

6 years ago
Steps to reproduce:
1. Load a theme page: https://marketplace-dev.allizom.org/en-US/theme/somewhere-beneath-the-golde/
2. Click on a preview image.
3. Nothing happens. There used to be "reset" text overlaying the preview, and the theme would be previewed in the browser.

Probably caused by https://github.com/mozilla/zamboni/commit/7512a5cc
(Assignee)

Updated

6 years ago
Assignee: nobody → ngoke
(Assignee)

Comment 1

6 years ago
I don't think that patch caused the regression, and doesn't touch JS. I don't ever remember it working locally; the reset overlay appears but doesn't do anything. Installing works on -dev though.

I looked further and all the proper events are fired off to the browser (PreviewBrowserTheme, ResetBrowserThemePreview, InstallBrowserTheme)...
(Assignee)

Comment 2

6 years ago
https://github.com/mozilla/zamboni/commit/d1209e359bf1f6043063c966588207a57b1a62a7
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 3

6 years ago
Verified as fixed. Even if the designs were changed , the main issue from this bug is fixed : http://screencast.com/t/5olkCDd5
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.