implementation of web apps seems to be breaking All profile contents should use cross-platform formats

RESOLVED INVALID

Status

RESOLVED INVALID
6 years ago
3 years ago

People

(Reporter: asmodeusme, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/16.0 Firefox/16.0
Build ID: 20120705030540

Steps to reproduce:

Install a web app


Actual results:

web apps installed in the OS rather than webapp folder in profile


Expected results:

One of the beauty of Mozilla is its platform independent
MAC_OS/WINDOWS/*NIX same profile will work everywhere(just copy the profile folder if you dual boot or have many devices, please keep it that way)


But implementation of web apps seems to be breaking this
So i would request to have an options to disable this because i prefer cross platform profile usability over a web app, i don't want to sync profiles(using internet) to test stuff under same profile on various platforms(as a developer you might feel my pain)


My advise would be to install all files in the profile directory called Web Apps/appname
so it is cross platform(can be launched from inside firefox if profile is shared cross platform[similar to addons]) & uninstalled like extensions

need for menus etc should be asked & if user declines no entry in menus should be made & the app should be launced from inside firefox
(Reporter)

Updated

6 years ago
Blocks: 7067, 761806
Severity: normal → blocker
Component: Untriaged → Web Apps
OS: Windows XP → All
Priority: -- → P1
Hardware: x86 → All
Please don't set the priority field.
Severity: blocker → normal
Priority: P1 → --

Updated

6 years ago
No longer blocks: 761806
(Reporter)

Comment 2

6 years ago
(In reply to Jason Smith [:jsmith] from comment #1)
> Please don't set the priority field.

Sorry didn't know that but its a blocker right?
(In reply to Sillius Soddus from comment #2)
> (In reply to Jason Smith [:jsmith] from comment #1)
> > Please don't set the priority field.
> 
> Sorry didn't know that but its a blocker right?

We triage these bugs weekly, so we'll know tomorrow for sure (we have a triage tomorrow).

Updated

6 years ago
QA Contact: jsmith
(In reply to Sillius Soddus from comment #0)
[...]
> 
> One of the beauty of Mozilla is its platform independent
> MAC_OS/WINDOWS/*NIX same profile will work everywhere(just copy the profile
> folder if you dual boot or have many devices, please keep it that way)
>
> But implementation of web apps seems to be breaking this
> So i would request to have an options to disable this because i prefer cross
> platform profile usability over a web app, 

What exactly is broken about this?  Copying your Firefox profile from one OS to another should still work.  The only things that will not be copied over are your natively-installed webapps (which makes sense since they are natively installed applications).

> i don't want to sync
> profiles(using internet) to test stuff under same profile on various
> platforms(as a developer you might feel my pain)

Will you be developing web apps? If not then you shouldn't have to sync anything across your various OSes.

> 
> My advise would be to install all files in the profile directory called Web
> Apps/appname
> so it is cross platform(can be launched from inside firefox if profile is
> shared cross platform[similar to addons]) & uninstalled like extensions

Webapps are inherently platform-specific; there is no way to install a Windows webapp (which is an EXE) in a way that would make it work on Mac or Linux, and vice versa.

> need for menus etc should be asked & if user declines no entry in menus
> should be made & the app should be launced from inside firefox

One of the main goals of the Webapps project is to integrate webapps with the OS in a way that makes them feel like native applications.  Launching webapps within Firefox, while possible, is a different user experience.
We _are_ committed to providing an awesome Apps experience for every Web Runtime for every App we list in our Marketplace. As Tim says, our implementation involves a modest amount of platform-specific information for each native installation.

Rather than managing Apps by copying profiles around, we want users to take advantage of our Apps in the Cloud (AITC) service[1]. With AITC, the user natively installs their Apps on all their devices. Making the actual profiles cross-platform is not a project goal right now, since we don't expect users to manage their Apps that way.

[1] https://wiki.mozilla.org/Services/AppsInTheCloud
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
Resolution: WONTFIX → INVALID
(Assignee)

Updated

3 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.