Last Comment Bug 771529 - Hover state is not active when mouse hover.. And hover state remains active until I make a window in-active
: Hover state is not active when mouse hover.. And hover state remains active u...
Status: VERIFIED FIXED
: regression
Product: Core
Classification: Components
Component: Layout (show other bugs)
: 16 Branch
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Chris Lord [:cwiiis]
: Paul Silaghi, QA [:pauly]
Mentors:
Depends on: 769541 772079
Blocks: 758620
  Show dependency treegraph
 
Reported: 2012-07-06 08:32 PDT by Alice0775 White
Modified: 2012-09-10 06:42 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified


Attachments
testcase xul (828 bytes, application/vnd.mozilla.xul+xml)
2012-07-06 08:32 PDT, Alice0775 White
no flags Details

Description Alice0775 White 2012-07-06 08:32:17 PDT
Created attachment 639686 [details]
testcase xul

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/4b1249ae1906
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120706030535

Hover state is not active when mouse hover.
And hover state remains active until I make a window in-active

Steps to Reproduce:
1. Prepare a new profile
2. Make sure allow remote XUL
3. Open attached xul
4. Move mouse over button -- observe color and button border
5. Click button -- observe color and button border 
6. Move mouse out the button -- observe color and button border 

Actual Results:
 Hover state is not active at step 4.
 Hover state remains active at step 6.


Expected Results:
 Hover state should be active at step 4.
 Hover state should be removed at step 6.
Comment 1 Alice0775 White 2012-07-13 20:47:07 PDT
This is regressed by Bug 758620.
And the patch in bug 772079 will fix this.
Comment 2 Alice0775 White 2012-07-14 04:06:43 PDT
The patch in bug 772079 landed on Inbound tinderbox build.
http://hg.mozilla.org/integration/mozilla-inbound/rev/a7f80f6408ed
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120714005020

However, This is still reproducible. this is not fixed...
Comment 3 Chris Lord [:cwiiis] 2012-07-14 06:39:59 PDT
(In reply to Alice0775 White from comment #2)
> The patch in bug 772079 landed on Inbound tinderbox build.
> http://hg.mozilla.org/integration/mozilla-inbound/rev/a7f80f6408ed
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0
> ID:20120714005020
> 
> However, This is still reproducible. this is not fixed...

If an earlier patch in bug 772079 fixed this, it is at least invalidation related... The test case here is nice and compact, so I'll take a look at this and hopefully whatever fixes this also fixes bug 769541.
Comment 4 Chris Lord [:cwiiis] 2012-07-16 05:25:03 PDT
(In reply to Alice0775 White from comment #0)
> Created attachment 639686 [details]
> testcase xul
> 
> Build Identifier:
> http://hg.mozilla.org/mozilla-central/rev/4b1249ae1906
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0
> ID:20120706030535
> 
> Hover state is not active when mouse hover.
> And hover state remains active until I make a window in-active
> 
> Steps to Reproduce:
> 1. Prepare a new profile
> 2. Make sure allow remote XUL
> 3. Open attached xul
> 4. Move mouse over button -- observe color and button border
> 5. Click button -- observe color and button border 
> 6. Move mouse out the button -- observe color and button border 
> 
> Actual Results:
>  Hover state is not active at step 4.
>  Hover state remains active at step 6.
> 
> 
> Expected Results:
>  Hover state should be active at step 4.
>  Hover state should be removed at step 6.

Can you elaborate on these steps to reproduce? Following these steps, I see no problem, with and without the patch from bug 772079.
Comment 5 Alice0775 White 2012-07-16 05:45:13 PDT
>Can you elaborate on these steps to reproduce?
This happens Windows 7 with HWA on. not happens with HWA off.
Comment 6 Alice0775 White 2012-07-16 05:48:46 PDT
And this problem does not happen if layers.acceleration.disabled = true;
Comment 7 Chris Lord [:cwiiis] 2012-07-16 06:35:19 PDT
Ok, that changes things a bit - I don't have a Linux setup where layers acceleration isn't massively glitchy atm, so I'm going to assume that bug 769451 and this have the same root cause for now and work on that.
Comment 8 Chris Lord [:cwiiis] 2012-07-18 22:51:47 PDT
A patch is on inbound for bug 769541, do you think you could test to see if it fixes this issue?
Comment 9 Alice0775 White 2012-07-19 00:56:44 PDT
(In reply to Chris Lord [:cwiiis] from comment #8)
> A patch is on inbound for bug 769541, do you think you could test to see if
> it fixes this issue?

The following inbound tinderbox build fixes this Bug 771529 as well.
http://hg.mozilla.org/integration/mozilla-inbound/rev/e6068bdf8268
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120718223824

Thanks :)
Comment 10 Alice0775 White 2012-08-03 14:02:02 PDT
fixed by bug 769541
Comment 11 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-08-28 13:41:15 PDT
Dropping qawanted because I believe it is addressed by comment 1. Adding verifyme to flag for verification.
Comment 12 Paul Silaghi, QA [:pauly] 2012-09-10 06:42:37 PDT
Using Remote XUL Manager add-on to allow remote XUL. Verified fixed using the STR in comment 0 on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0b2.

Note You need to log in before you can comment on or make changes to this bug.