Section Editing on non-English Docs Fails

RESOLVED DUPLICATE of bug 839559

Status

Mozilla Developer Network
Editing
P2
major
RESOLVED DUPLICATE of bug 839559
5 years ago
4 years ago

People

(Reporter: davidwalsh, Unassigned)

Tracking

(Blocks: 1 bug)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Trying to edit the section of a non-EN-US doc fails miserable.  Screenshot attached.

Even worse is that sometimesthe doc itself becomes hosed; somehow the data is found, no redirection takes place, but there's a block that says "This document doesn't exist yet, create it!"  Other times it simply shows the monsterous page and if you refresh, the section is gone.

Looking at the code, edit_document() forwards the request to the translate() method, where there is no section handling at all.
(Reporter)

Updated

5 years ago
Severity: normal → critical
(Reporter)

Comment 1

5 years ago
Created attachment 639838 [details]
Translate Section Edit Shock Horror

Updated

5 years ago
Blocks: 756263
Priority: -- → P1
(Reporter)

Comment 2

5 years ago
IMO, we should really disable all section editing until this is fixed.
Blocks: 773292

Updated

5 years ago
No longer blocks: 756263
Tempted to create a new bug to removing section editing, then revisit this one after launch.

However, let's at least look into this first. If we end up spending hours on it, let's consider the above.
See bug 774449.
Blocks: 774452
Blocks: 775601
Priority: P1 → P2
(Reporter)

Comment 5

5 years ago
Moved to post-launch, not been prioritized, downgrading importance.
Severity: critical → major
(Assignee)

Updated

5 years ago
Version: Kuma → unspecified
(Assignee)

Updated

5 years ago
Component: Docs Platform → Editing
Product: Mozilla Developer Network → Mozilla Developer Network
No longer blocks: 775601
Merging this into our single tracking bug for section editing.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 839559
Blocks: 839559
You need to log in before you can comment on or make changes to this bug.