Last Comment Bug 771817 - Add-on compatibility dialog appears when launching app using different version from that previously run
: Add-on compatibility dialog appears when launching app using different versio...
Status: VERIFIED FIXED
[qa!]
:
Product: Firefox Graveyard
Classification: Graveyard
Component: Webapp Runtime (show other bugs)
: Trunk
: All All
: P1 normal
: Firefox 16
Assigned To: Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not)
: Jason Smith [:jsmith]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-07 10:58 PDT by :Gavin Sharp [email: gavin@gavinsharp.com]
Modified: 2016-03-21 12:39 PDT (History)
2 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch v1 (1.27 KB, patch)
2012-07-08 20:16 PDT, Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not)
gavin.sharp: review+
Details | Diff | Splinter Review

Description :Gavin Sharp [email: gavin@gavinsharp.com] 2012-07-07 10:58:11 PDT
STR:
1) Install "BarFight" from https://apps.mozillalabs.com/appdir/ in an Aurora build
2) Run it (e.g. double click icon in Applications) and close it
3) Un-install the app (delete bundle from Applications)
4) Install the app again, this time in a Nightly build
5) Run the newly installed version

Expected: app launches normally
Actual: "Checking add-on compatibility" dialog appears, stays indefinitely
Comment 1 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-07-07 10:58:56 PDT
We should also do some testing to ensure that this doesn't happen in normal upgrade scenarios (e.g. when users update to Firefox 17 and run the apps they installed with Firefox 16 for the first time).
Comment 2 Jason Smith [:jsmith] 2012-07-07 11:45:08 PDT
I can't reproduce this bug on Win 7. Can you be more specific? Was Aurora running when executing steps 2 and 3? Is step 3 you are meaning the app (BarFight), not Firefox Aurora, right? 

Upon executing step 4, the add-on compatibility dialog came up for when you started Nightly, right? Then, it showed up again in step 5?
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-07-07 16:56:34 PDT
I'm testing on Mac. Aurora and Nightly were both running the entire time. "the app" refers to BarFight, in all cases. Step 5 means running the newly installed version of Barfight (installed from Nightly).

The web app runtime needs to disable the add-on compatibility dialog entirely (or perhaps the add-ons manager entirely).
Comment 4 Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not) 2012-07-08 19:48:57 PDT
Oh, duh - I forgot about that. We have a pref to disable that, patch coming up.
Comment 5 Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not) 2012-07-08 20:16:30 PDT
Created attachment 640129 [details] [diff] [review]
Patch v1
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-07-10 15:46:20 PDT
https://hg.mozilla.org/mozilla-central/rev/021cff093a3c
Comment 7 Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not) 2012-07-10 17:58:51 PDT
Bah, forgot to hit submit when I landed this on inbound. That changeset was:
https://hg.mozilla.org/integration/mozilla-inbound/rev/021cff093a3c

Note You need to log in before you can comment on or make changes to this bug.