[BiDi]Unable to migrate Address Book prefs

VERIFIED INVALID

Status

VERIFIED INVALID
18 years ago
10 years ago

People

(Reporter: marina, Assigned: erik)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Steps to repro:
-delete mozilla dir (under Profiles);
-select 4.x profile;
-start mozilla;
-open Address Book;
//note: Personal AB, Collected AB are empty, nothing is migrated
(Assignee)

Updated

18 years ago
Blocks: 75982

Comment 1

18 years ago
can this be reproduce by non-bidi build?
(Reporter)

Comment 2

18 years ago
in non-bidi build delivered by Erik there is no migration done either 

Comment 3

18 years ago
This is not an issue. We try the non bidi build also. it does not migrate 
addressbook neither. Nhotta and I look at the /ns source code, it seems the 
addressbook migration code is under /ns/mailnews/adderssbook/upgrade so it is 
not part fo mozilla build. mark this bug as invalid since address book migration 
is a ns only feature. 
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Assignee)

Updated

18 years ago
No longer blocks: 75982
Just to provide more information for everyone.

Addressbooks in 4.x were stored in NAB files - Neologic address book.

The code to migrate these address books is proprietary and is only a part of 
the Netscape branded products.
(Reporter)

Comment 5

18 years ago
verifying it as invalid: address book migration feature is not in mozilla
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.