Closed Bug 771924 Opened 7 years ago Closed 7 years ago

Provide option in Tabs-Section to disable 'Close Other Tabs' warning

Categories

(Firefox :: Tabbed Browser, defect)

16 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 772319

People

(Reporter: pc-elitist, Unassigned)

References

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:16.0) Gecko/16.0 Firefox/16.0
Build ID: 20120708030543

Steps to reproduce:

I used 'Close Other Tabs' command.


Actual results:

I received a warning. 


Expected results:

There should be an option to stop receiving, like other kind of warning in 'Tabs' section in Options.
Component: Untriaged → Tabbed Browser
Duplicate of this bug: 774591
FYI: I created a new profile to try and reproduce this on another computer, and Firefox behaved correctly (IE shut all tabs with no warning.)
This bug is 100% reproducible with a clean new profile for me. The preference browser.tabs.warnOnClose is not respected anymore and the warning gets always shown.

Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/17.0 Firefox/17.0

Built from http://hg.mozilla.org/mozilla-central/rev/a79132ac2f05
(In reply to Ilja Sekler from comment #3)
> This bug is 100% reproducible with a clean new profile for me. The
> preference browser.tabs.warnOnClose is not respected anymore and the warning
> gets always shown.
> 
> Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/17.0 Firefox/17.0
> 
> Built from http://hg.mozilla.org/mozilla-central/rev/a79132ac2f05

I can confirm that browser.tabs.warnOnClose is not respected anymore. Tested on OS X 10.8.1 using latest nightly build.
Firefox 16 beta 3 already includes the notification. Any plans to implement this bug? Having Mouse Gestures, this is the most used command, and I'm pretty sure I'm not the only one... I'd appreciate this, thanks!
Reproducible on the 09/16 Nightly.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86 → All
This issue doesn't reproduce on Firefox 15.0.1, but it does happen on Fx 16 beta 3. It's a regression introduced in Firefox 16, but I don't have the time to find the regression range right now.

If anyone else reproducing this issue can find one, that would be much appreciated.
Keywords: regression
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 772319
Ioanna, are you sure this is a regression. I thought it was intented... Almost one month ago, they've added in Nightly a new notification specifically for "close other tabs" only. They just haven't add the option to disable this new one, like the other 2 notifications. Anyway, I'm not completely sure and I wouldn't like to confuse anyone.
You need to log in before you can comment on or make changes to this bug.