Last Comment Bug 772319 - No option to disable the "Close other tabs" prompt
: No option to disable the "Close other tabs" prompt
Status: VERIFIED FIXED
:
Product: Firefox
Classification: Client Software
Component: Menus (show other bugs)
: Trunk
: x86_64 All
: -- normal with 26 votes (vote)
: Firefox 18
Assigned To: Tetsuharu OHZEKI [:tetsuharu] [UTC+9]
:
Mentors:
: 771924 799448 799857 799951 800008 800014 801122 801323 801360 803629 807390 807568 807942 808400 811223 814857 817880 827464 (view as bug list)
Depends on:
Blocks: 801072 277079
  Show dependency treegraph
 
Reported: 2012-07-09 19:28 PDT by Grant
Modified: 2013-10-07 13:24 PDT (History)
49 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
affected
+
verified
verified
unaffected
verified


Attachments
add the new option & clean up the method (4.84 KB, patch)
2012-10-05 08:06 PDT, Tetsuharu OHZEKI [:tetsuharu] [UTC+9]
no flags Details | Diff | Splinter Review
add the new option v2 (3.34 KB, patch)
2012-10-05 08:57 PDT, Tetsuharu OHZEKI [:tetsuharu] [UTC+9]
dao+bmo: review+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Grant 2012-07-09 19:28:23 PDT
Hi guys,

Since Bug 277079 - ""Close other tabs" should always warn about closing multiple tabs" landed, I am getting very frustrated with having to confirm every time I use this feature - I open multiple links from a single page such as NYT and then when done go to the main tab and click "Close other tabs".

Shouldn't this be disabled if I have disabled "Warn me when closing multiple tabs"?
Comment 1 Dão Gottwald [:dao] 2012-07-10 00:44:28 PDT
(In reply to Grant from comment #0)
> Shouldn't this be disabled if I have disabled "Warn me when closing multiple
> tabs"?

The point of bug 277079 is to let that pref not affect the prompt in this particular case. The reason is that people hit "Close other tabs" accidentally and thus asked us to remove it. We didn't want to do that, recognizing that it's a time saver for people using it intentionally. Hence this compromise.
Comment 2 Grant 2012-07-10 00:47:21 PDT
Ahhh I see - I can see why that would be annoying for someone with a whole bunch of tabs they don't want closing.

Is there a way to at least disable it in about:config?
Comment 3 WaltS48 2012-07-10 07:21:05 PDT
(In reply to Grant from comment #2)
> Ahhh I see - I can see why that would be annoying for someone with a whole
> bunch of tabs they don't want closing.
> 
> Is there a way to at least disable it in about:config?

Not that I could find when I looked.

BTW this is common to all platforms.

Mozilla/5.0 (X11; Linux x86_64; rv:16.0) Gecko/16.0 Firefox/16.0
Comment 4 Frank Lion 2012-07-22 07:33:48 PDT
(In reply to Dão Gottwald [:dao] from comment #1)
> (In reply to Grant from comment #0)
> > Shouldn't this be disabled if I have disabled "Warn me when closing multiple
> > tabs"?
> 
> The point of bug 277079 is to let that pref not affect the prompt in this
> particular case. The reason is that people hit "Close other tabs"
> accidentally and thus asked us to remove it. We didn't want to do that,
> recognizing that it's a time saver for people using it intentionally. Hence
> this compromise.

I've missed something somewhere. I understand the point about possible accidental data loss being the reason for bug 277079 (even though I think it is a rare case scenario). What I don't understand is why you don't just prompt by default and remove the Options window entry for 'Warn me when closing multiple tabs' and leave the about:config entry alone? 

'Novice' users will then be protected from data loss (instead of just going ape by clicking/unclicking a checkbox that doesn't do anything) and users who are 'expert enough/stupid enough' to fiddle in about:config will only have themselves to blame if they close loads of tabs without meaning to. Then again, being 'experts' they will recover the lost info from History within minutes.

Could you explain, please? - because I'm sure there must be something I've missed on this one.
Comment 5 Virtual_ManPL [:Virtual] - (ni? me) 2012-07-23 13:41:17 PDT
I agree. Option "Warn me when closing multiple tabs" should be also affecting "Close other tabs".

@ Dão Gottwald - now we removed "tabs on bottom" option in menus and we starting to get rid of this completely,
why not get rid of "Close Other Tabs" option too
I think it have smaller user base than "tabs on bottom" and "send link" as we also remove this not used by many feature
What you think?
Comment 6 Grant 2012-07-23 16:58:10 PDT
If you remove it will it be able to be added from an about:config entry?
Comment 7 WaltS48 2012-07-23 17:13:11 PDT
(In reply to Virtual_ManPL from comment #5)
> I agree. Option "Warn me when closing multiple tabs" should be also
> affecting "Close other tabs".
> 
> @ Dão Gottwald - now we removed "tabs on bottom" option in menus and we
> starting to get rid of this completely,
> why not get rid of "Close Other Tabs" option too
> I think it have smaller user base than "tabs on bottom" and "send link" as
> we also remove this not used by many feature
> What you think?

I think if you got rid of the "Close Other Tabs" option, I would be very annoyed at having to close each one individually.

I really would just like a check box that disables the warning that I am closing multiple tabs, when I select "Close Other Tabs", because I know what I am doing.

If I close some accidentally, that is my problem to fix, not Mozilla's.
Comment 8 »Q« 2012-07-24 19:52:33 PDT
(In reply to Dão Gottwald [:dao] from comment #1)

> The point of bug 277079 is to let that pref not affect the prompt in this
> particular case. The reason is that people hit "Close other tabs"
> accidentally and thus asked us to remove it. We didn't want to do that,
> recognizing that it's a time saver for people using it intentionally. Hence
> this compromise.

This reads as a WONTFIX, but the bug's status is still UNCONFIRMED.  Since it remains a possibility to add a separate pref for this specific case, shouldn't it be CONFIRMED?
Comment 9 Kemcy BEST 2012-07-27 21:15:48 PDT
I'd like to add my support to bring back some (hidden) pref's to disable this warning. Sometimes we know what we do. My point is, when a user right clicks on the tabbar and select "close other tabs", his/her intention is clear, at least the meaning of "close other tabs" is understood. Now if a warning is displayed, the user will be taught to pay attention to this action. Then wouldn't it be good if there's a check box in this warning dialog reading "I see, do not warn me next time" before you click OK? "Accidentally" should not be the reason to remove something. Someone hits this "option" accidentally only once but not twice if he/she disagrees with its behavior. If he/she know what "close other tabs" does and wants still to use it, he/she will accept no warnings.
Comment 10 Virtual_ManPL [:Virtual] - (ni? me) 2012-07-29 02:12:52 PDT
Hidden pref is a bad idea, user will need to spend some time on searching answer on the web.

Better idea will be when option "Warn me when closing multiple tabs" will be also affecting "Close other tabs".
Comment 11 Robert 2012-09-13 06:48:51 PDT
In logic, I think "closing multiple tabs" should include "other tabs". So option "Warn me when closing multiple tabs" should be also affecting "Close other tabs".
Comment 12 Tetsuharu OHZEKI [:tetsuharu] [UTC+9] 2012-09-14 07:15:57 PDT
I agree that "browser.tabs.warnOnClose" should affect "Close other tabs" too.
The current behavior is not clearly.

I propose 2 idea:

1. Add the new pref which affects "Close other tabs".
This approach is based on the thought which browser should always warn when user closing only tabs (without a window). Because it may be user's miss.
But browser should not warn when user closing a window with tabs. Because user may hope quit browser.

2. Revert the behavior of "browser.tabs.warnOnClose" which affects "Close other tabs". And  Remove the item of "browser.tabs.warnOnClose" from Options. So "browser.tabs.warnOnClose" is only shown in closing a window with opening multiple tabs.
This approach is based on the thought which browser should warn when user close multiple tabs. But If user hope it, "browser.tabs.warnOnClose" should affect (the prompt is not shown).

I like 2. But I don't recommend it strongly.
Comment 13 Tetsuharu OHZEKI [:tetsuharu] [UTC+9] 2012-09-17 06:46:16 PDT
*** Bug 771924 has been marked as a duplicate of this bug. ***
Comment 14 Andy Bajka 2012-09-17 06:58:25 PDT
I recommend this be a about:config switch only. No need to complicate the Preference menus with this function.

Please fix browser.tabs.warnOnClose so that it once again functions correctly.
Comment 15 ChrisX 2012-09-25 05:00:53 PDT
Agreed. browser.tabs.warnOnClose right now is inconsistent and illogical if it still warns on "close other tabs" even though it's set to false. Right-clicking and choosing "close other tabs" is no more dangerous than accidentally clicking the red dot in the main window (Mac), which closes all tabs and doesn't give a warning, either, if I don't want it.
Comment 16 Tetsuharu OHZEKI [:tetsuharu] [UTC+9] 2012-10-05 08:06:11 PDT
Created attachment 668447 [details] [diff] [review]
add the new option & clean up the method

This patch adds a new *hidden* pref to switch showing prompt when command "close other tabs".
I use this approach to not break the current (after fixed Bug 277079) behavior.

What do you think?
Comment 17 Dão Gottwald [:dao] 2012-10-05 08:13:59 PDT
Comment on attachment 668447 [details] [diff] [review]
add the new option & clean up the method

>+pref("services.sync.prefs.sync.browser.tabs.warnOnCloseOtherTabs", true);

We shouldn't sync hidden prefs.

>       <method name="warnAboutClosingTabs">
>-      <parameter name="aAll"/>
>+      <parameter name="aIsClosingAll"/>
>       <body>
>         <![CDATA[
>-          var tabsToClose = (aAll ?
>+          var tabsToClose = (aIsClosingAll ?
>                                this.tabs.length - this._removingTabs.length :
>                                this.visibleTabs.length - 1)
>                             - gBrowser._numPinnedTabs;

I don't see how this makes anything clearer.
Comment 18 Tetsuharu OHZEKI [:tetsuharu] [UTC+9] 2012-10-05 08:35:35 PDT
(In reply to Dão Gottwald [:dao] from comment #17)
> Comment on attachment 668447 [details] [diff] [review] 
> >+pref("services.sync.prefs.sync.browser.tabs.warnOnCloseOtherTabs", true);
> We shouldn't sync hidden prefs.

OK, I'll remove this part.

> >       <method name="warnAboutClosingTabs">
> >-      <parameter name="aAll"/>
> >+      <parameter name="aIsClosingAll"/>
> >       <body>
> >         <![CDATA[
> >-          var tabsToClose = (aAll ?
> >+          var tabsToClose = (aIsClosingAll ?
> >                                this.tabs.length - this._removingTabs.length :
> >                                this.visibleTabs.length - 1)
> >                             - gBrowser._numPinnedTabs;
> 
> I don't see how this makes anything clearer.

The parameter, |aAll|, is boolean value which indicate whether this methods is called when closing all tabs, or not.
If we change the param name to |aIsClosingAll| from |aAll|, it make easier to check when closing all tabs. I think it is clearer & more readable.
Comment 19 Dão Gottwald [:dao] 2012-10-05 08:45:36 PDT
All this method deals with are closing tabs, so "aAll" seems just as clear and readable to me. Not worth the hg blame pollution.
Comment 20 Tetsuharu OHZEKI [:tetsuharu] [UTC+9] 2012-10-05 08:57:07 PDT
Created attachment 668469 [details] [diff] [review]
add the new option v2

I reflect dao's comments.
Comment 21 Tetsuharu OHZEKI [:tetsuharu] [UTC+9] 2012-10-05 09:06:43 PDT
Thank you review!
Comment 22 Daniel Holbert [:dholbert] 2012-10-05 11:52:39 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/2c8f5efea9ad
Comment 23 Ed Morley [:emorley] 2012-10-06 12:48:24 PDT
https://hg.mozilla.org/mozilla-central/rev/2c8f5efea9ad
Comment 24 Marco Gruß 2012-10-09 10:51:50 PDT
*** Bug 799448 has been marked as a duplicate of this bug. ***
Comment 25 Matthias Versen [:Matti] 2012-10-10 06:44:59 PDT
*** Bug 799857 has been marked as a duplicate of this bug. ***
Comment 26 minus54 2012-10-10 07:16:04 PDT
Will this option be reflected on the interface? 
Just a hidden pref is not a great idea. I'm considering if opening a new feature suggestion on it.
Comment 27 Matthias Versen [:Matti] 2012-10-10 09:51:32 PDT
*** Bug 800014 has been marked as a duplicate of this bug. ***
Comment 28 Matthias Versen [:Matti] 2012-10-10 09:55:50 PDT
*** Bug 800008 has been marked as a duplicate of this bug. ***
Comment 29 Matthias Versen [:Matti] 2012-10-10 09:59:55 PDT
*** Bug 799951 has been marked as a duplicate of this bug. ***
Comment 30 Nathan Williams 2012-10-10 10:10:32 PDT
(In reply to Frank Lion from comment #4)
> (In reply to Dão Gottwald [:dao] from comment #1)
> > (In reply to Grant from comment #0)
> > > Shouldn't this be disabled if I have disabled "Warn me when closing multiple
> > > tabs"?
> > 
> > The point of bug 277079 is to let that pref not affect the prompt in this
> > particular case. The reason is that people hit "Close other tabs"
> > accidentally and thus asked us to remove it. We didn't want to do that,
> > recognizing that it's a time saver for people using it intentionally. Hence
> > this compromise.
> 
> I've missed something somewhere. I understand the point about possible
> accidental data loss being the reason for bug 277079 (even though I think it
> is a rare case scenario). What I don't understand is why you don't just
> prompt by default and remove the Options window entry for 'Warn me when
> closing multiple tabs' and leave the about:config entry alone? 
> 
> 'Novice' users will then be protected from data loss (instead of just going
> ape by clicking/unclicking a checkbox that doesn't do anything) and users
> who are 'expert enough/stupid enough' to fiddle in about:config will only
> have themselves to blame if they close loads of tabs without meaning to.
> Then again, being 'experts' they will recover the lost info from History
> within minutes.
> 
> Could you explain, please? - because I'm sure there must be something I've
> missed on this one.

I agree with Frank here.  I am confused on what I need to do to get the functionally back.  I am NOT an idiot.  If I hit close other tabs then that is the action I want taken. Immediately! I don't want a damn dialog asking me if I am sure or not.
Comment 31 minus54 2012-10-10 10:48:04 PDT
To get the functionally back you'll have to install Firefox 18, typing about:config in the address bar, search browser.tabs.warnOnCloseOtherTabs and change the value to false. All these annoying steps to not report this option in Tools > Options > Tabs interface. 1) There is a lot of space there 2) A novice user can't be so rash to uncheck an option casually. Otherwise he should be more careful, without blaming a functionality to be unsafe. 3) Some users will have to search a lot to find browser.tabs.warnOnCloseOtherTabs preference.
Comment 32 torsten.zachert 2012-10-11 06:55:29 PDT
Now we have Firefox 16. Please implemented this back immediately in the current version.
Comment 33 Alfredo Osorio 2012-10-11 07:28:13 PDT
Such annoying feature. Pleas fix this.
Comment 34 Tetsuharu OHZEKI [:tetsuharu] [UTC+9] 2012-10-11 07:42:30 PDT
Comment on attachment 668469 [details] [diff] [review]
add the new option v2

[Approval Request Comment]

This patch have not been land on Firefox 16-17.
But some problem which this patch fixes are reported.

So I think we need to land this patch to Firefox 17.
If we won't have landed this patch to 17, this will be not fixed until ESR 24 on ESR branch. It should be bad.
Fortunately, this patch does not have a side effect. Therefore we can land this.

And also, if it's available, we should land this to Firefox 16....
Comment 35 Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-10-11 08:00:19 PDT
Nathan Williams:

Hey, why did you remove the status flags? Is must be useful for checking the bug status.
Comment 36 Nathan Williams 2012-10-11 08:09:33 PDT
(In reply to Masayuki Nakano (:masayuki) (Mozilla Japan) from comment #35)
> Nathan Williams:
> 
> Hey, why did you remove the status flags? Is must be useful for checking the
> bug status.

Accidentally.  I'm just trying to unsubscribe from this bugreport. Please remove me and fix what damage I just did.  My apologies.
Comment 37 Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-10-11 08:16:34 PDT
(In reply to Nathan Williams from comment #36)
> (In reply to Masayuki Nakano (:masayuki) (Mozilla Japan) from comment #35)
> > Nathan Williams:
> > 
> > Hey, why did you remove the status flags? Is must be useful for checking the
> > bug status.
> 
> Accidentally.  I'm just trying to unsubscribe from this bugreport. Please
> remove me and fix what damage I just did.  My apologies.

You should have seen a warning page of "mid-air collisions" and you choose the button to overwrite the status. If not so, bugzilla has a bug.
Comment 38 Nathan Williams 2012-10-11 08:26:16 PDT
It has a bug because I never saw that.  Nor was I editing the flags.  Just the CC status.  I have removed myself and you reset the flags so again my apologies.
Comment 39 Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-10-11 15:17:19 PDT
I see, thanks. I'll contact bugzilla team for the issue.
Comment 40 GS 2012-10-12 06:15:06 PDT
Please make the annoying dialog box go away or give us an option to disable it. This new "feature" looks to me as useful as Microsoft's Clippy. It was equally well intended and equally annoying and useless.
Please stop considering all users idiots and stop trying to (over) protect them.
Comment 41 mrvotruba 2012-10-12 07:55:15 PDT
Add my voice to "Please make the annoying dialog box go away or give us an option to disable it." It's very patronizing of Firefox toward users to prevent them from setting their own option (and face the consequences as the case may be), treating them as if they were infantile and unable to make a choice and change it as they wish based on their own experiences.
Comment 42 Firefix 2012-10-12 08:00:58 PDT
I hate this 'confirm close' prompt and I do not understand why FF developers have not left the option to disable this annoying notification for more advanced users.

I wish I could stick with FF15 until FF18 finally addresses this issue but I reckon this is not a good idea security-wise. 

Why did you ever make this change? An undo 'close other tabs' function would have been much better.
Comment 43 minus54 2012-10-12 13:46:07 PDT
I created a Bug 801072 to suggest a new visible preference, because the fix in Firefox 18 consists in a hidden pref.
Comment 44 Alex Keybl [:akeybl] 2012-10-12 14:00:40 PDT
Comment on attachment 668469 [details] [diff] [review]
add the new option v2

We don't take fixes specifically for the ESR unless they're related to stability or security.
Comment 45 Alex Keybl [:akeybl] 2012-10-12 14:01:30 PDT
(and this doesn't meet our criteria for skipping the trains)
Comment 46 hardrada 2012-10-13 01:47:48 PDT
Add me to the list of people who are unhappy about being prompted about this.  I have "Warn me when closing multiple tabs" turned off, and yet I am being warned when I want to close multiple tabs.

Hiding an option to fix it away in about:config for Firefox 18 is not the solution I want to see when we already have an option that (falsely) claims to control this.
Comment 47 Matthias Versen [:Matti] 2012-10-13 05:57:23 PDT
*** Bug 801122 has been marked as a duplicate of this bug. ***
Comment 48 Matthias Versen [:Matti] 2012-10-13 16:47:21 PDT
*** Bug 801323 has been marked as a duplicate of this bug. ***
Comment 49 Matthias Versen [:Matti] 2012-10-13 16:49:56 PDT
Requesting an uplift to beta given the number of dupes or a backout of bug 277079.
a fix for bug 801072 should be considered as well
Comment 50 Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-10-13 21:06:00 PDT
*** Bug 801360 has been marked as a duplicate of this bug. ***
Comment 51 Lukas Blakk [:lsblakk] use ?needinfo 2012-10-15 14:56:34 PDT
Not tracking this for uplift, we'll let the fix ride the trains and ship with 18.
Comment 52 Lukas Blakk [:lsblakk] use ?needinfo 2012-10-15 14:57:43 PDT
(In reply to Matthias Versen (Matti) from comment #49)
> Requesting an uplift to beta given the number of dupes or a backout of bug
> 277079.
> a fix for bug 801072 should be considered as well

Will let the stakeholders in bug 277079 decide if the feature should be disabled or not now that we're getting user feedback.
Comment 53 Sarah Harvey 2012-10-15 22:54:21 PDT
I submitted user feedback that I was very unhappy with this. I play browser based games and I --ALWAYS-- use, "Close Other Tabs" and never before up until now, was there a dialogue box popping up asking to close. This slows down my performance when working with more than 50 tabs which I often do, and I checked all my preferences and they are disabled and I still get the box. So now what must I do? Switch over to Google Chrome or some **** when I was happy with Firefox? 

Please...you are going to lose customers this way. Its not fixed for me whatsoever.
Comment 54 Joe 2012-10-15 23:37:38 PDT
It's an annoying usability setback, IMHO. I'm already being nanny'ed by my OS and would hate to see Firefox taking the same route.
Comment 55 vladtorop 2012-10-16 02:51:59 PDT
Does somebody from FF team can tell me the sense of "Warn when closing multiple tabs" setting starting from 16.0.1 version? Anyway its value is ignored. I don't want to see the dialog every time I close 3+ tabs.
Comment 56 Tascam 2012-10-16 05:32:21 PDT
How is this "RESOLVED FIXED"?  I just had the same issue 2 minutes ago when setting up my account for this forum.

I have read all comments up to this point and am now thoroughly confused.  Please enlighten me.

1.  Default behavior is to warn when closing multiple tabs(To prevent novice users from data loss)

2.  Advanced users who understand the meaning of "Close Other Tabs" expend considerable energy to find and modify the option to display the popup warning, yet still get the warning to protect novice users.

This is equivalent to microsoft's "Are you sure you want to perform some action?" which you have no way of disabling.

Rather than displaying a fake option to disable the popup warning, why not display a genuine option to disable the popup warning since novice users will be responsible for their own actions at the point that they change the option to display the popup.

Or maybe you should show a warning when changing this option that tells a user that disabling the "Warn Me When Closing Multiple Tabs" option will prevent them from getting a popup when they close multiple tabs.(Very Redundant but better than the current situation, which has users modify an option yet still getting the same result)

I've been using firefox for many years now and this is the first time that I feel that a release version is broken.

Also note that novice users who change this option expecting that the popup warning will go away will now feel that firefox is buggy which may discourage them from using firefox and promote returning to another browser platform.(I hope that your plan for novice users is not to discourage their firefox usage?)

Once again...  HOW IS THIS "RESOLVED FIXED" WHEN I CONTINUE TO GET THE POPUP AFTER CHANGING THE OPTION TO DISPLAY THE WARNING?

Please advise me when disabling the popup actually disables the popup and when "RESOLVED FIXED" actually means that this issue is "RESOLVED FIXED"...  Or should I look somewhere in an advanced option to modify what "RESOLVED FIXED" means?
Comment 57 Matthias Versen [:Matti] 2012-10-16 06:54:42 PDT
>How is this "RESOLVED FIXED"?
This is fixed for Firefox18 (look at the target milestone of this bug). The uplift of zhis fix to Firefox17 got denied.
This bug added an additional hidden option to disable the prompt.
bug 277079 changed the "don't ask " option to not include "close other tabs"
bug 801072 wants that a user visible option will be added
Comment 58 Andy Bajka 2012-10-16 07:21:41 PDT
Has the browser.tabs.warnOnClose been fixed? If so which version of Firefox nightly can we verify that it once again works?
Comment 59 minus54 2012-10-16 08:40:45 PDT
Please post to the new bug 801072 if you want a visible option to disable it.
Thank you.
Comment 60 Andy Bajka 2012-10-16 08:42:48 PDT
minus54, what do you mean by "visible option" ?
Comment 61 minus54 2012-10-16 08:51:37 PDT
A new preference below the option "Warn me when closing multiple tabs".
Comment 62 minus54 2012-10-16 09:08:52 PDT
Something like ""Warn me when closing all tabs except the current"
Comment 63 André S. 2012-10-16 09:35:19 PDT
This must be one of the weirdest "bugfixes" ever. Fixing a "bug" that was written 2005?? And the second bugreporter had disabled the "warn when closing multiple tabs" option.
If a user has disabled that option and accidently hit "close other tabs" that can't really be seen as bug that needs to be fixed. He has the option to easily restore the ten last closed tabs and the rest can be found in history.

I use the "close other tabs" all the time, every day and hav been using since it first existed and never have i pressed it accidently.
Also there is an option to restore the last 10 closed tabs and the rest can be found in history.
This new "feature" might seem small, but for me and many others it is very annoying and a major deal breaker.

Also this is not a feature for about:config, it should just be rollbacked to the way it always has worked.
Comment 64 minus54 2012-10-16 09:50:09 PDT
I don't think that a rollback is a good idea. I prefer a good compromise between all parts involved in this mess. I can already imagine a new bug thread about restoring the current behavior in Firefox 16.
Comment 65 Andy Bajka 2012-10-16 10:39:32 PDT
I just realized that this bug is about the "Warn me when closing multiple tabs".

Preferences -> Tabs -> Warn me when closing multiple tabs

I assume this has been fixed. Can we test it in the nightly build?
Comment 66 Andy Bajka 2012-10-16 11:01:16 PDT
Just tested in nightly build 19.0a1 and it works perfect.
Comment 67 Firefix 2012-10-17 02:49:27 PDT
(In reply to Andy Bajka from comment #66)
> Just tested in nightly build 19.0a1 and it works perfect.

It also works with FF 18.0a2 (2012-10-16) (Aurora)
https://www.mozilla.org/en-US/firefox/aurora/

about:config -> browser.tabs.warnOnCloseOtherTabs -> set to 'false' (double click)

Some add-ons might not be compatible with FF 18 yet. For example, 'TACO with Abine 4.48'. Can anyone recommend a working alternative for TACO?
Comment 68 torsten.zachert 2012-10-18 03:40:01 PDT
Great News !!!

Until FF 18 use PlugIn "Tab Mix Plus 0.4.0.3" and you will get the old behavior.
Comment 69 Matthias Versen [:Matti] 2012-10-19 13:23:27 PDT
*** Bug 803629 has been marked as a duplicate of this bug. ***
Comment 70 Lukas Blakk [:lsblakk] use ?needinfo 2012-10-23 11:25:45 PDT
Comment on attachment 668469 [details] [diff] [review]
add the new option v2

Given the level of user requests for this, we'd like to uplift to 17 beta - please go ahead and land to branch this week so that it's in Beta 4 which goes to build early next week.
Comment 71 Lukas Blakk [:lsblakk] use ?needinfo 2012-10-23 13:22:57 PDT
Comment on attachment 668469 [details] [diff] [review]
add the new option v2

Sorry for the confusion, putting this back to ? right now while we confirm with product that uplifting this is the way to go.
Comment 72 Lukas Blakk [:lsblakk] use ?needinfo 2012-10-24 15:01:10 PDT
Comment on attachment 668469 [details] [diff] [review]
add the new option v2

Ok, confirmed that we can go ahead with this uplift and we'll also reach out to SUMO to get a knowledge base article written to guide users who want to set this in their configs.
Comment 73 Muthu 2012-10-24 15:03:37 PDT
Will it be available in firefox 17 ?

or there is a patch available now to get rid of it
Comment 74 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-10-24 15:03:55 PDT
Comment on attachment 668469 [details] [diff] [review]
add the new option v2

Don't we need this on ESR17 too, then?
Comment 75 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-10-24 15:04:40 PDT
Comment on attachment 668469 [details] [diff] [review]
add the new option v2

Oh, that's not forked yet, nevermind me.
Comment 76 Lukas Blakk [:lsblakk] use ?needinfo 2012-10-25 11:45:15 PDT
(In reply to Muthu from comment #73)
> Will it be available in firefox 17 ?

Yes, this pref will be available in 17 which ships on 11/20/2012
Comment 77 Ryan VanderMeulen [:RyanVM] 2012-10-27 15:30:44 PDT
https://hg.mozilla.org/releases/mozilla-beta/rev/b14b009ce8aa

To those watching from home, this will be in Firefox 17b4 when released.
Comment 78 Matthias Versen [:Matti] 2012-10-31 13:56:56 PDT
*** Bug 807390 has been marked as a duplicate of this bug. ***
Comment 79 Mardeg 2012-10-31 22:40:54 PDT
*** Bug 807568 has been marked as a duplicate of this bug. ***
Comment 80 Matthias Versen [:Matti] 2012-11-02 09:39:34 PDT
*** Bug 807942 has been marked as a duplicate of this bug. ***
Comment 81 Dão Gottwald [:dao] 2012-11-12 06:51:42 PST
*** Bug 808400 has been marked as a duplicate of this bug. ***
Comment 82 Matthias Versen [:Matti] 2012-11-13 02:50:48 PST
*** Bug 811223 has been marked as a duplicate of this bug. ***
Comment 83 Loic 2012-11-24 07:21:21 PST
*** Bug 814857 has been marked as a duplicate of this bug. ***
Comment 84 Peter 2012-11-24 12:54:12 PST
Install Close All Tabs Extension and you will be able to close with no warnings.
Comment 85 Matthias Versen [:Matti] 2012-12-03 16:47:03 PST
*** Bug 817880 has been marked as a duplicate of this bug. ***
Comment 86 Mihai Morar, (:MihaiMorar) 2012-12-07 04:31:48 PST
I verified this issue on FF 17 Release and FF 18.b3 for Windows 7 x64, Ubuntu x32 and Mac OX 10.8 : 

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20100101 Firefox/17.0
Mozilla/5.0 (X11; Linux i686; rv:18.0) Gecko/20100101 Firefox/18.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/17.0 Firefox/17.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:18.0) Gecko/20100101 Firefox/18.0


browser.tabs.warnOnClose and browser.tabs.warnOnCloseOtherTabs from about:config look to be fixed and work as expected.

Based on thees I consider this -> Verified Fixed.
Comment 87 supersapper89 2012-12-07 14:08:28 PST
It is NOT resolved. I JUST tried it and it's still prompting me! I am using Windows Vista with FF17. The problem is that the checkbox ONLY applies to closing the whole window. If I have right clicked and chosen "Close Other Tabs" That means I know what I'm trying to do and want it done. It's irritating to me that I have to put up with this simply because a few click happy people don't want to take responsibility for their own mistakes. Here's a SIMPLE suggestion: PUT IN A SECOND CHECK BOX, to let me choose the circumstances under which I want all tabs closed. i.e. "warn when closing a window with multiple tabs" AND "Warn when closing all but the current tab".
Comment 88 Nathan Williams 2012-12-09 07:51:50 PST
Is there a bug open to debate restoring the original functionally of the "Warn me when closing multiple tabs" checkbox.  I wish to vote on it.  I can't find it.

I vehemently disagree with the disabling of this.  And while I appreciate the adding of the about:config setting as a work around I really want the original feature restored.

Also isn't having a checkbox in the options that does nothing not a bug itself?  That checkbox is still there in FF17 and it does nothing.
Comment 89 blake.marcia 2012-12-11 08:33:17 PST
(In reply to Nathan Williams from comment #88)
> Is there a bug open to debate restoring the original functionally of the
> "Warn me when closing multiple tabs" checkbox.  I wish to vote on it.  I
> can't find it.

There is an Unconfirmed Bug 801072, "Add a visible preference to disable 'Close other tabs' prompt." (See also Comment 59 above, from minus54: "Please post to the new bug 801072 if you want a visible option to disable it. Thank you.")

> I vehemently disagree with the disabling of this.  And while I appreciate
> the adding of the about:config setting as a work around I really want the
> original feature restored.

Me, too.

> Also isn't having a checkbox in the options that does nothing not a bug
> itself?  That checkbox is still there in FF17 and it does nothing.

I agree.
Comment 90 Lukas Blakk [:lsblakk] use ?needinfo 2012-12-11 11:45:43 PST
This should be fixed on esr17 since it shipped with Firefox 17.
Comment 91 supersapper89 2012-12-11 12:02:19 PST
It SHOULD be fixed, as I've been told multiple times, but it's NOT. I HAVE FF17, and it STILL doesn't allow me to disable the pop-up. Here's a suggestion: Put a "Do not warn me about this again" checkbox in EVERY warning pop-up. Then I can choose what warnings I still want to see, customized for ME.
Comment 92 supersapper89 2012-12-11 12:03:53 PST
It SHOULD be fixed, as I've been told multiple times, but it's NOT. I HAVE FF17, and it STILL doesn't allow me to disable the pop-up. Here's a suggestion: Put a "Do not warn me about this again" checkbox in EVERY warning pop-up. Then I can choose what warnings I still want to see, customized for ME.
Comment 93 Nathan Williams 2012-12-11 12:08:22 PST
(In reply to supersapper89 from comment #92)
> It SHOULD be fixed, as I've been told multiple times, but it's NOT. I HAVE
> FF17, and it STILL doesn't allow me to disable the pop-up. Here's a
> suggestion: Put a "Do not warn me about this again" checkbox in EVERY
> warning pop-up. Then I can choose what warnings I still want to see,
> customized for ME.

Have you set the about:config setting mentioned in post 67?   That will turn off the dialog.  The checkbox in config/tabs is dead and has no function.   Why they call this fixed when they didn't remove that setting toggle is beyond me.
Comment 94 pc macdonald 2012-12-11 14:07:06 PST
With respect to Comment 93, and subsequently, his reference to Comment 67, I have tried the browser.tabs.warnOnClose = FALSE; it doesn't work.

I still get the frustrating confirmation dialog every time.

This is silliness, and this problem certainly is not fixed.
Comment 95 pc macdonald 2012-12-11 14:08:08 PST
(In reply to pc macdonald from comment #94)
> With respect to Comment 93, and subsequently, his reference to Comment 67, I
> have tried the browser.tabs.warnOnClose = FALSE; it doesn't work.
> 
> I still get the frustrating confirmation dialog every time.
> 
> This is silliness, and this problem certainly is not fixed.

17.0.1
Comment 96 Manachi 2012-12-19 17:20:05 PST
I don't think this is fixed. I'm on 17.0.1 and I have unticked "Warn me when closing multiple tabs", and then when I click "Close other Tabs", I get prompted with "You are about to close x tabs. Are you sure you want to continue?".  That's a bug.

In my opinion there is something very clearly broken here.  I feel that this and bug #277079 have just gone on a very flawed path.  My opinion is this: If a user unticks the option "Warn me when closing multiple tabs", then the behaviour should be that it should no longer warn you when closing multiple tabs. This is the expected behaviour based on the crystal clear, flawlessly concise and completely unambiguous wording, and thus it is the desired behaviour.  If people are making mistakes by selecting the wrong options, or "accidentally" clicking things, then they can have that option selected, fine.  But it completely defies logic to ignore that preference for the rest of us.  Since when is "ignoring a preference" a solution?
Comment 97 pc macdonald 2012-12-20 20:37:10 PST
(In reply to Manachi from comment #96)
> I don't think this is fixed. I'm on 17.0.1 and I have unticked "Warn me when
> closing multiple tabs", and then when I click "Close other Tabs", I get
> prompted with "You are about to close x tabs. Are you sure you want to
> continue?".  That's a bug.
> 
> In my opinion there is something very clearly broken here.  I feel that this
> and bug #277079 have just gone on a very flawed path.  My opinion is this:
> If a user unticks the option "Warn me when closing multiple tabs", then the
> behaviour should be that it should no longer warn you when closing multiple
> tabs. This is the expected behaviour based on the crystal clear, flawlessly
> concise and completely unambiguous wording, and thus it is the desired
> behaviour.  If people are making mistakes by selecting the wrong options, or
> "accidentally" clicking things, then they can have that option selected,
> fine.  But it completely defies logic to ignore that preference for the rest
> of us.  Since when is "ignoring a preference" a solution?

Well said.

Why is this ___BUG____   ___!!!!___ being treated so ___STUPIDLY___ by what ARE very likely a VERY BRIGHT BUNCH OF PROGRAMMERS?

I just don't get it.  The problem is obvious... to the point of ridiculous.

I shall not repeat the obvious.

pc
Comment 98 mrvotruba 2012-12-22 09:52:52 PST
> Why is this ___BUG____   ___!!!!___ being treated so ___STUPIDLY___
> by what ARE very likely a VERY BRIGHT BUNCH OF PROGRAMMERS?

So well put.  Firefox has been losing ground in the browser war for some time now, these programmers are part of the problem(s) and helping to do Firefox in.

While they fantasize they take care of the decreasing number of "novices," BUGS like this that flash on the long-time users' screens even several times an hour, will eventually push more of them to look for greener pastures, too.
Comment 99 Loic 2013-01-08 03:25:19 PST
*** Bug 827464 has been marked as a duplicate of this bug. ***
Comment 100 Mihai Morar, (:MihaiMorar) 2013-01-08 07:46:19 PST
Based on Comment 90 and on my verification done on ESR 17.0.2 I consider this issue Verified Fixed.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0(20130107124423)
Comment 101 Nathan Williams 2013-01-08 07:59:50 PST
(In reply to MarioMi from comment #100)
> Based on Comment 90 and on my verification done on ESR 17.0.2 I consider
> this issue Verified Fixed.
> 
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101
> Firefox/17.0(20130107124423)

Have you read Comment 89?   This is an UNDESIRED disabling of a menu item and turning it into an hack workaround.  This is being promoted as a desired change by a misguided MINORITY.   UNDO THIS!
Comment 102 Mihai Morar, (:MihaiMorar) 2013-01-09 00:29:49 PST
I will set this back as resolved but please attach a screencast to see your STR and where you issue appears.
Comment 103 10110010 2013-01-19 18:27:58 PST
browser.tabs.warnOnClose & browser.tabs.warnOnCloseOtherTabs fixes this (18.0.1), though it's ridiculous that the option in 'tabs' doesn't have this same functionality. If this is going to be the case, you might as well remove it..
Comment 104 10110010 2013-01-19 18:47:33 PST
Sorry for the double post but some comments here are beyond silly. I would expect this kind of logic in a bloated program written by amateurs, not Firefox. I use Firefox primarily for its functionality and GUI. Having to search about:config for such a simple option is a waste of not only my time, but others who use FF for the same reason (evidently). Most people do not like being nagged. I can't understand how this is fixed.
Comment 105 thecarofmiki 2013-01-20 05:25:24 PST
(In reply to 10110010 from comment #103)
> browser.tabs.warnOnClose & browser.tabs.warnOnCloseOtherTabs fixes this
> (18.0.1), though it's ridiculous that the option in 'tabs' doesn't have this
> same functionality. If this is going to be the case, you might as well
> remove it..

I would like to thank you for your solution. t worked like a charm. Although I now have to learn to refrain from hitting enter whenever I close other tabs
Comment 106 Richard Elkins 2013-02-25 10:02:45 PST
Some people want to be warned when closing multiple tabs at once and some do not.  That's why we need choices.  

The Edit > Preferences > Warn me when closing multiple tabs check-box does not work in Firefox version 19 on Linux and Windows 7.  Changing the preference in either direction has no effect on the about:config browser.tabs.warnOnCloseOtherTabs variable and the related operations.  It should.  Users should avoid about:config except as a last result (hence, the warning when requesting that URL the first time).

Why is this anomaly report marked "resolved fixed"?  This seems to be a preference setting that doesn't do its job as implied by its name.
Comment 107 Nathan Williams 2013-02-25 10:20:19 PST
(In reply to Richard Elkins from comment #106)
> Some people want to be warned when closing multiple tabs at once and some do
> not.  That's why we need choices.  
> 
> The Edit > Preferences > Warn me when closing multiple tabs check-box does
> not work in Firefox version 19 on Linux and Windows 7.  Changing the
> preference in either direction has no effect on the about:config
> browser.tabs.warnOnCloseOtherTabs variable and the related operations.  It
> should.  Users should avoid about:config except as a last result (hence, the
> warning when requesting that URL the first time).
> 
> Why is this anomaly report marked "resolved fixed"?  This seems to be a
> preference setting that doesn't do its job as implied by its name.

Because in BUG#227079 about 3 programers who apparently are so stupid/clumsy that they turn off the warning yet still manage to accidentally close tabs managed to shanghai the GUI design process and "FIX" this "bug".  Seriously read that bug.  Most retarded design process ever.   And it is not even fixed.  The checkbox is still there and does nothing and the same function has now been converted into a obscure about:config setting that no end user should want to do.  If you have to goto the backdoor settings page to restore a function then the program is BROKEN and the process that DELIBERATELY got you to that point is broken.   The fix was obviously addressed by the original function in the program.  If you are that prone to accidentally killing tabs then you should leave the warning box checked.  Which is what disabling the function all together is doing.  The default was checked.  How frakin hard is it to just leave it that way?
Comment 108 supersapper89 2013-02-26 02:21:22 PST
NOT FIXED!!!!!!!! It STILL prompts when closing multiple tabs (NOT when closing the window)
NOT FIXED!!!!!!!! It STILL prompts when closing multiple tabs (NOT when closing the window)
NOT FIXED!!!!!!!! It STILL prompts when closing multiple tabs (NOT when closing the window)
NOT FIXED!!!!!!!! It STILL prompts when closing multiple tabs (NOT when closing the window)
NOT FIXED!!!!!!!! It STILL prompts when closing multiple tabs (NOT when closing the window)
NOT FIXED!!!!!!!! It STILL prompts when closing multiple tabs (NOT when closing the window)
NOT FIXED!!!!!!!! It STILL prompts when closing multiple tabs (NOT when closing the window)
NOT FIXED!!!!!!!! It STILL prompts when closing multiple tabs (NOT when closing the window)
NOT FIXED!!!!!!!! It STILL prompts when closing multiple tabs (NOT when closing the window)
NOT FIXED!!!!!!!! It STILL prompts when closing multiple tabs (NOT when closing the window)
NOT FIXED!!!!!!!! It STILL prompts when closing multiple tabs (NOT when closing the window)
NOT FIXED!!!!!!!! It STILL prompts when closing multiple tabs (NOT when closing the window)
NOT FIXED!!!!!!!! It STILL prompts when closing multiple tabs (NOT when closing the window)
NOT FIXED!!!!!!!! It STILL prompts when closing multiple tabs (NOT when closing the window)
NOT FIXED!!!!!!!! It STILL prompts when closing multiple tabs (NOT when closing the window)
NOT FIXED!!!!!!!! It STILL prompts when closing multiple tabs (NOT when closing the window)
Comment 109 10110010 2013-02-26 13:06:54 PST
@ Mariomi: Good grief, you can not be this dense. Several people are trying to tell you something. Please listen.

The functionality of '**WARN ME** me when closing multiple tabs' is PARTIALLY BROKEN. When it's unticked and you try closing multiple tabs, people are STILL being warned. This is an issue on 12.04 Ubuntu x64 AND x32, 12.10 Lubuntu x32 and Windows 7 x32 with the latest SP.

If it's not already clear, just look at the damn wording again: "****WARN ME**** when ****CLOSING MULTIPLE TABS****. I should not be warned if I don't have the option selected.
Comment 110 XtC4UaLL [:xtc4uall] 2013-02-26 13:22:59 PST
You (and as it seems others) likely want Bug 801072.
This Bug Report - as proposed per Comment 16 introducing the Pref "browser.tabs.warnOnCloseOtherTabs" - is fixed properly.
Comment 111 Nathan Williams 2013-02-26 14:42:31 PST
Those reading here should also read bug https://bugzilla.mozilla.org/show_bug.cgi?id=277079

That is what has caused all the problems to begin with.  Bug#277079 asked that the "Close other Tabs" menu option ALWAYS prompt with a warning when closing multiple tabs.  Ignoring any preference that is set.  Enough users can irked at that bug that instead of reversing it a NEW method, using a about:config setting to disable the prompt be put into the code.  That is discussed HERE in this bug you are reading now.

Bug#801072 is discussing the merits of this whole mess.

If you want to complain about the actions taken in Bug#277079 please goto bug#801072 and post a complaint there.
Comment 112 Nathan Williams 2013-02-26 14:44:36 PST
Typo: "can irked" should read "got irked"
Comment 113 10110010 2013-02-26 15:31:35 PST
So let me get this straight. Users were complaining saying closing multiple tabs without a warning was unintuitive? So that's why people suggested putting an option to on the warning tab itself..? How hard would it have been to just keep the preference selected.. Way to complicate an issue that doesn't need to be complicated. Bravo.
Comment 114 Nathan Williams 2013-02-26 15:51:23 PST
Yes.   And it was sloppily done.  Bug#277079 turns this into always prompt. FINE. One would think that they would have removed that checkbox if they were going to take away the feature. Did the? Heck NO, that checkbox is still there and is a dead function.

To "fix" that problem they put a back door about:config setting in. (Apparantly UNDO is only a function in word processors not bugzilla.) So NOW we have a dead checkbox that doesn't do what it says and a hidden function that does what the checkbox does yet has nothing to do with said checkbox.  The old checkbox is still dead, no matter how you set about:config and the new about:config toggle has to be known by the end user in order to make use of it.   With no doubt said end user pounding his head against a wall in frustration trying to figure out why a labeled checkbox that use to work in FF15 doesn't now.
Comment 115 Manachi 2013-02-26 21:53:09 PST
I find it appalling, and outright insulting that the developers aren't listening to what is a clear, obvious, logical and valid concern we are pointing out.  Why did Mariomi just come in here and resolve/verify it withotu responding to us?  Is he blind? Or incompetent?
Comment 116 Mihai Morar, (:MihaiMorar) 2013-02-27 00:13:46 PST
First off all Manachi and the other new people to bugzilla, I am not confirming any fix as beeing verified without investigations and verifications. I guess you don't understand what this bug is about, as XtC said in Comment 110, fix done by Ed in Comment 23 and Ryan in Comment 77 are resolving this issue. I can make you sure that they know what they are doing as long they do this day by day, so if you want another option without the existing one in about:config, just file a new bug as enhancement. I trink I was clear enought now.

I confirm the fix is verified on Latest Nightly (2013-02-26) too.
Comment 117 Mihai Morar, (:MihaiMorar) 2013-02-27 00:21:06 PST
(In reply to Manachi from comment #115)
> Why did Mariomi just come in here and resolve/verify it
> withotu responding to us?  Is he blind? Or incompetent?

And before beeing insulting, here you can learn the entire proceess of How to verify bugs, if you don't know yet.

https://etherpad.mozilla.org/Firefox18-bug-verification

https://etherpad.mozilla.org/Firefox19-bug-verification
Comment 118 blake.marcia 2013-02-27 08:34:04 PST
I executed the workaround (changing the warning behavior in about:config) some time ago, so I'm no longer annoyed by that relentless warning every time I close multiple tabs. But of course the "Warn me when closing multiple tabs" option in Firefox [17.0.1]/Preferences/Tabs (on Mac OS X 10.6.8) is still non-functional: unless the user knows about and implements the about:config hack, then even when that purportedly explicit "Warn me..." option is explicity DE-selected, the user will still see the closing-multiple-tabs warning. It's clear that this unfixed, egregious bug is going to remain marked "Verified Fixed." After dealing with this in two upgrades (16 and 17), I quit. I am not going to waste any more energy thinking about it. I've beeen a steadfast user of Firefox since its earliest days - even when that gave me problems on some web sites. But I've finally taken the cure, and it's called Chrome.
Comment 119 Richard Elkins 2013-02-27 14:39:46 PST
Chrome has its own warts but to each their own.  I wouldn't be so hasty to write off the Firefox just because of one little roach - especially since it has a straight-forward work-around.
Comment 120 blake.marcia 2013-02-28 06:10:11 PST
Yes, Chrome has its own warts, as does any software (remember the old saying, "That's why they call it software"?). But IMO it's more secure at present than Firefox, and for me that's a big plus. This is not a decision made in haste - far from it. After all, as a high-intensity researcher, I probably run a browser more than any other user app on my system, and how any browser operates across Web sites is critical to its usefulness. So it behooves me to consider very carefully which one(s) I use. I'm not bailing on Firefox because of this one bug, but because for some time, each upgrade has disappointed me more than its predecessor; for me, the quality of the Firefox experience has been in declne for a long while. WRT this specific bug, however, I also must add that any workaround which requires a user to know about and use a config file to overcome a bug that has existed in an explicit Preferences tab for at least two versions (remember, I stopped upgrading at 17) is not "straight-forward" and should not be considered acceptable in any context. The response of Firefox coders to this issue has been obtuse at best, and I remain firmly of the opinion that this bug is *not* "fixed."
Comment 121 Nathan Williams 2013-02-28 07:59:52 PST
(In reply to Richard Elkins from comment #119)
> Chrome has its own warts but to each their own.  I wouldn't be so hasty to
> write off the Firefox just because of one little roach - especially since it
> has a straight-forward work-around.

I don't call using an about:config setting as a work around  straight-forward.  End users have to know about it to begin with and you are still left with a menu option that states you will or will not be warned on closing tabs that does not fully work.  It does work when you exit the program entirely.  But not on the close other tabs function.  That menu item either needs to be:

1) Restored to it's original function reverting the changes put in place by #277079
2)  The text of that item edited so that it refers only to closing down FF with more then one tab opened.  Ex:  "Warn me when I shut down Firefox with more then one tab open."
3) Removed altogether.

Personally I vote for #1.   Bug 277079 should have NEVER been done.  Comment 2 in that bug was the correct assessment.
Comment 122 Nathan Williams 2013-02-28 08:01:33 PST
Damn it. The comment link should be for bug 277079 not for this thread.  I wish we could edit comments.  Sorry.
Comment 123 michael ussher 2013-06-17 19:50:26 PDT
Also hate this with a passion.  somewhere around Ver 16 said it would be gone in ver 19.  Were at ver21 now and its still here.

The only thing I would call actually 'irritating' about firefox.

even if i did hit 'close all tabs' and they all closed without warning, i could easily get everything back with a few key taps of ctrl+shift+t.

The warning message is irritating.  having an option to turn it off that doesn't work is doubly irritating.
Comment 124 »Q« 2013-06-19 16:05:45 PDT
(In reply to michael ussher from comment #123)

> The warning message is irritating.  having an option to turn it off that
> doesn't work is doubly irritating.

This bug is marked FIXED, and I haven't had any trouble turning it off since the fix landed.  For figuring out why things aren't working for you, you might try <https://support.mozilla.org/>.
Comment 125 michael ussher 2013-06-19 16:23:56 PDT
It shouldn't be marked as fixed, its not.

Steps:
* in preferences, uncheck "Warn me when closing multiple tabs"
* open 3 or 4 tabs and right click one of them, select "Close other tabs"

Expected behavior:
They all close without warning.

Actual behavior:
Prompted with a warning "You are about to close 4 tabs, are you sure you want to continue?"

This wasn't the case before FF16 and I expected it to be fixed by FF19 but now were up to FF21 and its still irritating.
Comment 126 Richard Elkins 2013-06-19 16:25:45 PDT
Boxcars,

Please see comment 106.  I disagree with the statement in comment 124.  This issue is still not fixed in Firefox version 21 for Linux.  I am still unable through preferences to stop being warned about closing multiple tabs.  I still need to use the "about:config" URL technique to get this warning shut off.  Please note that I appreciate that some folks prefer being warned.

Richard
Comment 127 10110010 2013-06-19 22:52:59 PDT
To those saying this issue = fixed, I would advise carefully reading the preference for this: "Warn me when closing multiple tabs". This is a simple sentence that can be interpreted only one way. How could it be so grotesquely misconstrued FOR OVER A YEAR?
Firefox, please stop misrepresenting things. This is pitiful beyond words and forces the people who don't want a warning to resort to back end fixes that may result in browser corruption (especially for those who aren't tech savvy). People trust you to provide a smart, stable and secure browsing experience. If you can't and won't get your act together, I and surely others will find a company who can. Because surely a company who can't figure out something so simple doesn't deserve the trust or even consideration of millions.
Comment 128 »Q« 2013-06-24 16:01:02 PDT
(In reply to Richard Elkins from comment #126)

> I am still unable through preferences to stop being warned about closing multiple tabs.  > I still need to use the "about:config" URL technique to get this warning shut
> off.

That's bug 801072
Comment 129 Richard Elkins 2013-06-26 15:06:31 PDT
(In reply to »Q« from comment #128)
> (In reply to Richard Elkins from comment #126)
> 
> > I am still unable through preferences to stop being warned about closing multiple tabs.  > I still need to use the "about:config" URL technique to get this warning shut
> > off.
> 
> That's bug 801072

These seem to be duplicate bug reports of each other.  

My point was that it's not a support issue for one person as comment #124 inferred; this is a misbehavior in the product for everyone in that the check box "Edit > Preferences > Warn me when closing multiple tabs" does not function as advertised.
Comment 130 »Q« 2013-06-28 21:55:34 PDT
(In reply to Richard Elkins from comment #129)

Not dupes.  This bug is marked "FIXED" because you can now turn off the warning.  bug 801072 isn not marked "FIXED" because you still don't have a way to do that via the GUI.

Hopefully 801072 won't wind up with as much bugspam as this one has;  bugzilla's not the place for repeating how dire one thinks issues are.
Comment 131 Andreas Eibach 2013-10-07 13:24:01 PDT
(In reply from comment #130)
"bug 801072 isn not marked "FIXED" because you still don't have a way to do that via the GUI."

Thanks!!

This is what drove me insane here on Firefox 24 (Lubuntu 13.10 b2), because unchecking the box in Settings did not have any effect at all. So I will refrain from creating another duplicate.

Note You need to log in before you can comment on or make changes to this bug.