Last Comment Bug 772153 - unprefix CSS cursor: -moz-zoom-in | -moz-zoom-out
: unprefix CSS cursor: -moz-zoom-in | -moz-zoom-out
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla24
Assigned To: mjh563
:
:
Mentors:
Depends on: 204841 879119 879131
Blocks: unprefix
  Show dependency treegraph
 
Reported: 2012-07-09 11:17 PDT by j.j.
Modified: 2013-09-29 01:33 PDT (History)
13 users (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Another testcase (495 bytes, text/html)
2013-05-31 07:04 PDT, mjh563
no flags Details
Add support for unprefixed cursor:zoom-in/out (6.17 KB, patch)
2013-05-31 07:14 PDT, mjh563
bzbarsky: review+
dbaron: feedback+
Details | Diff | Splinter Review

Description j.j. 2012-07-09 11:17:04 PDT
It's named here:
http://wiki.csswg.org/spec/vendor-prefixes#specific-cases

and Opera has unprefixed support for cursor: zoom-in and zoom-out since 11.5
Comment 1 j.j. 2012-07-10 09:08:07 PDT
Adding my personal pet bug 204841 as dependency, may be it helps...
Comment 2 j.j. 2013-04-28 04:00:37 PDT
nice testcase is here:
http://www.elektronotdienst-nuernberg.de/bugs/cursor.html
Comment 3 mjh563 2013-05-31 07:04:54 PDT
Created attachment 756555 [details]
Another testcase

See also http://www.w3.org/TR/css3-ui/#cursor
Comment 4 mjh563 2013-05-31 07:14:16 PDT
Created attachment 756560 [details] [diff] [review]
Add support for unprefixed cursor:zoom-in/out
Comment 5 Boris Zbarsky [:bz] (still a bit busy) 2013-05-31 12:06:25 PDT
Comment on attachment 756560 [details] [diff] [review]
Add support for unprefixed cursor:zoom-in/out

r=me on the code, but dbaron should probably ok the general idea.
Comment 6 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2013-06-02 18:32:51 PDT
Comment on attachment 756560 [details] [diff] [review]
Add support for unprefixed cursor:zoom-in/out

Sounds good to me, but please file a bug on removing the prefixed ones in a few releases.
Comment 7 Ryan VanderMeulen [:RyanVM] 2013-06-03 05:51:16 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/6bff277e306c
Comment 8 Ryan VanderMeulen [:RyanVM] 2013-06-03 13:05:46 PDT
https://hg.mozilla.org/mozilla-central/rev/6bff277e306c
Comment 9 j.j. 2013-06-03 19:53:47 PDT
(In reply to David Baron [:dbaron] (in W3C meetings through June 11) (don't cc:, use needinfo? instead) from comment #6)

> Sounds good to me, but please file a bug on removing the prefixed ones in a
> few releases.

Filed Bug 879119 (because nobody else did)

[Seems we aren't consistent in having this kind of bugs opend. Perhaps I'll look and see to file more of it]

Note You need to log in before you can comment on or make changes to this bug.