Disable webapps support on FF 15

VERIFIED FIXED

Status

()

P1
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: jsmith, Assigned: wesj)

Tracking

Trunk
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox15+ verified)

Details

(Whiteboard: [blocking-webrtandroid1+])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Webapps support for FF for Android will not be ready in time for FF 15, so let's disable the functionality for it. We need to disable the install prompt and the management of apps.
(Reporter)

Updated

6 years ago
tracking-fennec: --- → ?
(Reporter)

Comment 1

6 years ago
Note for tracking nom - Android WebRT triage decided that we will not support web apps for FF for Android in FF 15, but we do not want this functionality active.
(Reporter)

Updated

6 years ago
tracking-fennec: ? → ---
tracking-firefox15: --- → ?
tracking-firefox15: ? → +
Assigning to blassey for now as the point person for disabling when the time comes. Brad, if there's someone else who could/should be on this feel free to re-assign to them.
Assignee: nobody → blassey.bugs
Wes can track this. Take a look at what desktop did to disable. We probably want to mimic that.
Assignee: blassey.bugs → wjohnston
(Reporter)

Updated

6 years ago
Priority: -- → P1
Whiteboard: [blocking-webrtandroid1+]
(Assignee)

Comment 4

6 years ago
Desktop is bug 772638.
(Reporter)

Updated

6 years ago
Blocks: 766259
(Assignee)

Comment 5

6 years ago
Created attachment 645933 [details] [diff] [review]
Patch

Webapps.manifest register the navigator properties, so I think (based on the desktop patch) this is all we need.
Attachment #645933 - Flags: review?(blassey.bugs)
Attachment #645933 - Flags: review?(blassey.bugs) → review+
(Assignee)

Comment 6

6 years ago
Comment on attachment 645933 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): None
User impact if declined: navigator.webapps methods will exist. could break sites that think that implies webapps support.
Testing completed (on m-c, etc.): Not landing on mc
Risk to taking this patch (and alternatives if risky): Low risk. same thing is on desktop firefox for 15.
String or UUID changes made by this patch: none.
Attachment #645933 - Flags: approval-mozilla-beta?
Comment on attachment 645933 [details] [diff] [review]
Patch

Please update the status for firefox15 to fixed when this lands.
Attachment #645933 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
status-firefox14: --- → fixed
(Assignee)

Updated

6 years ago
status-firefox14: fixed → ---
status-firefox15: --- → fixed
(Reporter)

Updated

6 years ago
Whiteboard: [blocking-webrtandroid1+] → [blocking-webrtandroid1+], [qa+]
(Assignee)

Comment 9

6 years ago
Note this just kills navigator.apps stuff. I didn't remove about:apps. If that's wanted please say something.

There is no UI to get to it, and it will probably just fail to work without some of these navigator methods.

Updated

6 years ago
Status: RESOLVED → VERIFIED
status-firefox15: fixed → verified

Updated

6 years ago
Whiteboard: [blocking-webrtandroid1+], [qa+] → [blocking-webrtandroid1+]
(Assignee)

Updated

6 years ago
Blocks: 786058
You need to log in before you can comment on or make changes to this bug.