Last Comment Bug 772406 - Make nsSVGGlyphFrame::UpdateBounds reuse GetBBoxContribution
: Make nsSVGGlyphFrame::UpdateBounds reuse GetBBoxContribution
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla16
Assigned To: Jonathan Watt [:jwatt]
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks: 772017
  Show dependency treegraph
 
Reported: 2012-07-10 06:13 PDT by Jonathan Watt [:jwatt]
Modified: 2012-07-10 20:30 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (4.39 KB, patch)
2012-07-10 06:30 PDT, Jonathan Watt [:jwatt]
roc: review+
Details | Diff | Splinter Review

Description Jonathan Watt [:jwatt] 2012-07-10 06:13:40 PDT
nsSVGGlyphFrame::UpdateBounds should reuse GetBBoxContribution instead of duplicating code.
Comment 1 Jonathan Watt [:jwatt] 2012-07-10 06:30:50 PDT
Created attachment 640577 [details] [diff] [review]
patch

I'm doing this separately from bug 772017, and passing flags to GetBBoxContribution that are consistent with what the code does now, even though I'm going to change them in bug 772017. This is because - although I think the patch is okay - there are so many layers of indirection in the nsSVGGlyphFrame code that it's hard to be totally sure. I want this separate patch that's as consistent with what we do now as possible so any regressions that might be caused by using GetBBoxContribution can be squarely blamed on this bug, and not flag changes.
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-07-10 20:30:37 PDT
https://hg.mozilla.org/mozilla-central/rev/9cb90658bd51

Note You need to log in before you can comment on or make changes to this bug.