results.py shouldn't say "Graph server unreachable" when the test name isn't recognised

RESOLVED WONTFIX

Status

Testing
Talos
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({sheriffing-untriaged})

Trunk
sheriffing-untriaged
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Example log:
https://tbpl.mozilla.org/php/getParsedLog.php?id=13398407&tree=Firefox
(search for "Graph server unreachable")

We've trained ourselves just to ignore/retrigger failures due to graphserver being down; so it's not overly helpful to say:

{
Traceback (most recent call last):
  File "run_tests.py", line 358, in <module>
    main()
  File "run_tests.py", line 355, in main
    run_tests(parser.config)
  File "run_tests.py", line 331, in run_tests
    talos_results.output(**results_urls)
  File "/home/cltbld/talos-slave/talos-data/talos/results.py", line 86, in output
    raise e
utils.talosError: 'Graph server unreachable (5 attempts)\nsend failed, graph server says:\nNo test_name called \'tspaint_places_generated_med\' can be found\n  File "/var/www/html/graphs/server/pyfomatic/collect.py", line 271, in handleRequest\n    metadata = MetaDataFromTalos(databaseCursor, databaseModule, inputStream)\n  File "/var/www/html/graphs/server/pyfomatic/collect.py", line 63, in __init__\n    self.doDatabaseThings(databaseCursor)\n  File "/var/www/html/graphs/server/pyfomatic/collect.py", line 106, in doDatabaseThings\n    raise DatabaseException("No test_name called \'%s\' can be found" % self.test_name)\n\n'
program finished with exit code 1
}

Since people just star it as unreachable.

Comment 1

6 years ago
So I *think* this should be pretty easy to fix.  If we get a result code back (that is, an HTTP response) we should probably 1. break out of the loop; and 2. err out (or at least display a different message) if the error code isn't a 200

Updated

6 years ago
Duplicate of this bug: 772997
(Reporter)

Updated

6 years ago
Whiteboard: [sheriff-want]
(Reporter)

Updated

5 years ago
Keywords: sheriffing-untriaged
Whiteboard: [sheriff-want]
Blocks: 1124697
See Also: → bug 1204303
oh, we don't use graph server anymore!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.