Last Comment Bug 772690 - Remove content-order check from SortByZOrder
: Remove content-order check from SortByZOrder
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla17
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
Depends on: 735898 867569
Blocks: 741682 783474
  Show dependency treegraph
 
Reported: 2012-07-10 16:38 PDT by Daniel Holbert [:dholbert]
Modified: 2013-05-01 14:56 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix [r=dbaron granted in bug 735898 comment 47] (1.38 KB, patch)
2012-07-23 08:19 PDT, Daniel Holbert [:dholbert]
dholbert: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] 2012-07-10 16:38:24 PDT
Filing this bug on finishing off / landing patch 8 in bug 735898, to remove the secondary content-order sort when we're sorting display-lists by z-index.

For background, see bug 735898 comment 50 & beyond.
Comment 1 Daniel Holbert [:dholbert] 2012-07-10 16:54:52 PDT
Actually, it looks like bug 748646 is already filed as a followup on this.

*** This bug has been marked as a duplicate of bug 748646 ***
Comment 2 Daniel Holbert [:dholbert] 2012-07-23 08:11:35 PDT
Actually, I shouldn't have duped this -- this bug isn't really a duplicate of bug 772690 -- it just depends on it.

That bugs' patches are now landed (on m-i), so the content-order-sort in SortByZOrder can now land without causing orange.

So, I'll land the SortByZOrder tweak in this bug. (simply using the changeset for part 8 from bug 735898, but with commit-message updated to point to this bug instead of that one)
Comment 3 Daniel Holbert [:dholbert] 2012-07-23 08:19:49 PDT
Created attachment 644938 [details] [diff] [review]
fix [r=dbaron granted in bug 735898 comment 47]

Here's the patch (review already granted in bug 735898 comment 47)
Comment 4 Daniel Holbert [:dholbert] 2012-07-23 08:29:29 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/a9053e89bab9
Comment 5 Ed Morley [:emorley] 2012-07-24 03:02:40 PDT
https://hg.mozilla.org/mozilla-central/rev/a9053e89bab9

Note You need to log in before you can comment on or make changes to this bug.