If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Syntax highlighter" button confusing

RESOLVED FIXED

Status

Mozilla Developer Network
Wiki pages
P3
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: openjck, Unassigned)

Tracking

Details

(Whiteboard: u= c= s= p=)

(Reporter)

Description

5 years ago
A user mentioned not understanding why the syntax highlighter button of the WYSIWYG is sometimes disabled. I actually had the same confusion when I first started using it.

It looks like the button cannot be used unless <pre> text is selected.

Some discussion would help here. The user requested that we just add a tooltip to the button (like "Button is disabled because <pre> text is not selected") but I would only use that as a last result (it's sort of like sticking the word "Push" on a confusing door).

What if the syntax highlighter just wrapped selected text in a <pre> under the hood?
I would like this as well, if it would automatically add a <pre> and just work.
Duplicate of this bug: 733803
(Reporter)

Updated

5 years ago
Priority: -- → P3
Oh, this was fixed a while ago.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

5 years ago
Yep. Looks great.
(Assignee)

Updated

5 years ago
Version: Kuma → unspecified
(Assignee)

Updated

5 years ago
Component: Website → Landing pages
Product: Mozilla Developer Network → Mozilla Developer Network
You need to log in before you can comment on or make changes to this bug.