Last Comment Bug 772883 - System proxy settings on Linux in nightlies (16.0a1) are broken
: System proxy settings on Linux in nightlies (16.0a1) are broken
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Widget: Gtk (show other bugs)
: 16 Branch
: x86 Linux
: -- normal (vote)
: mozilla17
Assigned To: Karl Tomlinson (:karlt)
:
Mentors:
Depends on:
Blocks: gtk3
  Show dependency treegraph
 
Reported: 2012-07-11 08:33 PDT by Georg Koppen
Modified: 2014-07-03 07:00 PDT (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed


Attachments
MissingSystemProxySettings.png (43.21 KB, image/png)
2012-07-11 08:33 PDT, Georg Koppen
no flags Details
replace MOZ_ENABLE_GTK with MOZ_WIDGET_GTK to restore nsUnixProxyModule (1.95 KB, patch)
2012-08-01 20:24 PDT, Karl Tomlinson (:karlt)
roc: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Georg Koppen 2012-07-11 08:33:35 PDT
Created attachment 641062 [details]
MissingSystemProxySettings.png

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:10.0) Gecko/20100101 Firefox/10.0

Steps to reproduce:

I upgraded  Nightly on my Linux box to 16.0a1.


Actual results:

The system proxy settings option in the proxy preferences in Firefox vanished (see attachment) while it is still available on Aurora. Entering in the error console:

Components.classes["@mozilla.org/system-proxy-settings;1"]

gives

Warning: ReferenceError: reference to undefined property Components.classes['@mozilla.org/system-proxy-settings;1']
Source File: javascript:%20Components.classes["@mozilla.org/system-proxy-settings;1"]
Line: 1

provided javascript.options.strict is set to true. On Aurora I get:

@mozilla.org/system-proxy-settings;1

instead indicating the component is still available.

That is happening both on my Debian box with XFCE and on the latest Ubuntu with GNOME but not on Windows as far as I can see (I only had an old Win XP to test).


Expected results:

The system proxy settings should still be available.
Comment 1 Eric H. Jung 2012-07-11 11:18:34 PDT
It's missing from the UI because of this http://mxr.mozilla.org/mozilla-central/source/browser/components/preferences/connection.js#40

So the core question is why the undefined property? I doubt there's an error on Windows as the implementation is completely different. The linux/unix impl is here:

http://mxr.mozilla.org/mozilla-central/source/toolkit/system/unixproxy/nsUnixSystemProxySettings.cpp

Windows implementation is here:
http://mxr.mozilla.org/mozilla-central/source/toolkit/system/windowsproxy/nsWindowsSystemProxySettings.cpp
Comment 2 Jason Duell [:jduell] (needinfo me) 2012-07-11 11:38:35 PDT
I see this too.

But neither the lines in connection.js nor nsUnixSystemProxySettings has been changed since February, so it must be something else.

cc-ing reed, who touched the connection.js logic last.
Comment 3 Josh Matthews [:jdm] (away until 9/3) 2012-07-11 11:50:43 PDT
A regression range would probably be the most useful thing here.
Comment 4 Georg Koppen 2012-07-12 00:25:56 PDT
(In reply to Josh Matthews [:jdm] from comment #3)
> A regression range would probably be the most useful thing here.

The bug is showing up in ftp://ftp.mozilla.org/pub/firefox/nightly/2012-06-17-mozilla-central-debug/ but not in ftp://ftp.mozilla.org/pub/firefox/nightly/2012-06-16-mozilla-central-debug/.
Comment 5 Josh Matthews [:jdm] (away until 9/3) 2012-07-12 05:27:14 PDT
That should correspond to http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4e3362864fbd&tochange=264f0a7a878c&, but I'm not seeing any culprit stick out at me :/
Comment 6 Jason Duell [:jduell] (needinfo me) 2012-07-12 18:23:23 PDT
moving to Firefox, since AFAICT this is a UI issue and not the result of a necko change.
Comment 7 Georg Koppen 2012-07-12 23:46:08 PDT
This is definitely not only a Firefox issue. I can reproduce the bug on the latest Thunderbird Daily and Seamonkey Nightly as well. And why should that be a UI issue? Getting

ReferenceError: reference to undefined property Components.classes['@mozilla.org/system-proxy-settings;1']

does not seem to involve a UI at all IMO.
Comment 8 Alice0775 White 2012-07-13 05:05:18 PDT
Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/290c7dcdeac3
Mozilla/5.0 (X11; Linux i686; rv:16.0) Gecko/16 Firefox/16.0a1 ID:20120615225224
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/88d69928e3b1
Mozilla/5.0 (X11; Linux i686; rv:16.0) Gecko/16 Firefox/16.0a1 ID:20120615230725
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=290c7dcdeac3&tochange=88d69928e3b1

Suspected: Bug 627699
Comment 9 Karl Tomlinson (:karlt) 2012-07-17 11:39:37 PDT
Caused by http://hg.mozilla.org/mozilla-central/diff/88d69928e3b1/toolkit/library/nsStaticXULComponents.cpp

I assume we should just use MOZ_WIDGET_GTK and remove MOZ_ENABLE_GTK2 from toolkit/library/Makefile.in

Looks like there's no point even testing for gtk for nsAutoConfigModule.
Comment 10 Karl Tomlinson (:karlt) 2012-08-01 20:24:51 PDT
Created attachment 648203 [details] [diff] [review]
replace MOZ_ENABLE_GTK with MOZ_WIDGET_GTK to restore nsUnixProxyModule

I checked that nsStaticXULComponents.o now contains nsUnixProxyModule
(but haven't tried to pick up any GNOME proxy settings).
Comment 11 Karl Tomlinson (:karlt) 2012-08-06 20:11:34 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/77fea247fe32

Try build here (Reftest had GL layers enabled):
https://tbpl.mozilla.org/?tree=Try&rev=c91996287d43
Comment 12 Ed Morley [:emorley] 2012-08-07 07:34:27 PDT
https://hg.mozilla.org/mozilla-central/rev/77fea247fe32
Comment 13 Karl Tomlinson (:karlt) 2012-08-07 18:44:41 PDT
Comment on attachment 648203 [details] [diff] [review]
replace MOZ_ENABLE_GTK with MOZ_WIDGET_GTK to restore nsUnixProxyModule

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 627699
User impact if declined: losing proxy configuration from system settings
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky):
Low risk; this is restoring code that was accidentally removed.
String or UUID changes made by this patch: None.
Comment 14 Karl Tomlinson (:karlt) 2012-08-09 18:26:49 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/7c89662c3310

Note You need to log in before you can comment on or make changes to this bug.