Closed Bug 773102 Opened 7 years ago Closed 7 years ago

transition-duration and animation-duration should reject negative values at parse time

Categories

(Core :: CSS Parsing and Computation, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla16

People

(Reporter: dbaron, Assigned: dbaron)

References

Details

(Keywords: dev-doc-complete)

Attachments

(4 files)

Per resolution in the CSS working group's teleconference today, animation-duration and transition-duration should reject negative values at parse time.
http://lists.w3.org/Archives/Public/www-style/2012Jul/0265.html
Assignee: nobody → dbaron
Status: NEW → ASSIGNED
Attachment #641275 - Attachment description: Rename VARIANT_POSITIVE_LENGTH to VARIANT_NONNEGATIVE_DIMENSION since (a) it also applies to times and frequencies and (b) it allows 0. → Rename VARIANT_POSITIVE_LENGTH to VARIANT_NONNEGATIVE_DIMENSION since (a) it also applies to times and frequencies and (b) it allows 0. (patch 1)
Comment on attachment 641275 [details] [diff] [review]
Rename VARIANT_POSITIVE_LENGTH to VARIANT_NONNEGATIVE_DIMENSION since (a) it also applies to times and frequencies and (b) it allows 0.  (patch 1)

The parser code ungets and returns false if "tk->mNumber <= 0.0".  So as far as I can tell, it really is requiring a positive value....

And in fact, the spec for "perspective" claims that lengths "must be positive".  Or is the spec and the parser code wrong?
Attachment #641275 - Flags: review?(bzbarsky) → review-
Comment on attachment 641274 [details] [diff] [review]
Require animation-duration and transtion-duration to be nonnegative at parse time.  (, patch 3)

This seems fine, assuming the first patch is fine...
Attachment #641274 - Flags: review?(bzbarsky) → review+
Attachment #641274 - Attachment description: Require animation-duration and transtion-duration to be nonnegative at parse time. (, patch 2) → Require animation-duration and transtion-duration to be nonnegative at parse time. (, patch 3)
Comment on attachment 641988 [details] [diff] [review]
Rename VARIANT_POSITIVE_LENGTH to VARIANT_POSITIVE_DIMENSION since it also applies to times and frequencies.  (, patch 1)

r=me
Attachment #641988 - Flags: review?(bzbarsky) → review+
Comment on attachment 641989 [details] [diff] [review]
Add VARIANT_NONNEGATIVE_DIMENSION.  (, patch 2)

r=me
Attachment #641989 - Flags: review?(bzbarsky) → review+
You need to log in before you can comment on or make changes to this bug.