Last Comment Bug 773160 - expose a reduced 'navigator' object to frameworker workers
: expose a reduced 'navigator' object to frameworker workers
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: SocialAPI (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 17
Assigned To: Mark Hammond [:markh]
:
Mentors:
Depends on:
Blocks: 770679
  Show dependency treegraph
 
Reported: 2012-07-11 23:58 PDT by Mark Hammond [:markh]
Modified: 2012-08-04 11:53 PDT (History)
3 users (show)
jaws: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
expose a subset of navigator and add navigator specific tests (3.94 KB, patch)
2012-07-11 23:58 PDT, Mark Hammond [:markh]
no flags Details | Diff | Review
expose a subset of navigator and add navigator specific tests and include __exposedProps__ (4.10 KB, patch)
2012-07-12 00:05 PDT, Mark Hammond [:markh]
gavin.sharp: review+
Details | Diff | Review
Old patch neglected to call worker.terminate() which caused leaks in the test (4.22 KB, patch)
2012-07-15 22:29 PDT, Mark Hammond [:markh]
gavin.sharp: review+
Details | Diff | Review

Description Mark Hammond [:markh] 2012-07-11 23:58:08 PDT
Created attachment 641373 [details] [diff] [review]
expose a subset of navigator and add navigator specific tests

From https://bugzilla.mozilla.org/show_bug.cgi?id=770679#c2, we should not expose the full 'navigator' object to workers.

http://www.whatwg.org/specs/web-apps/current-work/multipage/workers.html#the-workernavigator-object lists what a real DOM worker gets, and our Frameworker should restrict things to this list.
Comment 1 Mark Hammond [:markh] 2012-07-12 00:05:17 PDT
Created attachment 641375 [details] [diff] [review]
expose a subset of navigator and add navigator specific tests and include __exposedProps__

This patch adds __exposedProps__ to the navigator object to prevent warnings.
Comment 2 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-07-12 09:33:27 PDT
Comment on attachment 641375 [details] [diff] [review]
expose a subset of navigator and add navigator specific tests and include __exposedProps__

thanks!
Comment 4 Mark Hammond [:markh] 2012-07-15 22:03:45 PDT
backed out due to leaks
Comment 5 Mark Hammond [:markh] 2012-07-15 22:29:35 PDT
Created attachment 642489 [details] [diff] [review]
Old patch neglected to call worker.terminate() which caused leaks in the test

Same as old patch except one line added:  worker.terminate();
Comment 6 Mark Hammond [:markh] 2012-07-15 22:36:56 PDT
New patch pushed as https://hg.mozilla.org/integration/mozilla-inbound/rev/6d2002bd64c5
Comment 7 Ed Morley [:emorley] 2012-07-16 11:15:09 PDT
Didn't make it to mozilla-central before the uplift (merge was blocked on bug 774259). Adjusting milestone accordingly.
Comment 8 Ed Morley [:emorley] 2012-07-17 02:14:38 PDT
https://hg.mozilla.org/mozilla-central/rev/6d2002bd64c5

Note You need to log in before you can comment on or make changes to this bug.