Language served doesn't change upon changing my browser->Language preferences

VERIFIED FIXED in 2012-08-16

Status

Marketplace
Consumer Pages
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: krupa, Assigned: cvan)

Tracking

2012-08-16
Points:
---

Details

(Reporter)

Description

5 years ago
steps to reproduce:
1. Load https://marketplace-dev.allizom.org/en-US
2. Nightly->Preferences. Change your default language to es-Es
3. Reload Marketplace

expected behavior:
Content is now served in Spanish

observed behavior:
Content is still served in English.
(Assignee)

Updated

5 years ago
Assignee: nobody → cvan
Target Milestone: --- → 2012-07-19
(Assignee)

Comment 1

5 years ago
https://github.com/mozilla/zamboni/commit/cd9a9e3

I was letting the cookie take precedence over what you set in your browser. I've changed it so that the "Accept-Language" header that the browser sends takes precedence. That certainly makes more sense.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

5 years ago
This works the first time I change the Language preference. But switching between languages doesn't reflect on the site.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 3

5 years ago
https://github.com/mozilla/zamboni/commit/ad2a887
Blocks: 762649
No longer blocks: 756282
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

5 years ago
This is not fixed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 5

5 years ago
https://github.com/mozilla/zamboni/commit/b4c6c2b

This seems to work pretty reliably now. Don't whack it too hard!
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: 2012-07-19 → 2012-07-26
(Reporter)

Comment 6

5 years ago
STR:
1. Load https://marketplace-dev.allizom.org/
2. Browser->Preferences->Languages
3. Choose es-ES as the default language
4. Reload marketplace
5. Repeat step #2 and change the language to en-US

expected behavior:
Marketplace loads in en-US after step #5

observed behavior:
marketplace still loads in es-es after step #5


screencast: http://screencast.com/t/BmLQVW61h83
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

5 years ago
Target Milestone: 2012-07-26 → 2012-08-09
Target Milestone: 2012-08-09 → 2012-08-16
(Assignee)

Comment 7

5 years ago
https://github.com/mozilla/zamboni/commit/a9d84d9
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

5 years ago
This seems to be working.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.