Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Change in-product Twitter search icon

VERIFIED FIXED in Firefox 16

Status

()

Firefox for Android
General
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: aaronmt, Assigned: Margaret)

Tracking

({productization})

Trunk
Firefox 18
ARM
Android
productization
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox15 wontfix, firefox16 verified, firefox17 fixed, firefox18 verified, fennec+)

Details

Attachments

(6 attachments)

(Reporter)

Description

5 years ago
Twitter changed their icons and they don't want people using the T icon anymore

http://twitter.com/logo
(Reporter)

Updated

5 years ago
tracking-fennec: --- → ?
status-firefox15: --- → affected
status-firefox16: --- → affected
(Assignee)

Comment 1

5 years ago
We would need to update the search plugin:
http://mxr.mozilla.org/mozilla-central/source/mobile/locales/en-US/searchplugins/twitter.xml#7

I feel like we usually work with our search partners to get these icons from them. Cc'ing Kev, since he would know.

(FWIW, the desktop search plugin has the new icon, but we should use a higher resolution version for mobile.)
Keywords: productization

Comment 2

5 years ago
I'll reach out to Twitter and ask for an updated base64 encoded image.
(In reply to Kev [:kev] Needham from comment #2)
> I'll reach out to Twitter and ask for an updated base64 encoded image.

32x32 please
tracking-fennec: ? → +
(Assignee)

Updated

5 years ago
Blocks: 785381

Comment 4

5 years ago
Because I'm awesome, I dropped the ball on this. I hope to have an updated icon from Twitter in the next 48 hours. Apologies.

Comment 5

5 years ago
Created attachment 655999 [details]
New Twitter Icon 32x32

This icon should be used in both mobile and desktop, so should go into central. It's pending final approval from Twitter, but has been created per their request from the source at http://twitter.com/logo/
(Assignee)

Comment 6

5 years ago
(In reply to Kev [:kev] Needham from comment #5)
> Created attachment 655999 [details]
> New Twitter Icon 32x32
> 
> This icon should be used in both mobile and desktop, so should go into
> central. It's pending final approval from Twitter, but has been created per
> their request from the source at http://twitter.com/logo/

Thanks! However, Gavin says that we'll want a 16x16 icon for desktop.
Assignee: nobody → margaret.leibovic
Blocks: 786358

Comment 7

5 years ago
Tell Gavin he'll use the 32x32, and like it! :)

Comment 8

5 years ago
Created attachment 656138 [details]
New Twitter Icon 16x16

16 x 16, because I suspect my previous comment will not be accepted.
(Assignee)

Comment 9

5 years ago
Created attachment 656194 [details] [diff] [review]
patch for mobile
Attachment #656194 - Flags: review?(bnicholson)
(Assignee)

Comment 10

5 years ago
Created attachment 656195 [details]
mobile screenshot
(Assignee)

Comment 11

5 years ago
Created attachment 656204 [details] [diff] [review]
patch for desktop
Attachment #656204 - Flags: review?(gavin.sharp)
(Assignee)

Comment 12

5 years ago
Created attachment 656206 [details]
desktop screenshot

I can't tell if this is actually blurry, or if it's my retina display being dumb. In any case, the icon is correct :)
Comment on attachment 656204 [details] [diff] [review]
patch for desktop

We should probably also file a bug to update twitter-ja (ja locale has their own fork).
Attachment #656204 - Flags: review?(gavin.sharp) → review+
Attachment #656194 - Flags: review?(bnicholson) → review+
(Assignee)

Comment 14

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/f3a789ca296a
https://hg.mozilla.org/integration/mozilla-inbound/rev/fed9bcc5862f
Target Milestone: --- → Firefox 18
(Assignee)

Updated

5 years ago
Depends on: 786452
https://hg.mozilla.org/mozilla-central/rev/f3a789ca296a
https://hg.mozilla.org/mozilla-central/rev/fed9bcc5862f
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 16

5 years ago
Channel uplift?
Status: RESOLVED → VERIFIED
status-firefox18: --- → verified
Certainly seems safe enough to push to Aurora, maybe even Beta
(Assignee)

Comment 18

5 years ago
Comment on attachment 656194 [details] [diff] [review]
patch for mobile

[Approval Request Comment]
Bug caused by (feature/regressing bug #): n/a
User impact if declined: old twitter icon will be used for search
Testing completed (on m-c, etc.): landed on m-c 8/29
Risk to taking this patch (and alternatives if risky): low-risk image swap
String or UUID changes made by this patch: n/a (although this change is in locales directory, so we should double check with Pike that this wouldn't cause any problems)

Gavin, do you want me to try to uplift the desktop change as well?
Attachment #656194 - Flags: approval-mozilla-beta?
Attachment #656194 - Flags: approval-mozilla-aurora?
Comment on attachment 656204 [details] [diff] [review]
patch for desktop

[Triage Comment]
sure
Attachment #656204 - Flags: approval-mozilla-beta+
Attachment #656204 - Flags: approval-mozilla-aurora+
Comment on attachment 656194 [details] [diff] [review]
patch for mobile

I don't expect there to be any l10n fallout for this resource switch. Approved for branches.
Attachment #656194 - Flags: approval-mozilla-beta?
Attachment #656194 - Flags: approval-mozilla-beta+
Attachment #656194 - Flags: approval-mozilla-aurora?
Attachment #656194 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 21

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/182d1fe4f2db
https://hg.mozilla.org/releases/mozilla-aurora/rev/7ec3cb3adef9

https://hg.mozilla.org/releases/mozilla-beta/rev/079b6572fc8c
https://hg.mozilla.org/releases/mozilla-beta/rev/2f4c512e4f3e
status-firefox15: affected → wontfix
status-firefox16: affected → fixed
status-firefox17: --- → fixed
(Reporter)

Updated

5 years ago
status-firefox16: fixed → verified
You need to log in before you can comment on or make changes to this bug.