Last Comment Bug 773653 - Intermittent leak in browser_dbg_breakpoint-new-script.js
: Intermittent leak in browser_dbg_breakpoint-new-script.js
Status: RESOLVED FIXED
: intermittent-failure, mlk
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: Trunk
: x86 Mac OS X
: P3 normal (vote)
: Firefox 17
Assigned To: Victor Porof [:vporof][:vp]
:
: James Long (:jlongster)
Mentors:
Depends on:
Blocks: 438871 bc-leaks 754804 771452
  Show dependency treegraph
 
Reported: 2012-07-13 08:02 PDT by Ed Morley [:emorley]
Modified: 2012-11-25 19:31 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
v1 (1.98 KB, patch)
2012-07-18 07:23 PDT, Victor Porof [:vporof][:vp]
rcampbell: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2012-07-13 08:02:35 PDT
Rev3 MacOSX Leopard 10.5.8 fx-team debug test mochitest-other on 2012-07-13 06:25:11 PDT for push c9371c78dfb5

slave: talos-r3-leopard-062

https://tbpl.mozilla.org/php/getParsedLog.php?id=13494431&tree=Fx-Team

{
TEST-UNEXPECTED-FAIL | browser/devtools/debugger/test/browser_dbg_breakpoint-new-script.js | leaked 2 window(s) until shutdown [url = http://example.com/browser/browser/devtools/debugger/test/browser_dbg_breakpoint-new-script.html]
}
Comment 1 Ed Morley [:emorley] 2012-07-13 08:03:18 PDT
^ occurred on the initial landing of the test.
Comment 2 Treeherder Robot 2012-07-16 16:42:28 PDT
ryanvm%gmail.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=13579728&tree=Firefox
Rev3 MacOSX Leopard 10.5.8 mozilla-central debug test mochitest-other on 2012-07-16 11:00:28
slave: talos-r3-leopard-014

TEST-UNEXPECTED-FAIL | ShutdownLeaks | leaked 6 DOMWindow(s) and 1 DocShell(s) until shutdown
TEST-UNEXPECTED-FAIL | browser/base/content/test/browser_bug597218.js | leaked 1 window(s) until shutdown [url = chrome://browser/content/tabview.html]
TEST-UNEXPECTED-FAIL | browser/base/content/test/browser_bug597218.js | leaked 1 docShell(s) until shutdown
TEST-UNEXPECTED-FAIL | browser/components/places/tests/browser/browser_views_liveupdate.js | leaked 1 window(s) until shutdown [url = chrome://browser/content/bookmarks/bookmarksPanel.xul]
TEST-UNEXPECTED-FAIL | browser/components/places/tests/browser/browser_views_liveupdate.js | leaked 1 window(s) until shutdown [url = about:blank]
TEST-UNEXPECTED-FAIL | browser/devtools/debugger/test/browser_dbg_breakpoint-new-script.js | leaked 2 window(s) until shutdown [url = http://example.com/browser/browser/devtools/debugger/test/browser_dbg_breakpoint-new-script.html]
TEST-UNEXPECTED-FAIL | browser/devtools/debugger/test/browser_dbg_bug723071_editor-breakpoints-pane.js | leaked 1 window(s) until shutdown [url = http://example.com/browser/browser/devtools/debugger/test/browser_dbg_script-switching.html]
Comment 3 Treeherder Robot 2012-07-17 00:20:59 PDT
ttaubert
https://tbpl.mozilla.org/php/getParsedLog.php?id=13589762&tree=Fx-Team
Rev3 MacOSX Leopard 10.5.8 fx-team debug test mochitest-other on 2012-07-16 17:42:56
slave: talos-r3-leopard-003

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/newtab/browser_newtab_focus.js | Validate focus count in the new tab page. - Got 28, expected 19
TEST-UNEXPECTED-FAIL | ShutdownLeaks | leaked 7 DOMWindow(s) and 1 DocShell(s) until shutdown
TEST-UNEXPECTED-FAIL | browser/base/content/test/browser_bug597218.js | leaked 1 window(s) until shutdown [url = chrome://browser/content/tabview.html]
TEST-UNEXPECTED-FAIL | browser/base/content/test/browser_bug597218.js | leaked 1 docShell(s) until shutdown
TEST-UNEXPECTED-FAIL | browser/components/places/tests/browser/browser_views_liveupdate.js | leaked 1 window(s) until shutdown [url = chrome://browser/content/bookmarks/bookmarksPanel.xul]
TEST-UNEXPECTED-FAIL | browser/components/places/tests/browser/browser_views_liveupdate.js | leaked 1 window(s) until shutdown [url = about:blank]
TEST-UNEXPECTED-FAIL | browser/devtools/debugger/test/browser_dbg_breakpoint-new-script.js | leaked 2 window(s) until shutdown [url = http://example.com/browser/browser/devtools/debugger/test/browser_dbg_breakpoint-new-script.html]
TEST-UNEXPECTED-FAIL | browser/devtools/debugger/test/browser_dbg_bug723071_editor-breakpoints-pane.js | leaked 1 window(s) until shutdown [url = http://example.com/browser/browser/devtools/debugger/test/browser_dbg_script-switching.html]
TEST-UNEXPECTED-FAIL | browser/devtools/debugger/test/browser_dbg_bug731394_editor-contextmenu.js | leaked 1 window(s) until shutdown [url = http://example.com/browser/browser/devtools/debugger/test/browser_dbg_script-switching.html]
Comment 4 Treeherder Robot 2012-07-17 10:07:39 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=13606618&tree=Mozilla-Inbound
Rev3 MacOSX Leopard 10.5.8 mozilla-inbound debug test mochitest-other on 2012-07-17 09:02:09
slave: talos-r3-leopard-014

TEST-UNEXPECTED-FAIL | ShutdownLeaks | leaked 6 DOMWindow(s) and 1 DocShell(s) until shutdown
TEST-UNEXPECTED-FAIL | browser/base/content/test/browser_bug597218.js | leaked 1 window(s) until shutdown [url = chrome://browser/content/tabview.html]
TEST-UNEXPECTED-FAIL | browser/base/content/test/browser_bug597218.js | leaked 1 docShell(s) until shutdown
TEST-UNEXPECTED-FAIL | browser/components/places/tests/browser/browser_views_liveupdate.js | leaked 1 window(s) until shutdown [url = about:blank]
TEST-UNEXPECTED-FAIL | browser/components/places/tests/browser/browser_views_liveupdate.js | leaked 1 window(s) until shutdown [url = chrome://browser/content/bookmarks/bookmarksPanel.xul]
TEST-UNEXPECTED-FAIL | browser/devtools/debugger/test/browser_dbg_breakpoint-new-script.js | leaked 2 window(s) until shutdown [url = http://example.com/browser/browser/devtools/debugger/test/browser_dbg_breakpoint-new-script.html]
TEST-UNEXPECTED-FAIL | browser/devtools/debugger/test/browser_dbg_bug723071_editor-breakpoints-pane.js | leaked 1 window(s) until shutdown [url = http://example.com/browser/browser/devtools/debugger/test/browser_dbg_script-switching.html]
Comment 5 Treeherder Robot 2012-07-17 10:27:39 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=13607157&tree=Mozilla-Inbound
Rev3 MacOSX Leopard 10.5.8 mozilla-inbound debug test mochitest-other on 2012-07-17 09:22:21
slave: talos-r3-leopard-060

TEST-UNEXPECTED-FAIL | ShutdownLeaks | leaked 6 DOMWindow(s) and 1 DocShell(s) until shutdown
TEST-UNEXPECTED-FAIL | browser/base/content/test/browser_bug597218.js | leaked 1 window(s) until shutdown [url = chrome://browser/content/tabview.html]
TEST-UNEXPECTED-FAIL | browser/base/content/test/browser_bug597218.js | leaked 1 docShell(s) until shutdown
TEST-UNEXPECTED-FAIL | browser/components/places/tests/browser/browser_views_liveupdate.js | leaked 1 window(s) until shutdown [url = about:blank]
TEST-UNEXPECTED-FAIL | browser/components/places/tests/browser/browser_views_liveupdate.js | leaked 1 window(s) until shutdown [url = chrome://browser/content/bookmarks/bookmarksPanel.xul]
TEST-UNEXPECTED-FAIL | browser/devtools/debugger/test/browser_dbg_breakpoint-new-script.js | leaked 2 window(s) until shutdown [url = http://example.com/browser/browser/devtools/debugger/test/browser_dbg_breakpoint-new-script.html]
TEST-UNEXPECTED-FAIL | browser/devtools/debugger/test/browser_dbg_bug723071_editor-breakpoints-pane.js | leaked 1 window(s) until shutdown [url = http://example.com/browser/browser/devtools/debugger/test/browser_dbg_script-switching.html]
Comment 6 Victor Porof [:vporof][:vp] 2012-07-18 07:23:54 PDT
Created attachment 643367 [details] [diff] [review]
v1

I may be on to something, but dunno.. currently running through try.
Comment 7 Victor Porof [:vporof][:vp] 2012-07-19 00:05:05 PDT
Green on try so far (same run as the one in bug 770542).
Comment 8 Rob Campbell [:rc] (:robcee) 2012-07-19 11:58:38 PDT
https://hg.mozilla.org/integration/fx-team/rev/8e3abb88d88c
Comment 9 Rob Campbell [:rc] (:robcee) 2012-07-20 07:10:54 PDT
https://hg.mozilla.org/mozilla-central/rev/8e3abb88d88c
Comment 10 Treeherder Robot 2012-07-26 17:31:54 PDT
ryanvm%gmail.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=13888109&tree=Mozilla-Aurora
Rev3 MacOSX Leopard 10.5.8 mozilla-aurora debug test mochitest-other on 2012-07-26 15:29:47
slave: talos-r3-leopard-043

TEST-UNEXPECTED-FAIL | ShutdownLeaks | leaked 6 DOMWindow(s) and 1 DocShell(s) until shutdown
TEST-UNEXPECTED-FAIL | browser/base/content/test/browser_bug597218.js | leaked 1 window(s) until shutdown [url = chrome://browser/content/tabview.html]
TEST-UNEXPECTED-FAIL | browser/base/content/test/browser_bug597218.js | leaked 1 docShell(s) until shutdown
TEST-UNEXPECTED-FAIL | browser/components/places/tests/browser/browser_views_liveupdate.js | leaked 1 window(s) until shutdown [url = about:blank]
TEST-UNEXPECTED-FAIL | browser/components/places/tests/browser/browser_views_liveupdate.js | leaked 1 window(s) until shutdown [url = chrome://browser/content/bookmarks/bookmarksPanel.xul]
TEST-UNEXPECTED-FAIL | browser/devtools/debugger/test/browser_dbg_breakpoint-new-script.js | leaked 2 window(s) until shutdown [url = http://example.com/browser/browser/devtools/debugger/test/browser_dbg_breakpoint-new-script.html]
TEST-UNEXPECTED-FAIL | browser/devtools/debugger/test/browser_dbg_bug723071_editor-breakpoints-pane.js | leaked 1 window(s) until shutdown [url = http://example.com/browser/browser/devtools/debugger/test/browser_dbg_script-switching.html]
Comment 11 Treeherder Robot 2012-07-28 14:28:48 PDT
ryanvm%gmail.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=13934383&tree=Mozilla-Aurora
Rev3 MacOSX Leopard 10.5.8 mozilla-aurora debug test mochitest-other on 2012-07-28 03:24:21
slave: talos-r3-leopard-026

TEST-UNEXPECTED-FAIL | ShutdownLeaks | leaked 6 DOMWindow(s) and 1 DocShell(s) until shutdown
TEST-UNEXPECTED-FAIL | browser/base/content/test/browser_bug597218.js | leaked 1 window(s) until shutdown [url = chrome://browser/content/tabview.html]
TEST-UNEXPECTED-FAIL | browser/base/content/test/browser_bug597218.js | leaked 1 docShell(s) until shutdown
TEST-UNEXPECTED-FAIL | browser/components/places/tests/browser/browser_views_liveupdate.js | leaked 1 window(s) until shutdown [url = chrome://browser/content/bookmarks/bookmarksPanel.xul]
TEST-UNEXPECTED-FAIL | browser/components/places/tests/browser/browser_views_liveupdate.js | leaked 1 window(s) until shutdown [url = about:blank]
TEST-UNEXPECTED-FAIL | browser/devtools/debugger/test/browser_dbg_breakpoint-new-script.js | leaked 2 window(s) until shutdown [url = http://example.com/browser/browser/devtools/debugger/test/browser_dbg_breakpoint-new-script.html]
TEST-UNEXPECTED-FAIL | browser/devtools/debugger/test/browser_dbg_bug723071_editor-breakpoints-pane.js | leaked 1 window(s) until shutdown [url = http://example.com/browser/browser/devtools/debugger/test/browser_dbg_script-switching.html]
Comment 12 Treeherder Robot 2012-07-31 09:49:10 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=14006448&tree=Mozilla-Aurora
Rev3 MacOSX Leopard 10.5.8 mozilla-aurora debug test mochitest-other on 2012-07-31 08:13:47
slave: talos-r3-leopard-028

TEST-UNEXPECTED-FAIL | ShutdownLeaks | leaked 5 DOMWindow(s) and 1 DocShell(s) until shutdown
TEST-UNEXPECTED-FAIL | browser/base/content/test/browser_bug597218.js | leaked 1 window(s) until shutdown [url = chrome://browser/content/tabview.html]
TEST-UNEXPECTED-FAIL | browser/base/content/test/browser_bug597218.js | leaked 1 docShell(s) until shutdown
TEST-UNEXPECTED-FAIL | browser/components/places/tests/browser/browser_views_liveupdate.js | leaked 1 window(s) until shutdown [url = chrome://browser/content/bookmarks/bookmarksPanel.xul]
TEST-UNEXPECTED-FAIL | browser/components/places/tests/browser/browser_views_liveupdate.js | leaked 1 window(s) until shutdown [url = about:blank]
TEST-UNEXPECTED-FAIL | browser/devtools/debugger/test/browser_dbg_breakpoint-new-script.js | leaked 2 window(s) until shutdown [url = http://example.com/browser/browser/devtools/debugger/test/browser_dbg_breakpoint-new-script.html]
Comment 13 Treeherder Robot 2012-07-31 17:20:29 PDT
ryanvm%gmail.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=14018157&tree=Mozilla-Aurora
Rev3 MacOSX Leopard 10.5.8 mozilla-aurora debug test mochitest-other on 2012-07-31 16:05:31
slave: talos-r3-leopard-061

TEST-UNEXPECTED-FAIL | ShutdownLeaks | leaked 5 DOMWindow(s) and 1 DocShell(s) until shutdown
TEST-UNEXPECTED-FAIL | browser/base/content/test/browser_bug597218.js | leaked 1 window(s) until shutdown [url = chrome://browser/content/tabview.html]
TEST-UNEXPECTED-FAIL | browser/base/content/test/browser_bug597218.js | leaked 1 docShell(s) until shutdown
TEST-UNEXPECTED-FAIL | browser/components/places/tests/browser/browser_views_liveupdate.js | leaked 1 window(s) until shutdown [url = about:blank]
TEST-UNEXPECTED-FAIL | browser/components/places/tests/browser/browser_views_liveupdate.js | leaked 1 window(s) until shutdown [url = chrome://browser/content/bookmarks/bookmarksPanel.xul]
TEST-UNEXPECTED-FAIL | browser/devtools/debugger/test/browser_dbg_breakpoint-new-script.js | leaked 2 window(s) until shutdown [url = http://example.com/browser/browser/devtools/debugger/test/browser_dbg_breakpoint-new-script.html]
Comment 14 Treeherder Robot 2012-08-01 04:58:13 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=14033368&tree=Mozilla-Aurora
Rev4 MacOSX Snow Leopard 10.6 mozilla-aurora debug test mochitest-other on 2012-08-01 02:53:33
slave: talos-r4-snow-060

TEST-UNEXPECTED-FAIL | ShutdownLeaks | leaked 5 DOMWindow(s) and 1 DocShell(s) until shutdown
TEST-UNEXPECTED-FAIL | browser/base/content/test/browser_bug597218.js | leaked 1 window(s) until shutdown [url = chrome://browser/content/tabview.html]
TEST-UNEXPECTED-FAIL | browser/base/content/test/browser_bug597218.js | leaked 1 docShell(s) until shutdown
TEST-UNEXPECTED-FAIL | browser/components/places/tests/browser/browser_views_liveupdate.js | leaked 1 window(s) until shutdown [url = about:blank]
TEST-UNEXPECTED-FAIL | browser/components/places/tests/browser/browser_views_liveupdate.js | leaked 1 window(s) until shutdown [url = chrome://browser/content/bookmarks/bookmarksPanel.xul]
TEST-UNEXPECTED-FAIL | browser/devtools/debugger/test/browser_dbg_breakpoint-new-script.js | leaked 2 window(s) until shutdown [url = http://example.com/browser/browser/devtools/debugger/test/browser_dbg_breakpoint-new-script.html]
Comment 15 Ed Morley [:emorley] 2012-08-02 05:09:42 PDT
Comment on attachment 643367 [details] [diff] [review]
v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 771452
User impact if declined: Intermittent orange
Testing completed (on m-c, etc.): Baked on trunk for 13 days
Risk to taking this patch (and alternatives if risky): Test-only fix
String or UUID changes made by this patch: None
Comment 16 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-03 12:05:03 PDT
Comment on attachment 643367 [details] [diff] [review]
v1

test-only, approved.

Note You need to log in before you can comment on or make changes to this bug.