Last Comment Bug 773713 - Stop using profile directory for Device Storage testings
: Stop using profile directory for Device Storage testings
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla16
Assigned To: Doug Turner (:dougt)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on: 774368
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-13 10:22 PDT by Doug Turner (:dougt)
Modified: 2012-07-16 10:56 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v.1 (13.69 KB, patch)
2012-07-13 11:16 PDT, Doug Turner (:dougt)
jmaher: review+
Details | Diff | Splinter Review

Description Doug Turner (:dougt) 2012-07-13 10:22:31 PDT

    
Comment 1 Mounir Lamouri (:mounir) 2012-07-13 10:27:44 PDT
Hmm, any context?
Comment 2 Doug Turner (:dougt) 2012-07-13 11:16:29 PDT
Created attachment 641967 [details] [diff] [review]
patch v.1
Comment 3 Joel Maher ( :jmaher) 2012-07-13 11:23:06 PDT
Comment on attachment 641967 [details] [diff] [review]
patch v.1

Review of attachment 641967 [details] [diff] [review]:
-----------------------------------------------------------------

overall this looks good, no red flags.  A bit out of my league for what I know.

::: dom/devicestorage/test/devicestorage_common.js
@@ +18,5 @@
> +  try {
> +    const Cc = SpecialPowers.wrap(Components).classes;
> +    const Ci = Components.interfaces;
> +    var directoryService = Cc["@mozilla.org/file/directory_service;1"].getService(Ci.nsIProperties);
> +    var f = directoryService.get("TmpD", Components.interfaces.nsIFile);

do you have access to Ci.nsiFile?
Comment 4 Doug Turner (:dougt) 2012-07-13 11:30:50 PDT
wierd, i didn't.  but I will fix the patch so that it uses the wrapped.
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-07-13 21:09:15 PDT
Sorry, but your push had to be backed out due to compilation errors on all platforms.
https://hg.mozilla.org/integration/mozilla-inbound/rev/7db81ae082e7

/builds/slave/m-in-lnx/build/dom/ipc/PContent.ipdl:166: error: ctor for protocol `PDeviceStorageRequest', which is not managed by protocol `PContent'
Specification is not well typed.
Comment 7 Doug Turner (:dougt) 2012-07-13 22:38:03 PDT
bad rebase - https://hg.mozilla.org/integration/mozilla-inbound/rev/ebaadef40580
Comment 8 Ryan VanderMeulen [:RyanVM] 2012-07-14 10:02:18 PDT
https://hg.mozilla.org/mozilla-central/rev/ebaadef40580

Note You need to log in before you can comment on or make changes to this bug.