Image type not always shown in titlebar

VERIFIED DUPLICATE of bug 24478

Status

()

VERIFIED DUPLICATE of bug 24478
18 years ago
17 years ago

People

(Reporter: bzbarsky, Assigned: pavlov)

Tracking

Trunk
mozilla0.9.7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
This is a followup to bug 57549

BUILD: Linux build 2001-04-24-08

STEPS TO REPRODUCE:
1)  Open a blank new browser
2)  Go to an image URL (eg http://www.mozilla.org/images/mozilla-banner.gif)
3)  Throbber stops. The titlebar updates.
4)  Go to http://www.mozilla.org
5)  Go to http://www.mozilla.org/images/mozilla-banner.gif
6)  Throbber stops. The titlebar does _not_ update.
7)  Reload
8)  Throbber stops. The titlebar updates.

EXPECTED RESULTS: the titlebar updates whenever you visit an image URL

ACTUAL RESULTS: the updating only happens sometimes.

Putting in some printf's, it looks like nsImageDocument::EndLayout() is not
always called.

Comment 1

18 years ago
I ran into this problem on Windows, so setting all/all.
OS: Linux → All
Hardware: PC → All
(Assignee)

Updated

18 years ago
Target Milestone: --- → mozilla0.9.2
(Assignee)

Comment 2

18 years ago
images coming from the cache is breaking this.. moving to 0.9.3
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Comment 3

18 years ago
*** Bug 83064 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 4

18 years ago
*** Bug 85555 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
Doesn't look like this is getting fixed before the freeze tomorrow night.
Pushing out a milestone.  Please correct if I'm mistaken.
Target Milestone: mozilla0.9.3 → mozilla0.9.4
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.4 → mozilla0.9.5
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.5 → mozilla0.9.7

Comment 6

17 years ago
Isn't this a duplicate of bug 24478?
(Reporter)

Comment 7

17 years ago


*** This bug has been marked as a duplicate of 24478 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 8

17 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.