java.lang.NoSuchMethodError: org.mozilla.gecko.GeckoApp$MenuPanel.onPopulateAccessibilityEvent at org.mozilla.gecko.GeckoApp$MenuPanel.dispatchPopulateAccessibilityEvent(GeckoApp.java)

RESOLVED FIXED in Firefox 15

Status

()

Firefox for Android
General
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Scoobidiver (away), Assigned: eeejay)

Tracking

({crash, regression, topcrash})

15 Branch
Firefox 16
ARM
Android
crash, regression, topcrash
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox15+ fixed, firefox16+ fixed)

Details

(Whiteboard: [native-crash], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
There are four crashes from the same user in 16.0a1/20120714: bp-42389037-7dc8-469d-812c-a48892120714.

java.lang.NoSuchMethodError: org.mozilla.gecko.GeckoApp$MenuPanel.onPopulateAccessibilityEvent
	at org.mozilla.gecko.GeckoApp$MenuPanel.dispatchPopulateAccessibilityEvent(GeckoApp.java:554)
	at android.widget.RelativeLayout.dispatchPopulateAccessibilityEvent(RelativeLayout.java:956)
	at android.widget.RelativeLayout.dispatchPopulateAccessibilityEvent(RelativeLayout.java:956)
	at android.view.View.sendAccessibilityEventUnchecked(View.java:3452)
	at android.view.View.sendAccessibilityEvent(View.java:3428)
	at android.widget.PopupWindow$PopupViewContainer.sendAccessibilityEvent(PopupWindow.java:1540)
	at android.view.ViewRoot.sendAccessibilityEvents(ViewRoot.java:3465)
	at android.view.ViewRoot.handleMessage(ViewRoot.java:2188)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:132)
	at android.app.ActivityThread.main(ActivityThread.java:4126)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:491)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:844)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:602)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NoSuchMethodError%3A+org.mozilla.gecko.GeckoApp%24MenuPanel.onPopulateAccessibilityEvent+at+org.mozilla.gecko.GeckoApp%24MenuPanel.dispatchPopulateAccessibilityEvent%28GeckoApp.java%29

Comment 1

5 years ago
Eitan, this looks like it broke with bug 773039. I didn't see anything wrong when i tested it yesterday.
(Reporter)

Updated

5 years ago
Blocks: 773039
Keywords: regression
Version: Trunk → Firefox 15
(Assignee)

Comment 2

5 years ago
Created attachment 642259 [details] [diff] [review]
Fix crasher on pre-ICS in MenuPanel.dispatchPopulateAccessibilityEvent
(Assignee)

Comment 3

5 years ago
https://tbpl.mozilla.org/?tree=Try&rev=414e5d57e009

Not near a build env, so just making sure with try first.
(Reporter)

Updated

5 years ago
status-firefox15: --- → affected
status-firefox16: --- → affected
tracking-firefox15: --- → ?
tracking-firefox16: --- → ?
Keywords: topcrash
(Assignee)

Updated

5 years ago
Attachment #642259 - Flags: review?(mark.finkle)
Attachment #642259 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 4

5 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/c2760174d698
(Assignee)

Updated

5 years ago
Assignee: nobody → eitan
Target Milestone: --- → Firefox 15
(Assignee)

Comment 5

5 years ago
Comment on attachment 642259 [details] [diff] [review]
Fix crasher on pre-ICS in MenuPanel.dispatchPopulateAccessibilityEvent

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug #773039.
User impact if declined: Crashes on pre-ICS devices when menu comes up.
Testing completed (on m-c, etc.): Not yet, but pretty strong conviction that this works well.
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch:
Attachment #642259 - Flags: approval-mozilla-aurora?
Comment on attachment 642259 [details] [diff] [review]
Fix crasher on pre-ICS in MenuPanel.dispatchPopulateAccessibilityEvent

I agree that this is a simple fix that should get on fx15
Attachment #642259 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/c2760174d698

Target milestone is used for tracking when a fix lands on m-c. Please use the tracking flags for aurora/beta landings.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: Firefox 15 → Firefox 16
Like so :-P
https://hg.mozilla.org/releases/mozilla-aurora/rev/0110dcf342ff
status-firefox15: affected → fixed
Flags: in-testsuite-
(Reporter)

Updated

5 years ago
status-firefox16: affected → fixed

Comment 9

5 years ago
Backed out of aurora for winxp M2 crashes:
https://tbpl.mozilla.org/php/getParsedLog.php?id=13562129&tree=Mozilla-Aurora

https://hg.mozilla.org/releases/mozilla-aurora/rev/d7602223c982
status-firefox15: fixed → affected
Sorry, just had it pointed out that this was android only (I hadn't looked at the diff before backing out, oops), must have just been bad luck two pushes in a row.

Relanded on aurora:
https://hg.mozilla.org/releases/mozilla-aurora/rev/c511865c8ab1
status-firefox15: affected → fixed

Updated

5 years ago
tracking-firefox15: ? → +
tracking-firefox16: ? → +
You need to log in before you can comment on or make changes to this bug.