Prompted twice to make Firefox default browser on a clean install

RESOLVED DUPLICATE of bug 433249

Status

()

Firefox
Installer
RESOLVED DUPLICATE of bug 433249
5 years ago
3 years ago

People

(Reporter: Unfocused, Unassigned)

Tracking

13 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

I just installed Firefox 13.0.1 in a clean VM for testing, deselected "make Firefox the default browser" in the installer, then got the default browser prompt once Firefox started.

At the very least, that dialog should be delayed until the second startup.

Updated

5 years ago
Version: unspecified → 13 Branch
Hi Blair,

I just found your old bug-report and want to ask you if this is still valid?
i think this is solved in the 2 years since you open the bug :-)

thanks for a short feedback,
stefan
Flags: needinfo?(bmcbride)
Redirecting this to Jared, since he's been working a little on generally making this better, and I don't know what the current plans are.
Flags: needinfo?(bmcbride) → needinfo?(jaws)
Philipp, what should we do here?
Flags: needinfo?(jaws) → needinfo?(philipp)
Yes, we should not ask a second time if the user has chosen not to make Fx the default in the installer.
As with everything that has to do with the default browser, we should monitor data on this closely and be ready to revert if we see a big drop in default settings.

Michael Verdi also filed this bug about it: https://bugzilla.mozilla.org/show_bug.cgi?id=1041514
Flags: needinfo?(philipp)
Thanks Philipp.

The installer should be setting browser.shell.checkDefaultBrowser=false when that pref is set so that the default browser notification isn't displayed.
Component: Untriaged → Installer
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 433249
You need to log in before you can comment on or make changes to this bug.