Install.log file is locked by apprunner

VERIFIED WONTFIX

Status

P3
normal
VERIFIED WONTFIX
20 years ago
3 years ago

People

(Reporter: pawyskoczka, Assigned: dougt)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
Build is 6/6

Steps:
Build is 6/6

Steps:

1. Launch the browser
2. Enter the following url http://jimbob/trigger.htm
3. In the trigger field type http://jimbob/jars/a_dddelcomp.jar
4. Click the Trigger button
5. After the install.log file is created, drag it to the trash
6. Click "Empty Trash"
7. Error appears that "the item could not be deleted because it contains items
that are in use..."
8. Close apprunner and you can delete the file

Comment 1

20 years ago
Is this Mac only?

Comment 2

20 years ago
For Windows, I have observed this behavior to be intermittant.  There may be a
reproducible case, but I have not yet isolated this.  At this time, I would not
say this is platform specific.
(Assignee)

Comment 3

20 years ago
*** Bug 7744 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 4

20 years ago
This file has to be lock so that we can write to it.  I try to minimize this
time by only opening the file when I need to write.  The mac be more sensitive
about deleting open files than windows.  Should our customer be deleting this
file when the product is running?

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 5

20 years ago
Marking Verified/Won't Fix

Comment 6

19 years ago
Bulk move of XPInstall (component to be deleted) bugs to Installer: XPInstall
Engine
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.