Compiling Firefox fails --with-system-libvpx when using libvpx 1.1 or later

RESOLVED FIXED in mozilla17

Status

()

Core
Audio/Video
RESOLVED FIXED
5 years ago
6 days ago

People

(Reporter: Andrew Benton, Assigned: Andrew Benton)

Tracking

Trunk
mozilla17
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Assignee)

Description

5 years ago
Created attachment 642362 [details] [diff] [review]
firefox-system-libvpx.patch

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120710013846

Steps to reproduce:

tried to compile firefox --with-system-libvpx (I have libvpx-v1.1.0 installed)


Actual results:

the build failed:

/home/andy/save/src/firefox/media/webrtc/trunk/src/modules/video_coding/codecs/vp8/main/source/vp8.cc: In member function ‘virtual int webrtc::VP8Decoder::Decode(const webrtc::EncodedImage&, bool, const webrtc::RTPFragmentationHeader*, const webrtc::CodecSpecificInfo*, int64_t)’:
/home/andy/save/src/firefox/media/webrtc/trunk/src/modules/video_coding/codecs/vp8/main/source/vp8.cc:694:3: error: ‘vpx_dec_iter_t’ was not declared in this scope
/home/andy/save/src/firefox/media/webrtc/trunk/src/modules/video_coding/codecs/vp8/main/source/vp8.cc:694:18: error: expected ‘;’ before ‘iter’
/home/andy/save/src/firefox/media/webrtc/trunk/src/modules/video_coding/codecs/vp8/main/source/vp8.cc:707:42: error: ‘iter’ was not declared in this scope
/home/andy/save/src/firefox/media/webrtc/trunk/src/modules/video_coding/codecs/vp8/main/source/vp8.cc:760:40: error: ‘iter’ was not declared in this scope
make[7]: *** [video_coding/codecs/vp8/main/source/vp8.o] Error 1
make[7]: Leaving directory `/home/andy/save/src/firefox/firefox-build-dir/media/webrtc/trunk/src/modules/modules_webrtc_vp8'
make[6]: *** [src/modules/modules_webrtc_vp8_libs] Error 2
make[6]: *** Waiting for unfinished jobs....



Expected results:

It should have compiled.
The attached patch fixes the issue for me
(Assignee)

Updated

5 years ago
Version: 13 Branch → Trunk

Updated

5 years ago
Component: Untriaged → Video/Audio
Product: Firefox → Core
Comment on attachment 642362 [details] [diff] [review]
firefox-system-libvpx.patch

>diff -r 57abb5f70e01 media/webrtc/trunk/src/modules/video_coding/codecs/vp8/main/source/vp8.cc
>--- a/media/webrtc/trunk/src/modules/video_coding/codecs/vp8/main/source/vp8.cc	Sun Jul 15 09:11:22 2012 +0300
>+++ b/media/webrtc/trunk/src/modules/video_coding/codecs/vp8/main/source/vp8.cc	Sun Jul 15 11:04:58 2012 +0100
>@@ -691,7 +691,7 @@
>       propagation_cnt_++;
>   }
>
>-  vpx_dec_iter_t iter = NULL;
>+  vpx_codec_iter_t iter = NULL;
>   vpx_image_t* img;
>   int ret;
>
Attachment #642362 - Attachment is patch: true
This is fixed by r2337.
https://code.google.com/p/webrtc/source/detail?spec=svn2337&r=2337
Summary: Compiling Firefox fails --with-system-libvpx → Compiling Firefox fails --with-system-libvpx when using libvpx 1.1 or later

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 644609 [details] [diff] [review]
rebased by our format

This is backport of r2337.
Attachment #642362 - Attachment is obsolete: true
Attachment #644609 - Flags: review?(rjesup)

Updated

5 years ago
Assignee: nobody → andy
Comment on attachment 644609 [details] [diff] [review]
rebased by our format

Derf: is this change backwards compatible with any versions of system-vpx that webrtc is compatible with?  (I assume yes.)  Note that we can say that --with-system-libvpx is only allowed with webrtc enabled if the system VPX is greater than X.Y.Z.  I don't feel we need to test for that in configure/make, though that might be nice - perhaps a comment to that effect instead.
Attachment #644609 - Flags: review?(rjesup) → review?(tterribe)
As a matter of fact, the signature for vpx_codec_get_frame in libvpx 1.0 already uses vpx_codec_iter_t.
Comment on attachment 644609 [details] [diff] [review]
rebased by our format

Review of attachment 644609 [details] [diff] [review]:
-----------------------------------------------------------------

(In reply to Randell Jesup [:jesup] from comment #4)
> Derf: is this change backwards compatible with any versions of system-vpx
> that webrtc is compatible with?  (I assume yes.)  Note that we can say that

vpx_dec_iter_t was part of the pre-v0.9.0 API removed in this CL: https://gerrit.chromium.org/gerrit/21702

We already require at least v1.0.0 (and have a configure check for it), so this shouldn't be a problem.
Attachment #644609 - Flags: review?(tterribe) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/c9a8add393e9
Target Milestone: --- → mozilla17
https://hg.mozilla.org/mozilla-central/rev/c9a8add393e9
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 9

10 days ago
This issue is back, I'll post an updated version of the attached file later as well as the build log and mozconfig

Comment 10

10 days ago
just checked patch appears to change nothing now therefore obselete; will post the mozconfig and log now

Comment 11

10 days ago
Created attachment 8887102 [details]
build log

Comment 12

10 days ago
Created attachment 8887104 [details]
mozconfig

compile fine until i added the libvpx option, i was testing options one at a time
(In reply to goldsnakeking from comment #9)
> This issue is back, I'll post an updated version of the attached file later
> as well as the build log and mozconfig

could you file a new bug?  This seems to be another issue according to your log.
Those errors have to do with libevent, not libvpx, as best I can tell.  There is an open bug on --with-system-libevent.  Please see if that bug covers your issue
Flags: needinfo?(goldsnakeking)

Comment 15

7 days ago
the bug appears to be 8 years old? i'll see though
Flags: needinfo?(goldsnakeking)
(In reply to goldsnakeking from comment #15)
> the bug appears to be 8 years old? i'll see though

This bug is old bug and this has been fixed at past years.  But we hit new issue (maybe, after updating webrtc library to the latest), so please file a new bug with your mozconfig + your build log.

Comment 17

6 days ago
okay shall do
You need to log in before you can comment on or make changes to this bug.