Last Comment Bug 774178 - SocialProvider changes to properly handle "logout"
: SocialProvider changes to properly handle "logout"
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: SocialAPI (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 16
Assigned To: Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16]
:
Mentors:
Depends on:
Blocks: 771826
  Show dependency treegraph
 
Reported: 2012-07-15 21:24 PDT by :Gavin Sharp [email: gavin@gavinsharp.com]
Modified: 2012-07-16 08:52 PDT (History)
0 users
gavin.sharp: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Shane's patch, with test (3.02 KB, patch)
2012-07-15 21:47 PDT, :Gavin Sharp [email: gavin@gavinsharp.com]
gavin.sharp: review+
Details | Diff | Review

Description :Gavin Sharp [email: gavin@gavinsharp.com] 2012-07-15 21:24:47 PDT
The toolbar UI in bug 771826 needs to be able to indicate that the user has "logged out" from the provider. Need to adjust the SocialProvider to accommodate this.
Comment 1 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-07-15 21:47:02 PDT
Created attachment 642481 [details] [diff] [review]
Shane's patch, with test

Split out from bug 771826.
Comment 2 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-07-16 00:39:20 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/492da706c14c
Comment 3 Ed Morley [:emorley] 2012-07-16 02:11:14 PDT
Push backed out for mochitest-a11y failures:
https://tbpl.mozilla.org/php/getParsedLog.php?id=13567358&tree=Mozilla-Inbound

{
20840 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tree/test_dochierarchy.html | Wrong child document count of root accessible - got 2, expected 1
}

https://hg.mozilla.org/integration/mozilla-inbound/rev/082542b01af8
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-07-16 08:52:53 PDT
Re-landed, since it wasn't the cause of the failure:
https://hg.mozilla.org/mozilla-central/rev/075af07e9952

Note You need to log in before you can comment on or make changes to this bug.