java.lang.NullPointerException: at org.mozilla.gecko.GeckoInputConnection$<n>.run(GeckoInputConnection.java) on ICS and JB

VERIFIED FIXED in Firefox 15

Status

()

Firefox for Android
Graphics, Panning and Zooming
--
critical
VERIFIED FIXED
5 years ago
9 months ago

People

(Reporter: Scoobidiver (away), Assigned: kats)

Tracking

({crash, regression})

15 Branch
Firefox 17
ARM
Android
crash, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox15+ verified, firefox16+ verified, firefox17 verified)

Details

(Whiteboard: [native-crash], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
It first appeared in 16.0a1/20120714. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6489be1890c0&tochange=0602e44ac248

java.lang.NullPointerException
	at org.mozilla.gecko.GeckoInputConnection$1.run(GeckoInputConnection.java:1011)
	at android.os.Handler.handleCallback(Handler.java:615)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:4745)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:786)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:553)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+at+org.mozilla.gecko.GeckoInputConnection%241.run%28GeckoInputConnection.java%29
(Reporter)

Comment 1

5 years ago
It currently affect ICS and JB like bug 774206.
(Reporter)

Updated

5 years ago
Summary: java.lang.NullPointerException: at org.mozilla.gecko.GeckoInputConnection$1.run(GeckoInputConnection.java) → java.lang.NullPointerException: at org.mozilla.gecko.GeckoInputConnection$1.run(GeckoInputConnection.java) on ICS and JB
This is probably another NPE from "Don't keep activities" being on.
Blocks: 769269

Updated

5 years ago
tracking-fennec: --- → ?
(Reporter)

Updated

5 years ago
Crash Signature: [@ java.lang.NullPointerException: at org.mozilla.gecko.GeckoInputConnection$1.run(GeckoInputConnection.java)] → [@ java.lang.NullPointerException: at org.mozilla.gecko.GeckoInputConnection$1.run(GeckoInputConnection.java)] [@ java.lang.NullPointerException: at org.mozilla.gecko.GeckoInputConnection$2.run(GeckoInputConnection.java)]
(Reporter)

Updated

5 years ago
Summary: java.lang.NullPointerException: at org.mozilla.gecko.GeckoInputConnection$1.run(GeckoInputConnection.java) on ICS and JB → java.lang.NullPointerException: at org.mozilla.gecko.GeckoInputConnection$<n>.run(GeckoInputConnection.java) on ICS and JB
Created attachment 644924 [details] [diff] [review]
Guard against null layercontroller

It looks like the code assumes getView() will always be non-null, except possibly in the postOnUiThread runnables. That seems reasonable to me, assuming that all the other invocations are directly on the UI thread and are coming while the view is alive and well.
Attachment #644924 - Flags: review?(cpeterson)
Assignee: nobody → bugmail.mozilla
Component: General → Graphics, Panning and Zooming
Comment on attachment 644924 [details] [diff] [review]
Guard against null layercontroller

Review of attachment 644924 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #644924 - Flags: review?(cpeterson) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/727381afb1be
status-firefox16: --- → affected
status-firefox17: --- → fixed

Comment 6

5 years ago
https://hg.mozilla.org/mozilla-central/rev/727381afb1be
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 17
Comment on attachment 644924 [details] [diff] [review]
Guard against null layercontroller

[Approval Request Comment]
Bug caused by (feature/regressing bug #): exposed by bug 769269
User impact if declined: crash may happen if going to the awesomescreen while keyboard is up
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): mobile only, low risk
String or UUID changes made by this patch: none
Attachment #644924 - Flags: approval-mozilla-aurora?
Blocks: 777505
(Reporter)

Comment 8

5 years ago
15.0b2 is affected while 15.0b1 wasn't.
status-firefox15: --- → affected
Version: Firefox 16 → Firefox 15
Comment on attachment 644924 [details] [diff] [review]
Guard against null layercontroller

Requesting for beta as well.
Attachment #644924 - Flags: approval-mozilla-beta?
No longer blocks: 777505
Depends on: 777505

Updated

5 years ago
tracking-firefox15: --- → +
tracking-firefox16: --- → +
Comment on attachment 644924 [details] [diff] [review]
Guard against null layercontroller

[Triage Comment]
Low risk fix for a crash regression. Approved for Aurora 16 and Beta 15.
Attachment #644924 - Flags: approval-mozilla-beta?
Attachment #644924 - Flags: approval-mozilla-beta+
Attachment #644924 - Flags: approval-mozilla-aurora?
Attachment #644924 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/00738d54c024
https://hg.mozilla.org/releases/mozilla-beta/rev/f614c8f107c5
status-firefox15: affected → fixed
status-firefox16: affected → fixed
All latest crashes occurred (due to this crash report) on Firefox 15 Beta (2012-07-24), but there is no crash on Firefox 15 Release channel, 16 Beta or 17 Aurora.

Closing bug as verified fixed.

--
Device: Galaxy Note
OS: Android 4.0.4
Status: RESOLVED → VERIFIED
status-firefox15: fixed → verified
status-firefox16: fixed → verified
status-firefox17: fixed → verified
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.