The default bug view has changed. See this FAQ.

java.lang.NullPointerException: at org.mozilla.gecko.GeckoInputConnection.getInputMethodManager(GeckoInputConnection.java)

VERIFIED FIXED in Firefox 15

Status

()

Firefox for Android
Keyboards and IME
--
critical
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Scoobidiver (away), Assigned: kats)

Tracking

({crash})

Trunk
Firefox 17
All
Linux
crash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox15 verified, firefox16 verified, firefox17 verified)

Details

(Whiteboard: [native-crash], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
There's one crash in 17.0a1/20120725: bp-15c2b18d-00c9-4290-bdcf-c5a5a2120725.

java.lang.NullPointerException
	at org.mozilla.gecko.GeckoInputConnection.getInputMethodManager(GeckoInputConnection.java:439)
	at org.mozilla.gecko.GeckoInputConnection.access$100(GeckoInputConnection.java:47)
	at org.mozilla.gecko.GeckoInputConnection$3.run(GeckoInputConnection.java:1075)
	at android.os.Handler.handleCallback(Handler.java:605)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:4424)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:784)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:551)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+at+org.mozilla.gecko.GeckoInputConnection.getInputMethodManager%28GeckoInputConnection.java%29
Created attachment 646137 [details] [diff] [review]
Patch

Missed this in my last patch, apparently getInputMethodManager can be called in a runnable as well.
Assignee: nobody → bugmail.mozilla
Attachment #646137 - Flags: review?(cpeterson)
Comment on attachment 646137 [details] [diff] [review]
Patch

Do you know which Runnable is calling getInputMethodManager() here? Can it handle a null return? Not all of GeckoInputConnection's calls to getInputMethodManager() handle null returns (which is appropriate for code paths that can only run when we have a View and Context).
Attachment #646137 - Flags: review?(cpeterson) → review+
In this case it's the runnable in notifyIMEChange, according to the stack trace. I looked through all of the calls to getInputMethodManager and all of the ones in runnables seem to handle null returns.
https://hg.mozilla.org/integration/mozilla-inbound/rev/7ed41f8b0a92
Blocks: 769269
status-firefox17: --- → fixed
Depends on: 774205
https://hg.mozilla.org/mozilla-central/rev/7ed41f8b0a92
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 17
Comment on attachment 646137 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 774205 (this patch is a follow-up to the patch on that bug, also currently pending aurora approval)
User impact if declined: possible crash
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): mobile only, low risk
String or UUID changes made by this patch: none
Attachment #646137 - Flags: approval-mozilla-aurora?
Attachment #646137 - Flags: approval-mozilla-beta?
Blocks: 774205
No longer depends on: 774205

Updated

5 years ago
Attachment #646137 - Flags: approval-mozilla-beta?
Attachment #646137 - Flags: approval-mozilla-beta+
Attachment #646137 - Flags: approval-mozilla-aurora?
Attachment #646137 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/f67e1f5b8166
https://hg.mozilla.org/releases/mozilla-beta/rev/33b5e504df4f
status-firefox15: --- → fixed
status-firefox16: --- → fixed
Last crash date is 2012-07-25 and there are no crash reports since then. It seems that this issue was fixed on all branches. Closing bug as verified fixed.

--
Device: Galaxy Note
OS: Android 4.0.4
status-firefox15: fixed → verified
status-firefox16: fixed → verified
status-firefox17: fixed → verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.