Last Comment Bug 774248 - Request Desktop Site does not work if sites use cookies to remember UA
: Request Desktop Site does not work if sites use cookies to remember UA
Status: RESOLVED WONTFIX
[rdm]
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: 16 Branch
: ARM Android
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 860234 (view as bug list)
Depends on: 773250
Blocks: 766406
  Show dependency treegraph
 
Reported: 2012-07-16 05:56 PDT by Mark Finkle (:mfinkle) (use needinfo?)
Modified: 2013-04-10 06:49 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments

Description Mark Finkle (:mfinkle) (use needinfo?) 2012-07-16 05:56:50 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0
Build ID: 20120601045813

Steps to reproduce:

Using Acer A100 (4.0.3) 7" tablet with Nightly

1.  Link brought me to mobile version of Website
2.  Request Desktop Site did not function as intended

To replicate:
1.  Go to: m.wired.com
2.  Use Request Desktop Site menu item (won't change to destop display of website)


Actual results:

I have found that some sites which I have reached through links will not respond to Request Desktop site.

Today I pursued one of these: Wired.com.  I found that if the link takes me to "m.xyz.com", the Request Desktop Site does not work.

On Wired, there is a "view full website link" which gave me what I wanted.

It would be nice if Request Desktop Site worked in all cases, even if one is taken to a URL that is a discrete mobile version.  Can this be done?

[cloned from Bug 773250]
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2012-07-16 05:59:23 PDT
From bug 773250:

Apparently, wired.com uses cookies to remember the UA preference. I've seen the same thing on dailyshow.com. Presumably, dailyshow.com wants to prevent mobile users from watching full episodes, so they lock the user into mobile mode once the site has been visited with a mobile UA. I'm not sure why wired.com does this, but short of evangelism, there isn't much we can do (and it appears they've gone out of their way to cause this behavior). If you want to look at desktop versions of these sites, you'll have to clear your cookies, switch the tab to desktop mode, and then go to the site.
Comment 2 Aaron Train [:aaronmt] 2012-07-16 06:21:27 PDT
Sounds like this one step short of a SUMO article and that's that.
Comment 3 djprius 2012-07-30 15:51:15 PDT
I assume that allowing a preference to *always* use Desktop Site view would solve the issue.  In Opera Mobile, one can set "user agent" to desktop.  Why not the same for Firefox Android?

David
Comment 4 Brian Nicholson (:bnicholson) 2012-07-30 16:14:37 PDT
(In reply to djprius from comment #3)
> I assume that allowing a preference to *always* use Desktop Site view would
> solve the issue.  In Opera Mobile, one can set "user agent" to desktop.  Why
> not the same for Firefox Android?
> 
> David

I had a patch for "always request desktop sites" in bug 766406, but we didn't want it at the time. At the very least, though, I should be able to create an add-on that provides this.

CC'ing madhava/ibarlow for UX input - would we want an "always request desktop sites" option in the prefs?
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2012-07-30 21:29:14 PDT
(In reply to djprius from comment #3)
> I assume that allowing a preference to *always* use Desktop Site view would
> solve the issue.  In Opera Mobile, one can set "user agent" to desktop.  Why
> not the same for Firefox Android?

I don't feel like we want that kind of advanced tweak in the app. There is an add-on you can use:
https://addons.mozilla.org/en-us/android/addon/phony/
Comment 6 Brian Nicholson (:bnicholson) 2012-08-23 11:27:32 PDT
(In reply to djprius from comment #3)
> I assume that allowing a preference to *always* use Desktop Site view would
> solve the issue.  In Opera Mobile, one can set "user agent" to desktop.  Why
> not the same for Firefox Android?
> 
> David

I've created an add-on that should allow you to do this; see https://addons.mozilla.org/en-US/android/addon/desktop-by-default/.

This is really just a workaround - there's no proper fix to this bug (other than having sites not do this, which we can't control). Marking as resolved.
Comment 7 Aaron Train [:aaronmt] 2013-04-10 06:49:50 PDT
*** Bug 860234 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.