Last Comment Bug 774616 - Scrolling planet.mozilla.org results in a Force Close dialog on Nightly
: Scrolling planet.mozilla.org results in a Force Close dialog on Nightly
Status: RESOLVED WORKSFORME
oom
:
Product: Firefox for Android
Classification: Client Software
Component: Graphics, Panning and Zooming (show other bugs)
: 16 Branch
: ARM Android
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 766647
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 04:16 PDT by Adrian Tamas (:AdrianT)
Modified: 2015-04-13 04:05 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
affected
fixed


Attachments
logs (45.67 KB, text/plain)
2012-07-17 04:16 PDT, Adrian Tamas (:AdrianT)
no flags Details

Description Adrian Tamas (:AdrianT) 2012-07-17 04:16:36 PDT
Created attachment 642901 [details]
logs

Nightly 16.0a1 2012-07-16
Device: HTC Desire (Android 2.2)/Motorola Droid Pro (Android 2.3.4)

Steps to reproduce:
1. Load planet.mozilla.org.
2. While the page is loading scroll slowly leaving the viewport to be painted before advancing.

Expected results:
The page can be scrolled without any issues.

Actual results:
A Force Close dialog is displayed.

Notes:
The issue is not reproducible on Aurora 15.0a2 2012-07-16.
On the HTC Desire Z (Android 2.3.3) the steps produce a soft reset.
Comment 1 Aaron Train [:aaronmt] 2012-07-17 06:12:10 PDT
Sounds like a variant or dupe of bug 757920.
Comment 2 Adrian Tamas (:AdrianT) 2012-07-17 06:14:58 PDT
(In reply to Aaron Train [:aaronmt] from comment #1)
> Sounds like a variant or dupe of bug 757920.

The issue is not HTC Desire specific and is only reproducible on Nightly not Aurora and only, from what I can tell, while using planet.mozilla.org
Comment 3 Brad Lassey [:blassey] (use needinfo?) 2012-07-18 12:47:39 PDT
qawanted to retest, bug 766647 may have fixed this.
Comment 4 Aaron Train [:aaronmt] 2012-07-19 06:32:34 PDT
wfm
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2012-07-20 08:14:57 PDT
Please try testing in Fx16 too
Comment 6 Adrian Tamas (:AdrianT) 2012-07-22 23:06:08 PDT
The issue is not reproducible on Nightly 17.0a1 2012-07-22 on the HTC Desire running Android 2.2.2

On Aurora 16.0a2 2012-07-22 the issue can still be reproduced causing Firefox to display the same Force close dialog when scrolling planet.mozilla.org while the page is loading
Comment 7 Kartikaya Gupta (email:kats@mozilla.com) 2015-04-13 04:05:22 PDT
Per comment 6

Note You need to log in before you can comment on or make changes to this bug.