The default bug view has changed. See this FAQ.

Fennec causes Adreno 200 devices (HTC Desire with Android 2.2) to reboot with casual browsing

REOPENED
Assigned to

Status

()

Firefox for Android
General
--
critical
REOPENED
5 years ago
8 months ago

People

(Reporter: lmandel, Assigned: jrmuizel)

Tracking

unspecified
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox15+ wontfix, firefox16-, blocking-fennec1.0 -)

Details

(Whiteboard: [gfx], [SUMO])

Attachments

(6 attachments)

In casual browsing on an HTC Desire (Android 2.2) Fennec Beta 2 has crashed the phone many times. The browser starts up fast enough and is responsive for a short while (few mins max) until it locks up the phone to the point where no buttons are responsive. The phone subsequently reboots.

This seems to be reliably reproducible on http://mobile.aritzia.com/blog.

Note: I have no such issue with the same sites on a Samsung Galaxy S2 with ICS.
Show me tomorrow
I reset another HTC Desire that I have to factory defaults. Reinstalled Firefox Beta and cannot reproduce the issue as I described it in comment 0. However, on this device with very limited storage space, when I fill the onboard storage space until there are a couple of megs left and run Firefox it crashes consistently or otherwise behaves oddly
- takes a long time to finish loading about: at which point the page may remain blank
- other pages remain blank (no content shown) even though page loading shows to be complete (no throbber)
Created attachment 626882 [details]
Screenshot of about: loaded, no content
Created attachment 626883 [details]
logcat of loading about:
Created attachment 626884 [details]
Screenshot of mozilla.org loaded, no content
Created attachment 626885 [details]
logcat of loading mozilla.org
My guess is that this is bug 754257? Able to show Benoit?
Kevin does your Desire also do this?
(In reply to Aaron Train [:aaronmt] from comment #7)
> My guess is that this is bug 754257? Able to show Benoit?

This looks to be bug 754257. I'll leave this open until I can test again on my wife's phone tonight to see if I can repro the original problem that I reported.
Created attachment 627083 [details]
catlog of session for condition described in comment 0

I can reliably reproduce the issue that I described in comment 0. I have attached a catlog of the session while browsing and crashing. The new result of this issue is that the phone crashes while browsing a page from the Old Navy site.
The last line of my preview comment should read "The net result..." Nothing new here except the log.
Seems like more Adreno issues. Log has this error:

05-24 23:23:02.046: E/Adreno200-ES20(647): gsl_device_waittimestamp failed in rb_timestamp_wait_on_timestamp

followed by a whole lotta this:

05-24 23:23:03.911: W/SharedBufferStack(647): waitForCondition(LockCondition) timed out (identity=19, status=0). CPU may be pegged. trying again.

CC'ing some gfx folks.

Updated

5 years ago
blocking-fennec1.0: --- → ?

Updated

5 years ago
Severity: normal → major
Repro steps on my phone:

1. Open oldnavy.com
2. Select Women->Show Our Favorites->New Arrivals
3. Scroll down on page quickly. If you get to the bottom of the page without the phone freezing all input, pick another page and repeat until it does.
Assignee: nobody → bgirard
blocking-fennec1.0: ? → +

Updated

5 years ago
Whiteboard: [gfx]
This looks like an Android deadlock:
http://code.google.com/p/android/issues/detail?id=20833
I'm not confident we will be able to get a solution for this bug but I will continue to try.

There is a discussing to use glFinish in that bug. It appears to reduce the occurrence of the problem but it does not feel like a real solution.

Jeff suggest detecting when we are hung and kill ourselves. It's not clear to me if that will let us recover from the deadlock.
(Assignee)

Comment 16

5 years ago
Perhaps related is this fix in 2.3:

https://github.com/android/platform_frameworks_base/commit/1b4ecc63c4eceb7c125d4e749fd5f747d99d6ec6
In the past Ali had found that disabling the GL animated background on some phones made the reboot problem go away. This is similar to the description here except that it says that they must be in the same process. I believe the problem we're seeing may be a more general deadlock while switching between two context in general.

I'll take a look if other deadlock/GL related fixes have landed.
I don't believe there is much progress that can be made in this bug as this looks to be a OS deadlock. For now I'm focus my efforts on the flash corruption bug.

Updated

5 years ago
Assignee: bgirard → jmuizelaar
(Assignee)

Comment 19

5 years ago
Created attachment 630232 [details] [diff] [review]
Register dump when hangs happens

So when this hang happens the GPU or driver is somewhat upset about the current state of things and dumps the following registers.
Summary: Fennec causes HTC Desire to reboot with casual browsing → Fennec causes Adreno devices (HTC Desire, HTC One S, etc) to reboot with casual browsing
I mistook Jeff using the HTC Desire today as him using the HTC One S.

I'm renomming because we haven't seen this on a lot of devices, so it might not need to block. (It's possible that this is an Android 2.2-only issue, if comment 16 is correct.)

I'm adding qawanted to see if a) QA can repro with STR from comment 13 on their Desires and b) whether QA can repro with STR from comment 13 on other Adreno devices.
blocking-fennec1.0: + → ?
Keywords: qawanted
Summary: Fennec causes Adreno devices (HTC Desire, HTC One S, etc) to reboot with casual browsing → Fennec causes HTC Desire to reboot with casual browsing
(Assignee)

Comment 21

5 years ago
Here's my understanding of what's happening:
 - We get an 'opcode error' ringbuffer interrupt
 - This is a fatal error and causes us to afaict turn off interrupts effectively disabling the GPU.
 - surfaceflinger waits for the GPU, but it never comes back and eventually the watchdog reboots the phone.

We do seem to be causing the opcode error, but it's not clear how or why. It's the userspace driver's job to prevent this so we must be tickling a bug somehow. Figuring out what's causing this is probably possible but is a large amount of work. Before, we proceed with that work we need to figure out how common this problem is and whether it's worth trying to work around.
blocking-fennec1.0: ? → ---
Summary: Fennec causes HTC Desire to reboot with casual browsing → Fennec causes Adreno devices HTC Desire to reboot with casual browsing
This issue causes Firefox to be unusable on the HTC Desire. I say unusable as best case I can get several minutes of usage before my phone becomes unresponsive and subsequently reboots. Note that although in comment 13 I provide reproduction steps that include a specific site I can reproduce this issue with multiple sites.

I would suggest that if this problem cannot be fixed that we should consider blocking the use of Firefox on this device (if this is possible).
I was able to reproduce the issue on Nightly 16.0a1 2012-06-05 on HTC Desire running Android 2.2 using the steps in comment 13 but using engadget.com as the web page. Also while running normal, daily testing I am seeing a lot of device freezes with 4-5 tabs opened and scrolling fast on pages with a lot of content. The issue has been reported before in Bug 751073. I am not able to reproduce with the original STR of Bug 751073 but the freezes still occur and, if the phone is left idle, an eventual restart. I believe this is a dupe of the bug.

I have tried to replicate the issue on an HTC Desire Z running Android 2.3.3 but I was unable to.
Keywords: qawanted

Updated

5 years ago
Blocks: 742701

Comment 24

5 years ago
We talked about blocking the HTC Desire in bug 742701, did we?
blocking-fennec1.0: --- → ?
(In reply to JP Rosevear [:jpr] from comment #24)
> We talked about blocking the HTC Desire in bug 742701, did we?

https://bugzilla.mozilla.org/show_bug.cgi?id=742701#c31 suggests that we'd make this hardware unsupported (although this bug is specifically noted as a driver). Bug 764518 would prevent users from installing Fennec Native in that case, if it doesn't meet our minimum system requirements.

Irina notes in https://bugzilla.mozilla.org/show_bug.cgi?id=742701#c32 that it'd be good to have a plan moving forward for supporting the Desire, however, based upon the user population.

For history's sake, we did block the HTC desire for beta 1 in bug 755073 due to white pages being rendered, and unblocked for beta 2 in bug 755894.

Comment 26

5 years ago
Ok, nommed to get clarity on the blocking issue.
blocking-fennec1.0: ? → +
Keywords: productwanted
marking as a release blocker to get a call from product on whether or not to block this device
Keywords: productwanted
This phone is below our minimum specs - wontfix
Status: NEW → RESOLVED
blocking-fennec1.0: + → -
Last Resolved: 5 years ago
status-firefox14: --- → wontfix
Resolution: --- → WONTFIX

Updated

5 years ago
Duplicate of this bug: 768412

Updated

5 years ago
Duplicate of this bug: 768412
(In reply to Johnathan Nightingale [:johnath] from comment #28)
> This phone is below our minimum specs

(In reply to Aaron Train [:aaronmt] from bug 768412 comment 1)
> Unfortunately this phone is below our minimum supported requirements.

That's not accurate, is it?  This phone meets our stated RAM, CPU, storage, and OS requirements.  We're just manually blocking it because of this rebooting bug, right?

Comment 32

5 years ago
really sad to see a solution named wontfix...

i have htc desire with android 2.3, and tried all official versions and none would run with minimum speed to use at all.

is this going to be resolved?

strange to see a problem in firefox only, when there is opera, dolphin, ucbrowser, etç, running so well...

saying that the problem is in android is...well...sad...
Sounds like the phone should not be blocked based on spec but because of this bug.

About this bug: 

Do we even still know if recent builds are triggering reboots?

If not, I recommend we not block the device
(Assignee)

Comment 34

5 years ago
(In reply to Aaron Train [:aaronmt] from comment #33)
> Sounds like the phone should not be blocked based on spec but because of
> this bug.
> 
> About this bug: 
> 
> Do we even still know if recent builds are triggering reboots?

We should probably retest.
Duplicate of this bug: 768412

Comment 36

5 years ago
No problem on HTC Desire on ICS 4.0.4 with fennec-16.0a1.multi.android-arm.apk
i tried reproduce comment #13 steps sereval times but it didn't freeze
Summary: Fennec causes Adreno devices HTC Desire to reboot with casual browsing → Fennec causes Adreno 200 devices (HTC Desire with Android 2.2) to reboot with casual browsing
Duplicate of this bug: 768412

Comment 38

5 years ago
Just tried nightly as suggested in http://www.geckozone.org/forum/viewtopic.php?f=32&t=106324 casual browsing was OK and then wanted to test http://mobile.aritzia.com/blog and http://engadget.com and it crashed (and sent bug report for the occasion).

But only Nightly is affected, just asking for restart the application. No reboot for android or whatever.

HTC Desire, android 2.3 (Cyanogenmod 7.1)

Comment 39

5 years ago
Hello!

I just realised, that Firefox 14 and beta are blocked on HTC Desire. 
I am running the latest Oxygen ROM (Android 2.3, www.oxygen.im) and Firefox Beta worked very fast, stable and there were no rendering issues or crashes.
Thanks to this bug (which does not affect me) I am even not able to see Firefox in the Play Store any more and of course I can't install/upgrade it. This is just annoying, as I just wanted to use the stable build again.

Is there a possibility to just block the Stock ROM on the Desire, but not custom roms like Oxygen or Cyanogenmod? I would appreciate it. And if it is not possible, please unblock the Desire... people will anyway figure out if the App works for them or not. It should be the _users decision_ to install and use a program.

Comment 40

5 years ago
Hello,

I try the french release available here : 
ftp://ftp.mozilla.org/pub/mobile/releases/14.0/android/
and I don't see any bug.

I use cyanogenmod 7.2.0.1 on a HTC Desire.

Comment 41

5 years ago
(In reply to j.4 from comment #39)
> Hello!
> 
> I just realised, that Firefox 14 and beta are blocked on HTC Desire. 
> I am running the latest Oxygen ROM (Android 2.3, www.oxygen.im) and Firefox
> Beta worked very fast, stable and there were no rendering issues or crashes.
> Thanks to this bug (which does not affect me) I am even not able to see
> Firefox in the Play Store any more and of course I can't install/upgrade it.
> This is just annoying, as I just wanted to use the stable build again.
> 
> Is there a possibility to just block the Stock ROM on the Desire, but not
> custom roms like Oxygen or Cyanogenmod? I would appreciate it. And if it is
> not possible, please unblock the Desire... people will anyway figure out if
> the App works for them or not. It should be the _users decision_ to install
> and use a program.

Bad idea, i think it's bad for the product public image if it doesn't work.
I think it's a better idea that people which have a "not really supported device" figure out how install fennec on the device anyway than use the official way of distribution.
Re-opening for discussion here
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Updated

5 years ago
status-firefox14: wontfix → ---

Comment 43

5 years ago
(In reply to skalala from comment #41)
> (In reply to j.4 from comment #39)
> > Hello!
> > 
> > I just realised, that Firefox 14 and beta are blocked on HTC Desire. 
> > I am running the latest Oxygen ROM (Android 2.3, www.oxygen.im) and Firefox
> > Beta worked very fast, stable and there were no rendering issues or crashes.
> > Thanks to this bug (which does not affect me) I am even not able to see
> > Firefox in the Play Store any more and of course I can't install/upgrade it.
> > This is just annoying, as I just wanted to use the stable build again.
> > 
> > Is there a possibility to just block the Stock ROM on the Desire, but not
> > custom roms like Oxygen or Cyanogenmod? I would appreciate it. And if it is
> > not possible, please unblock the Desire... people will anyway figure out if
> > the App works for them or not. It should be the _users decision_ to install
> > and use a program.
> 
> Bad idea, i think it's bad for the product public image if it doesn't work.
> I think it's a better idea that people which have a "not really supported
> device" figure out how install fennec on the device anyway than use the
> official way of distribution.

The avoidance of the public image is a fair argument, but in this case it should be easy to grab the compiled app somewhere to install it on "unsupported" devices at your own risk.
At the moment is no direct download link at either http://www.mozilla.org/m nor here: https://wiki.mozilla.org/Mobile/Platforms/Android#System_Requirements
You have to search the mozilla ftp server to get an apk file (Additionally without market there will be no automatic updates, too).
My suggestion would be: Block whatever device is not working perfectly, but give the user a easy possibility to get this awesome piece of software and decide for him/herself if it works on his/her device (e.g. in providing a direct download link for unsupported devices together with a warning).

Updated

5 years ago
blocking-fennec1.0: - → ?

Comment 44

5 years ago
There are more than 6 million units of this model in market, making it a top device, so we should look into fixing this issue so that we can support them.
(In reply to j.4 from comment #43)
> At the moment is no direct download link at either http://www.mozilla.org/m
> nor here:
> https://wiki.mozilla.org/Mobile/Platforms/Android#System_Requirements

There are several links on that second wiki page to download APK files directly from our FTP servers.
(In reply to Matt Brubeck (:mbrubeck) from comment #45)
> There are several links on that second wiki page to download APK files
> directly from our FTP servers.

And I've just edited the page to make these links more prominent.

Comment 47

5 years ago
HTC Desire is still declared as supported and tested in https://support.mozilla.org/en-US/kb/will-firefox-work-my-mobile-device#os=android&browser=m14 and https://docs.google.com/spreadsheet/ccc?authkey=CPiPp9IK&key=0AhE7m4JB2j6tdEJFZ3NoZkRoRTM3TTRpQll3UjZLYnc&authkey=CPiPp9IK#gid=3

Updated

5 years ago
Duplicate of this bug: 768522
(In reply to Scoobidiver from comment #47)
> HTC Desire is still declared as supported and tested in
> https://support.mozilla.org/en-US/kb/will-firefox-work-my-mobile-
> device#os=android&browser=m14

I submitted a revision to the SUMO article:
https://support.mozilla.org/en-US/kb/will-firefox-work-my-mobile-device/revision/26805
Adding qawanted. Also tracking for FF15, since that feels like the right timeline to fix a bug in such a highly used device.

Aaron - can you take a look at the experience on the HTC Desire? We'd like some exploratory testing to see if this (and the blank pages issue) still occurs with 14.0, and with what frequency. Please file bugs for any other issues you find as well :)
tracking-firefox15: --- → +
Keywords: qawanted
re comment #50, Lawrence and Kevin are the ones with the device in hand
(In reply to Aaron Train [:aaronmt] from comment #51)
> re comment #50, Lawrence and Kevin are the ones with the device in hand

I gave my phone to jrmuizel for diagnosis. You're welcome to use it too.
I missed the triage call on this one but do we really want to punt to 15 here, or should we unblock the device in the meantime post some recent build assessment the device?
blocking-fennec1.0: ? → -
Nothing we can do for 14.0.1
Duplicate of this bug: 770161

Comment 56

5 years ago
Hi, I have been using the superb firefox betas with no problems on my HTC Desire w/ ICS (android 4.0.1 - 4.0.3) daily for months. In fact, I made it my primary browser a few weeks ago. I just upgraded my ROM and went to reinstall but the app is no longer listed in the play store for me (I might try the direct apk install I guess). 

Thought I would drop a line to say how much I appreciate fennec and also that there probably a lot of people running rooted HTC Desires unnecessarily affected by this change - in fact, given that custom ROM users are probably more likely to install a 3rd party browser than non-custom ROM users, this change probably has a disproportionate effect on people who weren't experiencing the bug at all (since they're on android 4.0+).

Comment 57

5 years ago
Agreed with the above, I've been running Firefox 14 Beta on my HTC Desire for several weeks now without any problems whatsoever. In fact I love it and it's replaced the stock browser for me. Currently using Cyanogenmod 7.2 which is based on Android 2.3. I've also tested it using the "ICS For Desire" ROM based on Android 4.0.4 and runs absolutley perfectly for me on both.

If it's a bug in Android 2.2 + Adreno drivers then can we not just block all users using HTC Desires with 2.2 installed?

As an aside, I've noticed that the Google Nexus One is still listed as a supported device, but it has the same hardware as the Desire.
Thanks dodgyville+bugzilla and gopher1369 for your feedback on the other OSes and your support.  Given that information, I think it might be a good indication that we could use a SUMO article about this.  Tagging as SUMO and cc'ing mluna
Whiteboard: [gfx] → [gfx], [SUMO]

Comment 59

5 years ago
I am also hit by this. Unlike the previous commenters, I use the Android version that my HTC Desire was delivered with (Android 2.2, HTC Sense etc.), and Firefox works great on it. I feel totally back in the old days when I would encounter a website with an error message saying i have to use IE, and then using User Agent Switcher, and the site worked just fine without a problem. Except I haven't found an easy to use UA switcher for the Play store yet.
(In reply to gopher1369 from comment #57)
> If it's a bug in Android 2.2 + Adreno drivers then can we not just block all
> users using HTC Desires with 2.2 installed?

Google Play does not let you fine tune such configurations by operating system version. The available selection is either block or not.

Comment 61

5 years ago
I don't know what the documentation request is above, can someone explain to me what is needed or log into the http://support.mozilla.org/kb/new and create a draft of the content?
mluna: draft complete... https://support.mozilla.org/en-US/kb/fennec-may-cause-htc-desire-android-22-reboot-casu/history

Comment 63

5 years ago
The UA stuff isn't a workaround. It's only an analogy with a workaround to make websites properly display in the old days of Firefox (see comment 59).
This article only makes sense if the block is removed in Google Play.
Fair point about UA stuff, I wrote that in haste.

However, the article does still apply as people can download the build from our ftp site.

Comment 65

5 years ago
(In reply to Naoki Hirata :nhirata from comment #64)
> However, the article does still apply as people can download the build from
> our ftp site.
If you consider the ftp download (non market apps allowed on Android) is a valid way to install Firefox for Android, you should write SUMO documentation for every blocked devices.

If HTC Desire is unblocked in Google Play, may be a note about Android 2.2 in https://support.mozilla.org/en-US/kb/will-firefox-work-my-mobile-device is enough instead of a dedicated article.
(In reply to Scoobidiver from comment #65)
> (In reply to Naoki Hirata :nhirata from comment #64)
> > However, the article does still apply as people can download the build from
> > our ftp site.
> If you consider the ftp download (non market apps allowed on Android) is a
> valid way to install Firefox for Android, you should write SUMO
> documentation for every blocked devices.

As Irina mentioned in comment 44, the HTC Desire is a top device. I can see your argument for every top blocked device but I don't think it's necessary or a good use of our time to document for every single blocked device.

> If HTC Desire is unblocked in Google Play, may be a note about Android 2.2
> in https://support.mozilla.org/en-US/kb/will-firefox-work-my-mobile-device
> is enough instead of a dedicated article.

AFAIK Android 2.2 is the latest official release for the HTC Desire. (It is for mine.) If we have data that shows that a large number of Desire owners have updated to a later version of Android then I think we should reconsider the block in Google Play. If not, I think the block is prudent as the majority of the owners of this phone are likely to encounter issues using Firefox. This not only will result in low ratings for Firefox but, more importantly, will deliver a poor experience to the users of this device.
(In reply to Lawrence Mandel [:lmandel] from comment #66)
> AFAIK Android 2.2 is the latest official release for the HTC Desire. (It is
> for mine.)

Actually HTC has released Gingerbread Update for Desire for certain markets. See https://www.facebook.com/note.php?note_id=225607660802056
................
Hey guys, we're happy to announce that Gingerbread for Desire is here! Please visit our Developer website to access the download. http://developer.htc.com
Please note that the following regional variants are not compatible with this upgrade: Germany (Telekom Deutschland), North America, South Korea and Japan.
................

http://www.htcdev.com/process/license_copy_gingerbread/ says:
................
On Exclusions: The following regional variants are not-compatible with this upgrade: Germany (Deutsch Telekom), North America, South America, South Korea, Japan, Turkey, and Arabic language speaking countries in the Middle East.
................

Is it possible to enable Firefox for HTC Desire on all markets but Germany (Deutsch Telekom), North America, South America, South Korea, Japan, Turkey, and Arabic language speaking countries in the Middle East on Google Play?

Comment 68

5 years ago
Should be easier to enable for ( HTC Desire && android >= 2.3 )

Device capabilities must be a combination of Hardware + Software, IMO

Comment 69

5 years ago
Alexander's comment is slightly misleading. The important information is "Hey guys, we're happy to announce that Gingerbread for Desire is here! Please visit our Developer website to access the download." 

To clarify this means that HTC never officially released a version of Gingerbread (2.3) for the HTC Desire. They made a version available to developers only via the HTC Developers website. This would require completely wiping your phone and manually locating, downloading and installing the ROM from htcdev.com. It is not something that an average user could do, or would ever even be aware existed. As per previous comments, it can safely be assumed that the vast majority of Desire users are running Froyo (2.2).

Comment 70

5 years ago
(In reply to Lawrence Mandel [:lmandel] from comment #66)
> If not, I think the block is prudent as the
> majority of the owners of this phone are likely to encounter issues using
> Firefox.

Would you mind sharing your numbers on this?
(In reply to Jesper Kristensen from comment #70)
> (In reply to Lawrence Mandel [:lmandel] from comment #66)
> > If not, I think the block is prudent as the
> > majority of the owners of this phone are likely to encounter issues using
> > Firefox.
> 
> Would you mind sharing your numbers on this?

I don't have any hard numbers on this. My statement is based on:
1. the reproducible failure that I reported in this bug using Firefox on the HTC Desire with Android 2.2 (diagnosed in comment 14 and comment 16 and confirmed in comment 23)
2. the understanding that Android 2.2 is the latest official release for this phone
3. the assumption that the mainstream consumer will not have updated their phone to a later Android version through an alternate mechanism

I don't have an explanation for why Firefox works on your Desire as you reported in comment 59. It reliably hangs and forces a reboot on mine and is reproducible in using multiple sites by others as well as me. Can you reproduce the crash using the steps in comment 13? If so, perhaps your usage pattern is sufficiently different than mine, which is why you haven't yet encountered this issue. If this is the case we should consider whether your usage pattern is actually more widespread than mine and factor that into the block decision.

Comment 72

5 years ago
This change has removed the store option for at least 80,000 people with upgraded Desires perfectly capable of running firefox. http://www.phonearena.com/news/CyanogenMod-now-on-over-1-million-devices_id25843

Also, in answer to Lawrence, the last officially supported version of Android on the Desire is 2.3, not 2.2.
(In reply to dodgyville+bugzilla from comment #72)
> This change has removed the store option for at least 80,000 people with
> upgraded Desires perfectly capable of running firefox.
> http://www.phonearena.com/news/CyanogenMod-now-on-over-1-million-
> devices_id25843

This is interesting data. I would like to see more of this type of information in the hope that we can get to a cumulative total of updated devices that is great enough to make the case to enable Firefox for the HTC Desire. (FWIW, I do want to enable Firefox on Android for the HTC Desire. The data that I've seen still shows that the vast majority of users will be on Android 2.2, which in my experience has a major issue. See comment 59 for a different/better experience on the same Android version.) Some other information to round this out:

80,000 / 6,000,000 devices in use = ~1.33% of the devices in use

The article cited is also from Jan. 2012. Unless I'm misreading something, clicking through to the referenced data at http://stats.cyanogenmod.com/ and looking at installs by device shows that the current total of HTC Desire phones with CyanogenMod is currently in the neighbourhood of 4,000.

> 
> Also, in answer to Lawrence, the last officially supported version of
> Android on the Desire is 2.3, not 2.2.

Citing wikipedia [1] (dangerous, I know) "The update was finally released for download from HTC's developer website on 1 August 2011, and is not available as an over-the-air update." See comment 69 for more details.

In fact, a visit to the HTC developer website [2] shows that the latest version for all HTC Desire phones listed (plain Desire, not HD, S, etc.) is Android v2.2.

Irina - Perhaps there is a more definitive way to get data about the version of Android in use on this device. Does Google or HTC have this data?

[1]http://en.wikipedia.org/wiki/HTC_Desire#Software
[2]http://htcdev.com/devcenter/downloads
(In reply to Lawrence Mandel [:lmandel] from comment #73)
> The article cited is also from Jan. 2012. Unless I'm misreading something,
> clicking through to the referenced data at http://stats.cyanogenmod.com/ and
> looking at installs by device shows that the current total of HTC Desire
> phones with CyanogenMod is currently in the neighbourhood of 4,000.
According to http://stats.cyanogenmod.com/ there are 125,968 installs for bravo	(HTC Desire GSM) and 4,187 for bravoc (HTC Desire CDMA).
(In reply to Alexander L. Slovesnik from comment #74)
> (In reply to Lawrence Mandel [:lmandel] from comment #73)
> > The article cited is also from Jan. 2012. Unless I'm misreading something,
> > clicking through to the referenced data at http://stats.cyanogenmod.com/ and
> > looking at installs by device shows that the current total of HTC Desire
> > phones with CyanogenMod is currently in the neighbourhood of 4,000.
> According to http://stats.cyanogenmod.com/ there are 125,968 installs for
> bravo	(HTC Desire GSM) and 4,187 for bravoc (HTC Desire CDMA).

That makes more sense. Thanks for the clarification. So the total is actually >2% of HTC Desire phones that have Cyanogenmod at this point according to these stats.
(In reply to Lawrence Mandel [:lmandel] from comment #73)
> In fact, a visit to the HTC developer website [2] shows that the latest
> version for all HTC Desire phones listed (plain Desire, not HD, S, etc.) is
> Android v2.2.
In order to download Android v2.3 for HTC Desire you should open http://htcdev.com/devcenter/downloads, select "Other" option (don't select "Kernel Source Code" or "All") and press "Find Files". It's called "RUU Upgrade" and its size - 161.0 MB.

Comment 77

5 years ago
> 
> Irina - Perhaps there is a more definitive way to get data about the version
> of Android in use on this device. Does Google or HTC have this data?
>

They probably have it, but not making it available anywhere. We can make some assumptions based on the overall Android version distribution in market and the time when the Gingerbread update started becoming available. Given that Froyo is 17% of the whole market and that the update for the Desire HD was made available a relatively long time ago, we can safely say that a significant portion of the units in market are on Gingerbread, if not the majority. 

The Desire HD did receive an OTA update to Gingerbread, I got it on mine which I bought in France and it's confirmed here http://www.engadget.com/2011/05/04/htc-starts-ota-gingerbread-updates-for-desire-hd-and-incredible/ . 

So if I had to put a number on it I would say it's 60% Gingerbread and 40% Froyo (there might be some ICS, but not a lot).
Thanks for the estimates Irina. This specific bug is for the HTC Desire, not the Desire HD. Can you make a similar estimate for the HTC Desire?

Comment 79

5 years ago
Oops.

For the Desire it looks indeed like there hasn't been an OTA update to Gingerbread. There has been one for Froyo, which means that probably the vast majority of the models are on it, also since Eclair is 4% of the overall market. So the Desire would be 70% on Froyo and 30% on Eclair (the amount of people to install Gingerbread from the website should be insignificant).
Keywords: qawanted
Just to add another datapoint: my HTC Desire with Cyanogenmod 7.2 runs Aurora (with Sync) flawlessly for my usage, no reboots/crashes. I hope Play adds some sort of OS filtering :-/
(In reply to Kevin Brubeck Unhammer from comment #80)
> Just to add another datapoint: my HTC Desire with Cyanogenmod 7.2 runs
> Aurora (with Sync) flawlessly for my usage, no reboots/crashes. I hope Play
> adds some sort of OS filtering :-/

Please consider using Aurora/Nightly, since they aren't distributed through the Play Store and have their own update mechanism.
^ the above was a note to other Desire users reading this bug, although poorly worded.
Bumping up tracking to 16 here in case we can get some cycles to continue investigation here in the coming weeks.  Jeff is there anything that can help here?
status-firefox15: --- → wontfix
tracking-firefox16: --- → +
Until the stats in Comment 79 change, this is an Android 2.2 OS bug and doesn't have further action on our part.
tracking-firefox16: + → -
This is still and issue on Firefox Mobile 16 beta 2 on HTC Desire (Android 2.2)

Updated

5 years ago
Severity: major → critical
Any plans to support one of the most popular phones out there?
You need to log in before you can comment on or make changes to this bug.