Last Comment Bug 774736 - Don't use $(shell) for Sync's version
: Don't use $(shell) for Sync's version
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla17
Assigned To: Gregory Szorc [:gps]
:
Mentors:
Depends on:
Blocks: 769390
  Show dependency treegraph
 
Reported: 2012-07-17 10:28 PDT by Gregory Szorc [:gps]
Modified: 2012-07-18 05:55 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove version.txt, general cleanup (2.49 KB, patch)
2012-07-17 10:38 PDT, Gregory Szorc [:gps]
mh+mozilla: review+
Details | Diff | Splinter Review

Description Gregory Szorc [:gps] 2012-07-17 10:28:58 PDT
services/sync/Makefile.in is using a $(shell) to obtain the Sync version number:

WEAVE_VERSION = $(shell cat $(topsrcdir)/services/sync/version.txt)

AFAICT, we only reference version.txt from Makefile.in. So, I think we can delete version.txt and just store the version string in Makefile.in.

rnewman/philikon: am I missing other consumers of version.txt?
Comment 1 Gregory Szorc [:gps] 2012-07-17 10:38:10 PDT
Created attachment 643024 [details] [diff] [review]
Remove version.txt, general cleanup

I removed version.txt and performed some cosmetic cleanup while I was here.

The version incremented because we haven't done that since the Firefox 17 switchover yet (rnewman or I does that every release - we have a bug on file to get the tree people to do it when they make a new release).

This file also needs some love to fix the libs:: abuse. That is the work of bug 759487.
Comment 2 Mike Hommey [:glandium] 2012-07-17 10:40:08 PDT
Comment on attachment 643024 [details] [diff] [review]
Remove version.txt, general cleanup

Review of attachment 643024 [details] [diff] [review]:
-----------------------------------------------------------------

::: services/sync/Makefile.in
@@ +10,5 @@
>  
>  include $(DEPTH)/config/autoconf.mk
>  
>  # Definitions used by constants.js.
> +weave_version := 1.19.0

Why do you change the version number?
r=me with this sorted out.
Comment 3 Mike Hommey [:glandium] 2012-07-17 10:40:50 PDT
(In reply to Mike Hommey [:glandium] from comment #2)
> Comment on attachment 643024 [details] [diff] [review]
> Remove version.txt, general cleanup
> 
> Review of attachment 643024 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: services/sync/Makefile.in
> @@ +10,5 @@
> >  
> >  include $(DEPTH)/config/autoconf.mk
> >  
> >  # Definitions used by constants.js.
> > +weave_version := 1.19.0
> 
> Why do you change the version number?
> r=me with this sorted out.

Ah, didn't see comment 1.
Comment 4 Gregory Szorc [:gps] 2012-07-17 10:48:21 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/b62f77f85ea4

I also removed the empty line at the top of the file. Thank you for the very quick review!
Comment 5 Ed Morley [:emorley] 2012-07-18 05:55:26 PDT
https://hg.mozilla.org/mozilla-central/rev/b62f77f85ea4

Note You need to log in before you can comment on or make changes to this bug.