Google Search from the search box does not work in Mainland China due to Chinese government blocking https://google.com

RESOLVED WORKSFORME

Status

()

Firefox
Search
--
major
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: briansmith, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(In reply to Mads from Bug 633773 comment 51)
> https is blocked in China.
> 
> This means that search is now broken for all users in mainland china
> (tourists, expats, citizens, who prefers other languages than Chinese) of
> locales updated to adhere to this new standard (I am assuming the Chinese
> locale won't be updating to this!).
> 
> Before redirecting users to https an IP-GEO check should be performed and
> users should be redirected appropriately. E.g, users from Mainland China
> (despite their locale) should be redirected to the insecure version of
> Google search.
> 
> I am assuming this bug is also responsible for users being redirected from
> http://google.com to the non-functioning (within mainland China)
> https://google.com, when manually typing in the address bar.
> Normally Google redirect requests from China to http://google.com.hk but not
> anymore for Firefox users.
> 
> I can use Google fine from Chrome and Safari from Mainland China, but Google
> is essentially broken in Firefox after this feature got implemented.
> 
> I think it is important to ensure that Firefox works not just in the country
> you installed it in, but also when you bring you laptop with you on travels.
> I also think it is important that users can choose to use Firefox in
> whichever language they desire. Therefore we must ensure that all locales
> works all over the world, and sadly the Chinese government isn't helping.

I did not verify this but it warrants investigation. If it is true, then we should have some kind of solution or at least a better UI for dealing with the problem.
Keywords: regression
Hong, could somebody from Mozilla China please test Google searches from the search box in us-EN Firefox (not Firefox China Edition) and report whether they are working or not?

Comment 2

6 years ago
Although the GFW does vary, we don't believe that https://www.google.com is blocked at the moment for most people within China. So, although there may be some differences, this probably doesn't affect most Firefox users in China, even if they're using Google and not Baidu.

Comment 3

6 years ago
If this is an issue, we could perhaps add-on hotfix this.
> (In reply to Mads from Bug 633773 comment 51)
> > I am assuming this bug is also responsible for users being redirected from
> > http://google.com to the non-functioning (within mainland China)
> > https://google.com, when manually typing in the address bar.
> > Normally Google redirect requests from China to http://google.com.hk but not
> > anymore for Firefox users.

(Quoting Mads from bug 633773 comment #55)
> I have also found that new profiles don't redirect manual requests for
> google.com to https and it must be a setting in my default profile. I
> apologize.

Assuming it's not caused by an add-on, this behaviour would be caused by inline-autocomplete (on by default since Firefox 13 [bug 735187]) and the fix for bug 720081 which prefers https over http for a site if you've been to both before.  In your new profile you wouldn't have a history entry for https://www.google.com so inline autocomplete wouldn't default to https if you don't include the scheme while you type.  If you include the scheme in the address bar, you shouldn't be redirected to the https version.
Just to state the obvious: some careful thought should be given to how this is addressed (assuming SSL Google is actually being blocked, we've only got 1 report)...

On the one had, switching back to non-SSL is fixing an unexpected regression, and makes search work for users again. It's the sensible thing to do, and puts people back into the known-good state they were before.

OTOH, I can see there being negative spin as caving to the Chinese Government's network policy. And there's the entirely fair question of what the right long-term action is (even if we do a short-term rollback). Difficult, thorny questions. So let's hope this isn't a widespread problem!

Comment 6

6 years ago
(In reply to Justin Dolske [:Dolske] from comment #5)
> Just to state the obvious: some careful thought should be given to how this
> is addressed (assuming SSL Google is actually being blocked, we've only got
> 1 report)...

Do we have the option of reaching out to Google in order to ask them what their server logs say about users from mainland China using their SSL services?
(In reply to Ehsan Akhgari [:ehsan] from comment #6)
> (In reply to Justin Dolske [:Dolske] from comment #5)
> > Just to state the obvious: some careful thought should be given to how this
> > is addressed (assuming SSL Google is actually being blocked, we've only got
> > 1 report)...
> 
> Do we have the option of reaching out to Google in order to ask them what
> their server logs say about users from mainland China using their SSL
> services?

Isn't comment 2 basically what you're looking for?
(In reply to Brian Smith (:bsmith) from comment #1)
> Hong, could somebody from Mozilla China please test Google searches from the
> search box in us-EN Firefox (not Firefox China Edition) and report whether
> they are working or not?

Test from Beijing office network with Fx 14.0.1 en-US, Google SSL search from search box is working.
(In reply to Hector Zhao [:hector_zhao] from comment #8)
> (In reply to Brian Smith (:bsmith) from comment #1)
> > Hong, could somebody from Mozilla China please test Google searches from the
> > search box in us-EN Firefox (not Firefox China Edition) and report whether
> > they are working or not?
> 
> Test from Beijing office network with Fx 14.0.1 en-US, Google SSL search
> from search box is working.

can we close this as wfm?
(In reply to Carsten Book [:Tomcat] from comment #9)
> 
> can we close this as wfm?

Given information in comment 2, that's okay, at least for now.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.