Closed Bug 774941 Opened 7 years ago Closed 7 years ago

Changes to the IT Request Bugzilla form

Categories

(bugzilla.mozilla.org :: Extensions, defect)

Production
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: csorenson, Assigned: glob)

References

Details

Attachments

(1 file, 1 obsolete file)

We need to make 3 changes to the IT Request Form: https://bugzilla.mozilla.org/enter_bug.cgi?product=mozilla.org&format=itrequest

1.  Please remove the 1st radio button (the option for, "Request an LDAP/E-mail/etc. account").

2.  Change the 2nd radio button text:

    --The black text should read, "Helpdesk issue/request go to Service Now" (make the words "Service Now" link to https://mozilla.service-now.com/)
    --Remove the current green text that pops up and just have the URL written out in green: https://mozilla.service-now.com/ (the url doesn't need to be a link)

3.  Change the functionality of the 2nd radio button. If you click and select the 2nd radio button, can you then make it so that the for below the radio button list then disappears?  So remove everything starting with the "Summary" field if the 2nd radio button is selected.

Please make these changes effective first thing July 23rd.
Assignee: ui → nobody
Component: User Interface → Extensions: BMO
OS: Mac OS X → All
Product: Bugzilla → bugzilla.mozilla.org
QA Contact: default-qa
Hardware: x86 → All
Version: unspecified → Production
Assignee: nobody → dkl
Status: NEW → ASSIGNED
(In reply to Clarissa Sorenson [:CSO] from comment #0)
> We need to make 3 changes to the IT Request Form:
> https://bugzilla.mozilla.org/enter_bug.cgi?product=mozilla.
> org&format=itrequest
> 
> 1.  Please remove the 1st radio button (the option for, "Request an
> LDAP/E-mail/etc. account").
> 
> 2.  Change the 2nd radio button text:
> 
>     --The black text should read, "Helpdesk issue/request go to Service Now"
> (make the words "Service Now" link to https://mozilla.service-now.com/)
>     --Remove the current green text that pops up and just have the URL
> written out in green: https://mozilla.service-now.com/ (the url doesn't need
> to be a link)
> 
> 3.  Change the functionality of the 2nd radio button. If you click and
> select the 2nd radio button, can you then make it so that the for below the
> radio button list then disappears?  So remove everything starting with the
> "Summary" field if the 2nd radio button is selected.
> 
> Please make these changes effective first thing July 23rd.

When I was working on this I came up with a different proposed solution.

"Request an LDAP/E-mail/etc. account" and "Desktop/Laptop/Printer/Phone/Tablet/License problem/order/request" map to Bugzilla components "Server Operations: Account Requests" and"Server Operations: Desktop Issues" respectively internally in the form.

Then I just remove the "Request an LDAP/E-mail/etc. account" and "Desktop/Laptop/Printer/Phone/Tablet/License problem/order/request" radio options altogether in the template if and only if their respective components are disabled for new bug use.

If the components are still active, then the form looks the same. I can push this type of change with this weeks code push. Then on Monday, I go into the Bugzilla admin page and disable those two components which will make those two radio choices therefore disappear.

Also if the components are disabled, I can show a block of text describing where to go (ServiceNow) for account/desktop related issues similar to how we have the text for mailing lists requests on the form now.

Originally I was going to code in some date login in the template to make the changes take effect on Monday automatically but seems like overkill now.

When disabling the above components for new bug entry, old bugs against those components are still accessible and are only affected if the components on those are changed.

Sound ok?

dkl
This patch implements my proposed alternate solution and once accepted and reviewed we can push it live this week and then disable the relevant components on Monday.

dkl
Attachment #643631 - Flags: review?(glob)
We actually need to keep both Account Request and Desktop Issues components enabled since we will still get requests pushed from other Server Operation queues.  The idea is to make it more difficult to get things into that queue to get people to file them in service now.
Comment on attachment 643631 [details] [diff] [review]
Patch to remove helpdesk related choices from itrequest form (v1)

r- due to guillermo's comments -- the component won't be deactivated.
Attachment #643631 - Flags: review?(glob) → review-
taking this bug in order to get it done for this week's push.
Assignee: dkl → glob
Attached image screenshot
i've altered your request slightly, by making the 'service now' link a clear button, and putting the old radio button labels into the green text (see attached screenshot).

this is the version i'll commit.  it will automatically switch from the current form to the service-now one on the 23rd.
Attachment #643631 - Attachment is obsolete: true
Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.0/
modified extensions/BMO/template/en/default/bug/create/create-itrequest.html.tmpl
Committed revision 8246.

Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.2/
modified extensions/BMO/template/en/default/bug/create/create-itrequest.html.tmpl
Committed revision 8254.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Thank you for the screenshot!  This looks good.  Much appreciated.
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: FIXED → ---
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Hey,

Can you change the text of the first radio button? We received feedback that what we changed it to is confusing.

Instead of "Helpdesk Issue/Request" have it read "Desktop Issue/Request" instead.

Additionally, we are concerned that the "Any other issue" option may be people's default now that we are trying to redirect them to ServiceNow.  Can you edit the green text for that option as well?  Change it to include the green text for the first radio button, so that it will read something like:

System administration for the mozilla.org servers. Requests for Server Ops that don't fit in any of the other Server Ops components can go here.

Use Service Now to:
Request an LDAP/E-mail/etc. account
Desktop/Laptop/Printer/Phone/Tablet/License problem/order/request

Hopefully this isn't too much trouble.  Thank you!!
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---
Blocks: 776806
(In reply to Clarissa Sorenson [:CSO] from comment #9)
> Can you change the text of the first radio button? We received feedback that
> what we changed it to is confusing.

as these changes have already been deployed, we need to track updates in a new bug.
i've created bug 776806 for you.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Component: Extensions: BMO → Extensions
You need to log in before you can comment on or make changes to this bug.