Closed Bug 775082 Opened 7 years ago Closed 4 years ago

Video controls disappear after dragging the tabs

Categories

(Core :: Plug-ins, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: simona.marcu, Unassigned)

References

Details

(Keywords: regression)

Mozilla/5.0 (Windows NT 5.1; rv:15.0) Gecko/20100101 Firefox/15.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0
Shockwave Flash: 11.3.300.265

The video controls are no longer displayed in the Flash players after dragging the tabs on the desktop. 
This is only reproducible on Windows machines (issue is not reproducible on Mac OS X or on Ubuntu).
Issue is reproducible ever since Firefox 4.0.1 so this is not a regression.

Reproducible: always

Steps to reproduce:
1. Navigate to http://vimeo.com/ or to http://www.imdb.com/
2. Select a video and start playing it.
3. Hover the mouse over the flash player and observe how the video controls appear and disappear. 
4. Click the tab in the tab bar and drag it to the desktop.
5. Hover the mouse over the video again.

Expected results:
The video controls are always displayed when hovering the mouse over the flash player.

Actual results:
The video controls are no longer displayed in the flash player after dragging the tab that contained it to the desktop.
Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/3c43aa9d0051
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100917 Firefox/4.0b7pre ID:20100918041933
Fails:
http://hg.mozilla.org/mozilla-central/rev/f1eec85dcfdc
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100918 Firefox/4.0b7pre ID:20100918052622
pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3c43aa9d0051&tochange=f1eec85dcfdc

Suspected :bug 449734
Blocks: 449734
Comment 1 technically makes this a regression, albeit a very old one.
Keywords: regression
Version: 15 Branch → Trunk
Simona, can you update this bug? I assume it still reproduces in the latest Nightly with the latest Flash version?
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #3)
> Simona, can you update this bug? I assume it still reproduces in the latest
> Nightly with the latest Flash version?

You're right, this is still reproducible on the latest Nightly with the latest flash version.
Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20130107 Firefox/20.0 Build ID: 20130107030932
Adobe Flash: 11.5.502.135
OS: Windows XP → All
Hardware: x86 → All
Duplicate of this bug: 767812
Duplicate of this bug: 691531
This bug has been present for quite a while (at least 6 months in my observation). Is there any status update on this?
(In reply to steve.g.kelly@gmail.com from comment #7)
> This bug has been present for quite a while (at least 6 months in my
> observation). Is there any status update on this?

Unfortunately there is no update on this bug. This was caused by changes made in bug 449734, a change we made all the way back in the Firefox 2 days so it's been around a lot longer than 6 months. I've cc'd the original developer of those changes so he can make an assessment.
I tested videos on vimeo.com and www.imdb.com.  Dragging the tabs to new windows
and it seems to work fine for me - the video continues to play and the video
controls appears when hovering the video and the controls work as expected.
I'm using Nightly on Linux with Flash 11.2 r202.
Works fine in Nightly on Windows 7 too.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.