The default bug view has changed. See this FAQ.

SVG chess pieces are "erased" when one piece moves over another

RESOLVED FIXED

Status

()

Core
SVG
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jwatt, Assigned: jwatt)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

5 years ago
On http://chesstempo.com/pgn-viewer-beta.html?nosvg=0 it seems that the SVG chess pieces are sometimes partly erased when one pieces is moved over another, although they do repaint once the piece that's being dragged is released. This is a regression from bug 769742.

Comment 1

5 years ago
Thanks Jonathan,

Are you able to reproduce this at your end yet, or is there more details I can provide that might help reproduce the problem outside of my own setup?

Regards,
Richard.
(Assignee)

Comment 2

5 years ago
Hi Richard. It looks like I made a mistake and my fix wasn't yet in latest nightly. It is now though. Can you download and check a build from this directory:

https://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2012/07/2012-07-19-03-05-43-mozilla-central/

Comment 3

5 years ago
Thanks, the latest nightly appears to fix this problem! A big speed improvement over the current stable release, and no "eraser" :-) Thanks so much for your (and any others responsible) work in this area.

Do you know which stable release is likely to be the first to see this group of fixes?

Regards,
Richard.
(Assignee)

Comment 4

5 years ago
Cool! Thanks for reporting the issue and all your testing, Richard, and sorry about the confusion with builds. The performance improvements will first be in Firefox 16.
(Assignee)

Comment 5

5 years ago
Closing as fixed by bug 773450 then.

[For anyone doing any future bug archeology, this bug was spun off from bug 703873.]
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 6

5 years ago
Thanks Jonathan,

Looking forward to FF 16 :-) (thank again for your help).

Regards,
Richard.
You need to log in before you can comment on or make changes to this bug.