Sync account is created with invalid credentials if the recovery key is correct

RESOLVED DUPLICATE of bug 705767

Status

()

Firefox for Android
Android Sync
--
major
RESOLVED DUPLICATE of bug 705767
6 years ago
9 months ago

People

(Reporter: AdrianT, Unassigned)

Tracking

unspecified
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox15 affected, firefox16 unaffected, firefox17 unaffected)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 643871 [details]
logs

Firefox Mobile 15.0b1
Device: Acer Iconia Tab (Android 3.2)

Steps to reproduce:
1. Go to "Sync" and choose "Advanced setup".
2. Enter the correct recovery key but an incorrect user or password.
3. Tap on "Connect".

Expected results:
The account is not created when username/password/recovery key values do not match.

Actual results:
If the recovery key is correct the account is created, sync is started but no data is downloaded.

Notes:
This is a bad experience for a user that may mistype a password without realizing and the account is created but no info about why his data is not synced is displayed.

Updated

6 years ago
Component: General → Android Sync
Product: Firefox for Android → Mozilla Services
Version: Firefox 15 → unspecified
(Reporter)

Comment 1

6 years ago
Non tablet specific issue. Also reproducible on Firefox Mobile 15.0b1 on HTC Desire running Android 2.2.2
(Reporter)

Comment 2

6 years ago
Issue is not reproducible on Nightly 17.0a1 2012-07-19 and Aurora 16.0a2 2012-07-19 on Acer Iconia Tab
status-firefox16: --- → unaffected
status-firefox17: --- → unaffected
Was fixed in 16.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 705767
(Reporter)

Comment 4

6 years ago
bug 705767 was fixed in Firefox Mobile 11 and the issue is reproducible on Firefox Mobile 15.0b1. Are they still duplicate issues?
(Reporter)

Comment 5

6 years ago
(In reply to adrian tamas from comment #4)
> bug 705767 was fixed in Firefox Mobile 11 and the issue is reproducible on
> Firefox Mobile 15.0b1. Are they still duplicate issues?

I'm sorry about that the bug was not verified on Firefox 11 but was verified fixed
I get "Incorrect account name or password" message as expected.

That's on both a Galaxy 10.1 tab and an old Nexus 2.2 phone. testing m-c Nightly (17a1) builds of this morning.
(Assignee)

Updated

5 years ago
Component: Android Sync → Android Sync
Product: Mozilla Services → Android Background Services
(Assignee)

Updated

5 years ago
tracking-fennec: ? → ---

Updated

9 months ago
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.