Last Comment Bug 775592 - MOZ Transition Ruined by FF 14 - works in all previous - including competitor browsers. No smoothness in transition.
: MOZ Transition Ruined by FF 14 - works in all previous - including competitor...
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Layout (show other bugs)
: 14 Branch
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Robert O'Callahan (:roc) (email my personal email if necessary)
:
: Jet Villegas (:jet)
Mentors:
http://www.independentlivingbullion.c...
: 775872 (view as bug list)
Depends on: 772079
Blocks: 753329
  Show dependency treegraph
 
Reported: 2012-07-19 09:07 PDT by Alex
Modified: 2012-08-02 06:24 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified
fixed


Attachments
ruined-transition-ff14.jpg (36.76 KB, image/jpeg)
2012-07-19 09:07 PDT, Alex
no flags Details
reduced html (1.18 KB, text/html)
2012-07-20 04:19 PDT, Alice0775 White
no flags Details

Description Alex 2012-07-19 09:07:08 PDT
Created attachment 643878 [details]
ruined-transition-ff14.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

Transition/Rotate CSS3 - image is now lagged or jumpy when transitioning - not smooth like in other browsers / FF13


Actual results:

Transition/Rotate CSS3 - image is now lagged or jumpy when transitioning - not smooth like in other browsers / FF13


Expected results:

Smooth Transitioning, like in FF13
Comment 1 Loic 2012-07-19 10:00:29 PDT
Could you provide a minimal testcase, please?
Comment 2 Alex 2012-07-19 10:57:08 PDT
(In reply to Loic from comment #1)
> Could you provide a minimal testcase, please?

See the URL I posted? There's a test environment there. CSS is in the header.
Comment 3 Alex 2012-07-19 11:38:09 PDT
(In reply to Alex from comment #2)
> (In reply to Loic from comment #1)
> > Could you provide a minimal testcase, please?
> 
> See the URL I posted? There's a test environment there. CSS is in the header.

Just in case-- http://www.independentlivingbullion.com/test/hot-topics/hot-topics.html
Comment 4 Loic 2012-07-19 18:10:06 PDT
Thanks, I have seen it.

Sometimes, it's not 100% smooth but I tried with Firefox 17 and it's smooth.
That's why I asked to provided a minimal testcase, with just a CSS3 animation. Not the whole website.
Comment 5 Loic 2012-07-20 03:28:33 PDT
I found a regression range in FF16a1, so maybe a patch has been backported into FF14.
But in FF17, all is ok, it's smooth.

Anyway this rendering issue needs more investigation!

m-c
good=2012-06-08
bad=2012-06-09
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5891cc95eac7&tochange=95d1bb200f4e

m-i
good=2012-06-07
bad=2012-06-08
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=30fc3d3e10d3&tochange=80e0fe778213
Comment 6 Loic 2012-07-20 03:28:53 PDT
*** Bug 775872 has been marked as a duplicate of this bug. ***
Comment 7 Alice0775 White 2012-07-20 04:00:46 PDT
Regression window(14.0 Beta)
Good
http://hg.mozilla.org/releases/mozilla-beta/rev/538cf07e6ba1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0 ID:20120605113340
Bad
http://hg.mozilla.org/releases/mozilla-beta/rev/1cbedcda8204
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0 ID:20120612164001
Pushlog:
http://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=538cf07e6ba1&tochange=1cbedcda8204


Regression window(15.0 Aurora)
Good
http://hg.mozilla.org/releases/mozilla-aurora/rev/77cf49ff4b57
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120608 Firefox/15.0a2 ID:20120608042008
Bad:
http://hg.mozilla.org/releases/mozilla-aurora/rev/43d14e9a5237
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120608 Firefox/15.0a2 ID:20120608144036
Pushlog:
http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=77cf49ff4b57&tochange=43d14e9a5237


In local build(src from http://hg.mozilla.org/releases/mozilla-aurora)
Last Good:ddb3b87d9384
First Bad: a125034a52b3

Regressed by a125034a52b3	Robert O'Callahan — Bug 753329. Share ThebesLayerInvalidRegion for a given ContainerLayer across all the frames that are sharing that layer as their ContainerLayer. r=mattwoodrow a=blassey * * * Bug 753329. Followup: put ThebesLayerInvalidRegionProperty in display-list-builder coordinates so it can be shared by frames with different coordinate systems. r=mattwoodrow




Progression Window
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/9f3534c54fa3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120713230821
Working again:
http://hg.mozilla.org/integration/mozilla-inbound/rev/a7f80f6408ed
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120714005020
Push log:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9f3534c54fa3&tochange=a7f80f6408ed

Fixed by Bug 772079 in Firefox16 in inbound


And similar to Bug 775163 (same regression/progression range)
Comment 8 Alice0775 White 2012-07-20 04:19:14 PDT
Created attachment 644254 [details]
reduced html
Comment 9 Alex Keybl [:akeybl] 2012-07-20 15:45:03 PDT
We'll likely approve bug 772079, but assigning to roc in the meantime nonetheless.
Comment 10 persona 2012-07-24 19:31:21 PDT
Issue is resolved if opacity:0; is removed for rule ".slide-up-boxes div {...}" on hot-topics.html line 55.

This does infact look to be the same issue as bug 777152 - thanks Loic.

Actually this looks like a revival of an older bug on FF4.0b3: bug 589143 - which is also resolved upon removal of opacity.
Comment 11 Alex 2012-07-25 09:38:02 PDT
Thanks Persona - good catch.
Comment 12 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-07-30 17:54:48 PDT
Should have been fixed by bug 772079.
Comment 13 Virgil Dicu [:virgil] [QA] 2012-08-02 06:24:18 PDT
Verified on Windows 7, 64 with reduced test case and url. Animation is now fluid with F15 beta 3.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0

Note You need to log in before you can comment on or make changes to this bug.