Last Comment Bug 777152 - 14.0.1 introduced severe rendering glitches when using -moz-transition on an element with opacity, scale & any positioning property (such as left)
: 14.0.1 introduced severe rendering glitches when using -moz-transition on an ...
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Layout (show other bugs)
: 14 Branch
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
Depends on: 772079
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-24 16:25 PDT by persona
Modified: 2012-08-02 00:33 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
jsFiddle.mpg (3.28 MB, application/octet-stream)
2012-07-24 16:25 PDT, persona
no flags Details

Description persona 2012-07-24 16:25:06 PDT
Created attachment 645573 [details]
jsFiddle.mpg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

Applied -moz-transition on an element that had opacity, left relative positioning, & -moz-transform:scale()

Details in jsFiddle here: http://jsfiddle.net/fCLaj/40/


Actual results:

As element animated, it repeatedly froze for milliseconds at a time while leaving temporary visual artifacts as it glitched through the animation.


Expected results:

Animation should have been visually smooth, transitioning opacity, scale, and position simultaneously.
Comment 1 Loic 2012-07-24 19:11:54 PDT
I think it's a dupe of bug 775592.
Comment 2 persona 2012-07-24 19:22:14 PDT
(In reply to Loic from comment #1)
> I think it's a dupe of bug 775592.

That bug is also resolved if opacity is removed (removed with firebug to confirm).

This is somehow contingent on opacity...
Comment 3 Loic 2012-07-25 01:16:42 PDT
(In reply to persona from comment #2)
> (In reply to Loic from comment #1)
> > I think it's a dupe of bug 775592.
> 
> That bug is also resolved if opacity is removed (removed with firebug to
> confirm).
> 
> This is somehow contingent on opacity...

I think there are 2 bugs in your testcase.

1) When I toggle to reduce the image from its large size (right position) to its small size (left position), there is a rendering glitch at the end as if there was a slight shift.
Look at my screenshot, especially the letters "O" & "y": http://i.imgur.com/qzRGl.png
It's a bug with opacity and resizing, see bug bug 745549.

2) A bug in the smoothness of the transition from left to right and from right to left.
Snapshot: http://i.imgur.com/qw8dc.png
It's bug 775592.
Comment 4 Loic 2012-08-01 10:51:09 PDT
I tried your testcase with the latest Nightly and the rendering bug is gone.
I think it's fixed according to comment https://bugzilla.mozilla.org/show_bug.cgi?id=775592#c12

Note You need to log in before you can comment on or make changes to this bug.