Closed Bug 775890 Opened 10 years ago Closed 10 years ago

Detect non-200 responses for resources in manifests

Categories

(Marketplace Graveyard :: Validation, enhancement, P4)

enhancement

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: cvan, Unassigned)

References

Details

We could probably start flagging or rejecting apps whose manifests contain invalid paths/URLs.

Fields that should probably absolutely be valid paths:
- launch_path (which defaults to origin)
- icons.128 (whose path defaults to origin but could point somewhere external)
- appcache_path (if specified)

If specified, these should also be valid paths (but probably don't matter too much):
- icons.*.url
- developer.url
- locales.*.developer.url
Blocks: 766199
No longer blocks: 766199
OS: Mac OS X → All
In addition to checking the path is valid we should make sure useful content is there if it doesn't take too long.  I'm duping that bug to this one.
Duplicate of this bug: 788835
Blocks: 751439
Merged:

https://github.com/mozilla/app-validator/commit/6a94fdcc28c9501b5170a771582bed997ccc9d0a

In response to comment #1:
We do enforce a standard HTTP timeout. If this is too long, it can be reduced going forward.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.