Last Comment Bug 775976 - java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp.handleThumbnailData(GeckoApp.java)
: java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp.handleThumbnail...
Status: RESOLVED FIXED
[native-crash]
: crash, regression
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: 17 Branch
: ARM Android
: -- critical (vote)
: Firefox 17
Assigned To: Kartikaya Gupta (email:kats@mozilla.com)
:
Mentors:
Depends on:
Blocks: 766647
  Show dependency treegraph
 
Reported: 2012-07-20 08:14 PDT by Scoobidiver (away)
Modified: 2012-07-30 12:19 PDT (History)
2 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
Patch (1.14 KB, patch)
2012-07-20 08:22 PDT, Kartikaya Gupta (email:kats@mozilla.com)
blassey.bugs: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Scoobidiver (away) 2012-07-20 08:14:38 PDT
There are 3 crashes in 17.0a1/20120720 from 2 users. Here is a crash report: bp-1c14b946-8470-42b5-ac82-97ec72120720.
The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6d8456a77e57&tochange=3a05d298599e
It's a new form of bug 775030 and likely a regression from bug 766647.

java.lang.NullPointerException
	at org.mozilla.gecko.GeckoApp.handleThumbnailData(GeckoApp.java:783)
	at org.mozilla.gecko.ScreenshotHandler$1.run(GeckoAppShell.java:2583)
	at android.os.Handler.handleCallback(Handler.java:587)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:130)
	at org.mozilla.gecko.GeckoBackgroundThread.run(GeckoBackgroundThread.java:31)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+at+org.mozilla.gecko.GeckoApp.handleThumbnailData%28GeckoApp.java%29
Comment 1 Kartikaya Gupta (email:kats@mozilla.com) 2012-07-20 08:22:00 PDT
Created attachment 644349 [details] [diff] [review]
Patch
Comment 2 Kartikaya Gupta (email:kats@mozilla.com) 2012-07-20 09:41:03 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/fb57d273902c
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-07-20 21:05:34 PDT
https://hg.mozilla.org/mozilla-central/rev/fb57d273902c
Comment 4 Kartikaya Gupta (email:kats@mozilla.com) 2012-07-23 07:09:54 PDT
Comment on attachment 644349 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 766647 (also pending aurora approval)
User impact if declined: crash may happen if a tab is closed while a thumbnail is in progress
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): mobile only, low risk.
String or UUID changes made by this patch: none
Comment 5 Alex Keybl [:akeybl] 2012-07-23 10:57:18 PDT
Comment on attachment 644349 [details] [diff] [review]
Patch

[Triage Comment]
Minusing along with bug 766647. Will be reconsidered together if this is still very desirable.
Comment 6 Kartikaya Gupta (email:kats@mozilla.com) 2012-07-25 10:54:19 PDT
Comment on attachment 644349 [details] [diff] [review]
Patch

Re-requesting aurora, is a follow-up for bug 766647.
Comment 7 Lukas Blakk [:lsblakk] use ?needinfo 2012-07-30 10:26:47 PDT
Comment on attachment 644349 [details] [diff] [review]
Patch

approving for aurora since this is needed in conjunction with bug 766647
Comment 8 Kartikaya Gupta (email:kats@mozilla.com) 2012-07-30 12:19:05 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/3028f8287bba

Note You need to log in before you can comment on or make changes to this bug.