Firefox 14 does not display the site icon when the current tab is scrolled out of view

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
7 years ago
5 years ago

People

(Reporter: fmcfix, Unassigned)

Tracking

14 Branch
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

The reason for removing the site icon from the URL bar is not valid. SSL connections can be identified by e.g. a lock icon showing a verified domain name on a yellow background.

Tab is an additional control which is not always visible to the user:
- When 'Always show the tab bar' option is not selected and a single page is open.
- The current tab can be scrolled out of view when there are multiple tabs open.

This change in Firefox 14 introduces new bugs. The site icon must be displayed in the URL bar which is always visible to the user at a predictable location -- unlike the selected tab which may even be hidden.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 748812
Reporter

Comment 2

7 years ago
This is not a duplicate of 748812. The subject says "Firefox 14 does not display the site icon in some cases" not "no favicon when the tab bar is hidden". I also dispute the "SSL" reason for removing the site icon from the URL bar.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
"no favicon when the tab bar is hidden" was one of the reasons why you want the icon back.
DAO should decide this
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Depends on: 748812
Resolution: --- → WONTFIX
Summary: Firefox 14 does not display the site icon in some cases → Firefox 14 does not display the site icon when the current tab is scrolled out of view
Reporter

Comment 4

7 years ago
What is the reason for WONTFIX? Can you present any valid arguments?
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
A tab being scrolled out of the view is an edge case that we won't bring the favicon in the location bar back for.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WONTFIX
Reporter

Comment 6

7 years ago
(In reply to Dão Gottwald [:dao] from comment #5)
> A tab being scrolled out of the view is an edge case that we won't bring the
> favicon in the location bar back for.

This is not the only problem. The reason for removing the site icon is easily proven to be wrong. There is a better solution described in this bug report.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
That design elements or also features are changed/removed or added is no bug. Those design decision are done by the designer or developer team and can be discussed in the newsgroups.
Valid are however real bugs caused by this change. You had 2 issues reported in this bug report and those 2 issues are marked wontfix.

Please do not reopen this report, thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WONTFIX
Reporter

Comment 8

7 years ago
Why should not we discuss the bugs here? The reason for removing the site icon is wrong. Either prove that it is not (the solution suggested here does not work) or stop closing this bug report as resolved.

If the user disables the 'Always show the tab bar' option to save space, why should he be prevented to see the site icon? Explain the reason why e.g. netbook users should not expect the icon to be visible?
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Comment 9

7 years ago
Because it's not a bug and because the decision was on purpose and because the developers decided that your request is a WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WONTFIX
Reporter

Comment 10

7 years ago
If the user disables the 'Always show the tab bar' option, the site icon is not visible. This is a bug.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
(In reply to fmcfix from comment #10)
> If the user disables the 'Always show the tab bar' option, the site icon is
> not visible. This is a bug.

That's bug 748812.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WONTFIX
Reporter

Comment 12

7 years ago
This is not a duplicate of 748812. The subject says "Firefox 14 does not display the site icon in some cases" not "no favicon when the tab bar is hidden". I also dispute the "SSL" reason for removing the site icon from the URL bar.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
(In reply to fmcfix from comment #12)
> This is not a duplicate of 748812.

You were however talking about bug 748812 in comment 10.

Anyway, I didn't resolve this as a duplicate but as wontfix. Please read over https://bugzilla.mozilla.org/page.cgi?id=etiquette.html and stop reopening this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WONTFIX
Reporter

Comment 14

7 years ago
If the user disables the 'Always show the tab bar' option to save space, why should he be prevented to see the site icon? Explain the reason why e.g. netbook users should not expect the icon to be visible?
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
Wontfix means that your report is valid but that it will not be fixed.
Dao already explained that the few affected users are not important enough to keep the feature.
Those affected user can install an extensions to get the favicon back.

Please read Point 2.2 of https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
Your Account will be suspended if you continue to open this bug report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WONTFIX
Reporter

Comment 16

7 years ago
How do you know that only a few users are affected by this bug?
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WONTFIX
Reporter

Comment 17

7 years ago
How do you know that only a few users are affected by this bug?
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WONTFIX
Reporter

Comment 18

7 years ago
The key question is not answered yet. Stop closing this bug as resolved.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Comment 19

7 years ago
This problem will not get FIXED, hence it is RESOLVED AS WONTFIX. Accept it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WONTFIX
Reporter

Comment 20

7 years ago
How do you know that only a few users are affected by this bug?
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
since version 29 of Firefox the UI is totaly new.
so this bug is no more valid.

for your question from 2012:
there are reports that the browser send to Mozilla if the user allow it - so they know how much users use a specific feature.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.