Last Comment Bug 776093 - "Dead" tab leads to being trapped in Panorama
: "Dead" tab leads to being trapped in Panorama
Status: RESOLVED WONTFIX
:
Product: Firefox Graveyard
Classification: Graveyard
Component: Panorama (show other bugs)
: 16 Branch
: x86 Linux
-- normal
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-20 13:54 PDT by aleth [:aleth]
Modified: 2016-04-12 14:00 PDT (History)
2 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image aleth [:aleth] 2012-07-20 13:54:13 PDT
User Agent: Mozilla/5.0 (X11; Linux i686; rv:16.0) Gecko/16.0 Firefox/16.0
Build ID: 20120720042008

Steps to reproduce:

1) Noticed one of my tabs was impossible to switch to (clicking on it had no effect)
2) Switched to Panorama mode


Actual results:

3) It was now impossible to leave Panorama mode again. Clicking on _any_ tab led to the "tab opening" animation getting about half way, then disappearing, leaving Panorama open.
4) FF completely unresponsive to Alt-F4, had to kill it from the terminal.

Possible regression - never happened in FF<16, and I only updated to FF16 today.
Comment 1 User image Virgil Dicu [:virgil] [QA] 2012-07-23 01:45:20 PDT
Was this a one-time problem? Can you reproduce this in safe mode? (Help-Restart with add-ons disabled)

If yes, please copy your error output from the error console.
Comment 2 User image aleth [:aleth] 2012-07-23 02:34:35 PDT
(In reply to Virgil Dicu [:virgil] [QA] from comment #1)
> Was this a one-time problem? Can you reproduce this in safe mode?

I don't have any STR. I also don't know if the 'real' bug is step 1 or step 3 (or both). It was a one-time problem, but dramatic enough that I thought I'd better file it, in case it happens to other people as well, as it seemed likely to be an infrequent issue.
Comment 3 User image Justin Dolske [:Dolske] 2016-02-03 16:10:53 PST
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.

Note You need to log in before you can comment on or make changes to this bug.