Last Comment Bug 776271 - Don't focus the content area when closing a places context menu
: Don't focus the content area when closing a places context menu
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 17
Assigned To: Dão Gottwald [:dao]
:
Mentors:
Depends on:
Blocks: 365171
  Show dependency treegraph
 
Reported: 2012-07-21 12:09 PDT by Dão Gottwald [:dao]
Modified: 2012-07-31 06:11 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (944 bytes, patch)
2012-07-21 12:09 PDT, Dão Gottwald [:dao]
asaf: review+
mak77: feedback+
Details | Diff | Splinter Review

Description Dão Gottwald [:dao] 2012-07-21 12:09:22 PDT
Created attachment 644667 [details] [diff] [review]
patch

This was added in bug 365171. Whereas this.focus() in buildContextMenu is gone by now, this seems to be a leftover. As far as I can tell, no special treatment is needed. Focus should just go back to where it was.
Comment 1 Marco Bonardo [::mak] 2012-07-24 06:52:47 PDT
Comment on attachment 644667 [details] [diff] [review]
patch

Review of attachment 644667 [details] [diff] [review]:
-----------------------------------------------------------------

I think this was here to update places commands on focus, though looks like it's no more needed and I think it's fine to remove it.
But since Mano originally added it, he may have some insight on the reasons.
Comment 2 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2012-07-30 08:53:17 PDT
Comment on attachment 644667 [details] [diff] [review]
patch

Indeed.
Comment 4 Ed Morley [:emorley] 2012-07-31 06:11:20 PDT
https://hg.mozilla.org/mozilla-central/rev/fadf5073473d

Note You need to log in before you can comment on or make changes to this bug.