7" tablet should have tablet-ish interface

VERIFIED FIXED in Firefox 15

Status

()

Firefox for Android
Theme and Visual Design
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: sriram, Assigned: sriram)

Tracking

15 Branch
Firefox 17
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox15 verified, firefox16 verified, fennec15+)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

6 years ago
The URL bar of 7" tablets should resemble tablets, and the tabs-tray should be a drawer instead of a sidebar.
(Assignee)

Comment 1

6 years ago
Created attachment 644710 [details] [diff] [review]
Patch (1/2): XLARGE rename

This patch makes XLARGE to be only V11+. This basically renames folders and changes makefile to reflect this.
Attachment #644710 - Flags: review?(mbrubeck)
(Assignee)

Comment 2

6 years ago
Created attachment 644711 [details] [diff] [review]
Patch (2/2): 7" tablet

This patch moves the files that are common between LARGE and XLARGE to LARGE. New XML files required for LARGE have been added.

Images that are LARGE specific have been newly added.

Note: browser_toolbar.xml and browser_toolbar_menu.xml are same f
Attachment #644711 - Flags: review?(mbrubeck)
(Assignee)

Comment 3

6 years ago
Note: browser_toolbar.xml and browser_toolbar_menu.xml are same for LARGE and XLARGE as they won't have h/w menu button.
(Assignee)

Comment 4

6 years ago
Created attachment 644715 [details] [diff] [review]
Patch (2/2): 7" tablet

Realized that hasPermanentMenuKey() was given the opposite value. Fixed that, and removed the unnecessary copies of browser_toolbar.xml and tabs_panel_toolbar.xml in LARGE and XLARGE folders.
Attachment #644715 - Flags: review?(mbrubeck)
(Assignee)

Updated

6 years ago
Attachment #644711 - Attachment is obsolete: true
Attachment #644711 - Flags: review?(mbrubeck)
Attachment #644710 - Flags: review?(mbrubeck) → review+
Comment on attachment 644715 [details] [diff] [review]
Patch (2/2): 7" tablet

Review of attachment 644715 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good!  Note: I didn't really examine the binary file additions; I assume they are copies of existing assets.  If there are any that I should look at more closely, let me know.
Attachment #644715 - Flags: review?(mbrubeck) → review+
(Assignee)

Comment 7

6 years ago
Comment on attachment 644710 [details] [diff] [review]
Patch (1/2): XLARGE rename

[Approval Request Comment]
Bug caused by (feature/regressing bug #): -
User impact if declined: pre-honeycomb tablets will have tablet ui -- though we won't support it anymore.
Testing completed (on m-c, etc.): Landed on m-i on 07/23
Risk to taking this patch (and alternatives if risky): This is just renaming of the folder names to be 11+
String or UUID changes made by this patch: None.
Attachment #644710 - Flags: approval-mozilla-beta?
Attachment #644710 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 8

6 years ago
Comment on attachment 644715 [details] [diff] [review]
Patch (2/2): 7" tablet

[Approval Request Comment]
Bug caused by (feature/regressing bug #): -
User impact if declined: 7" tablets will have phone UI.
Testing completed (on m-c, etc.): Landed in m-i on 07/23
Risk to taking this patch (and alternatives if risky): None. This is 7" tablets only.
String or UUID changes made by this patch: None.
Attachment #644715 - Flags: approval-mozilla-beta?
Attachment #644715 - Flags: approval-mozilla-aurora?
Assignee: nobody → sriram
Status: NEW → ASSIGNED
tracking-fennec: --- → 15+
status-firefox15: --- → affected
status-firefox16: --- → affected
Target Milestone: --- → Firefox 17
Version: unspecified → Firefox 15

Comment 9

6 years ago
Comment on attachment 644710 [details] [diff] [review]
Patch (1/2): XLARGE rename

[Triage Comment]
We're supporting all tablet sizes in FN15. Please land on all branches.
Attachment #644710 - Flags: approval-mozilla-beta?
Attachment #644710 - Flags: approval-mozilla-beta+
Attachment #644710 - Flags: approval-mozilla-aurora?
Attachment #644710 - Flags: approval-mozilla-aurora+

Updated

6 years ago
Attachment #644715 - Flags: approval-mozilla-beta?
Attachment #644715 - Flags: approval-mozilla-beta+
Attachment #644715 - Flags: approval-mozilla-aurora?
Attachment #644715 - Flags: approval-mozilla-aurora+
Verifying early on inbound, on my Galaxy Tab 2 7" I get the hybrid design (tablet bar/phone tab menu).

Comment 11

6 years ago
I had a play with this on the Nexus 7 - it looks good, I get the hybrid UI, and it is all pretty functional. The only issue I found (other than the tab preview issue, which I think is known) was that hit testing the menu button (with three vertical dots) is slightly off, it is more noticeable in landscape mode. When trying to hit the dots, it often mistakes this for hitting the tab dropdown, the hit test box seems to follow the box created by the bounding box of the tab dropdown, not the actual curve between the two buttons. I don't have an older nightly to test against, so not 100% sure these patches are the cause, but it is not a problem on Aurora.
https://hg.mozilla.org/mozilla-central/rev/abdc19758652
https://hg.mozilla.org/mozilla-central/rev/48077fafad8c
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
status-firefox15: affected → fixed
status-firefox16: affected → fixed
Verifying against the Galaxy Tab 2 7". More tablets for testing these changes would be nice.
Status: RESOLVED → VERIFIED
status-firefox15: fixed → verified
Verified on Galaxy Tab 2 7.0 running Android (4.0.4) on Firefox Mobile 16.0b5. Marking as verified on Firefox Mobile 16 also.
status-firefox16: fixed → verified

Updated

6 years ago
Depends on: 793480
You need to log in before you can comment on or make changes to this bug.