Closed Bug 793480 Opened 7 years ago Closed 7 years ago

Opening link in new tab greys out back button

Categories

(Firefox for Android :: General, defect)

16 Branch
ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 18
Tracking Status
firefox15 --- wontfix
firefox16 + wontfix
firefox17 + verified
firefox18 --- verified
fennec 16+ ---

People

(Reporter: ash.c.1741, Assigned: sriram)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Android; Tablet; rv:16.0) Gecko/16.0 Firefox/16.0
Build ID: 20120919064051

Steps to reproduce:

Hold down a link then select "Open link in new tab" on Asus Transformer TF300T


Actual results:

New link opens fine, current page remains in focus but page back button is greyed out and can't be used. Tapping any of the tabs, even the current one in focus, restores back button.


Expected results:

Back button should not grey out
This may be a dupe of bug 790994 wherein the issue and solution may be the same.

Can we get this tracking 16 as it's a regression?
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Ever confirmed: true
Keywords: regression
Hardware: Other → ARM
Assignee: nobody → sriram
tracking-fennec: ? → 16+
It's important for us to figure out when this regression first occurred.

Aaron - please help with a regression range, and what devices are affected.
Sriram - our final beta is going to build Monday, so if this is a new regression, investigation needs to kick off ASAP.
QA Contact: aaron.train
Duplicate of this bug: 790994
This is not new. This was introduced with the initial patches for tablet interfaces (at least for 7" tablets in my testing here via Nexus 7) via bug 776309; which landed on Aurora (16 at the time) on July 24th.
Adding 776309 as blocking (at least for 7" tablets where I can reproduce), I can't find the culprit bug for larger tablets.
Blocks: 776309
Attached patch PatchSplinter Review
(I dont know when we stopped sending "background" tab as a parameter from Gecko. Or actually did we?)
We were defaulting to disabling Back/Forward button on adding, removing tabs. This has been fixed by doing it only if its the selected tab.
Attachment #666279 - Flags: review?(mark.finkle)
Comment on attachment 666279 [details] [diff] [review]
Patch

Seems like the right thing to do. This has been like this since back when this code was in Tabs.java
Attachment #666279 - Flags: review?(mark.finkle) → review+
Status: NEW → ASSIGNED
I'll try this on inbound when it lands
(In reply to Aaron Train [:aaronmt] from comment #4)
> This is not new. This was introduced with the initial patches for tablet
> interfaces (at least for 7" tablets in my testing here via Nexus 7) via bug
> 776309; which landed on Aurora (16 at the time) on July 24th.

Given that, wontfixing for FF16. We can take this for the first time in FF17, since this doesn't meet our typical criteria for uplift.
Sriram - The risk looks very low, but can you add an approval request for aurora?
Comment on attachment 666279 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Been there for a long time.
User impact if declined: Back/Forward will be disabled unnecessarily when opening new tabs.
Testing completed (on m-c, etc.): Landed on m-i now.
Risk to taking this patch (and alternatives if risky): Low to none.
String or UUID changes made by this patch: None.
Attachment #666279 - Flags: approval-mozilla-beta?
Attachment #666279 - Flags: approval-mozilla-aurora?
removing regression window, there's a patch!
Attachment #666279 - Flags: approval-mozilla-beta?
Attachment #666279 - Flags: approval-mozilla-beta-
Attachment #666279 - Flags: approval-mozilla-aurora?
Attachment #666279 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/48724698ca34
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18
Status: RESOLVED → VERIFIED
Verified on Firefox Mobile 17.0b1 on Samsung Galaxy Tab 2 7.0 (Android 4.0.4)
You need to log in before you can comment on or make changes to this bug.