Last Comment Bug 776328 - "ASSERTION: Forgot to check if this is a wrapper?" with Components.lookupMethod
: "ASSERTION: Forgot to check if this is a wrapper?" with Components.lookupMethod
Status: RESOLVED FIXED
: assertion, regression, testcase
Product: Core
Classification: Components
Component: XPConnect (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- critical (vote)
: mozilla17
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks: 326633 774245
  Show dependency treegraph
 
Reported: 2012-07-22 00:24 PDT by Jesse Ruderman
Modified: 2014-01-10 10:42 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified


Attachments
testcase (asserts fatally when loaded) (214 bytes, text/html)
2012-07-22 00:24 PDT, Jesse Ruderman
no flags Details
stack traces (23.30 KB, text/plain)
2012-07-22 00:24 PDT, Jesse Ruderman
no flags Details
Only create holders for WNs. v1 (2.29 KB, patch)
2012-08-09 02:45 PDT, Bobby Holley (:bholley) (busy with Stylo)
mrbkap: review+
Details | Diff | Splinter Review

Description Jesse Ruderman 2012-07-22 00:24:39 PDT
Created attachment 644728 [details]
testcase (asserts fatally when loaded)

###!!! ASSERTION: Forgot to check if this is a wrapper?: 'IS_WRAPPER_CLASS(js::GetObjectClass(obj))', file ../../../dist/include/xpcpublic.h, line 70

Assertion failure: (DebugCheckWrapperClass(obj) && !js::GetReservedSlot(obj, 0).isDouble()), at /Users/jruderman/trees/mozilla-central/js/xpconnect/wrappers/XrayWrapper.cpp:440

Might be a regression from bug 774245.
Comment 1 Jesse Ruderman 2012-07-22 00:24:54 PDT
Created attachment 644729 [details]
stack traces
Comment 2 Bobby Holley (:bholley) (busy with Stylo) 2012-07-23 06:43:15 PDT
Same as bug 776333.

*** This bug has been marked as a duplicate of bug 776333 ***
Comment 3 Jesse Ruderman 2012-08-01 17:48:13 PDT
This testcase still asserts for me.
Comment 4 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-08 09:12:20 PDT
Testcase still asserts even though bug 776333 is now resolved, so what's the impact here of this assert being tripped?  How does this manifest?  What's the ramification for the end user?  Trying to get a sense of the importance for tracking here.
Comment 5 Bobby Holley (:bholley) (busy with Stylo) 2012-08-09 02:45:26 PDT
Created attachment 650481 [details] [diff] [review]
Only create holders for WNs. v1

Fixed a stupid mistake. Flagging Blake for review.
Comment 6 Bobby Holley (:bholley) (busy with Stylo) 2012-08-09 02:46:47 PDT
(In reply to Lukas Blakk [:lsblakk] from comment #4)
> Testcase still asserts even though bug 776333 is now resolved, so what's the
> impact here of this assert being tripped?  How does this manifest?  What's
> the ramification for the end user?  Trying to get a sense of the importance
> for tracking here.

We should track. Simple fix, and potential crashes etc if left unfixed.
Comment 7 Bobby Holley (:bholley) (busy with Stylo) 2012-08-10 01:21:19 PDT
Pushed to m-i:

https://hg.mozilla.org/integration/mozilla-inbound/rev/4e0f55796e6f

(this is very low risk for bustage, so I don't think it's worth the try resources to do a push there)
Comment 8 Ryan VanderMeulen [:RyanVM] 2012-08-11 19:57:37 PDT
https://hg.mozilla.org/mozilla-central/rev/4e0f55796e6f
Comment 9 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-15 13:56:37 PDT
Already fixed, setting status & tracking for completeness in case there's fallout later for any reason.
Comment 10 Mihaela Velimiroviciu (:mihaelav) 2012-10-19 08:27:08 PDT
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:17.0) Gecko/17.0 Firefox/17.0

Verified the fix with the latest beta-debug build (id 20121017141413) on Mac OS X 10.7.5 and doesn't assert anymore.
Marking verified for Firefox 17.
Comment 11 Tracy Walker [:tracy] 2014-01-10 10:42:24 PST
mass remove verifyme requests greater than 4 months old

Note You need to log in before you can comment on or make changes to this bug.